7 Replies Latest reply on Jul 10, 2011 5:09 AM by koitsu

    Intel SSD with ICH9 controllers

    tbarkan

      Hi,

       

      I have an ASUS P5KC motherboard with P35 ICH9 chipset.

       

      I previously bought an SSD drive from another vendor, and it wouldn't work well.

      Once every day or two I would find my computer in a "Please enter bootable media" mode, and the BIOS would not detect the SSD drive, until I physically powered off the PC and turned it back on (CTRL-ALT-DEL wouldn't do it).

       

      After some conversations with the product's support I was told that ICH9 is an old controller that didn't work well with SSD.

      I wanted to know if intel drives suffer from the same (or other) problems with these older controllers before I purchase a new intel drive to replace my old one.

       

      Does anyone use an intel drive with ASUS P5K motherboards that can say for certain? Anyone use P5KC specifically?

       

      Thanks.

       

      EDIT: Specifically I'm interested in the 510 SSD, 120GB (I know my mobo is not SATA3, but I'll upgrade it at some point...)

        • 1. Re: Intel SSD with ICH9 controllers

          Hi, I have Asus P5Q3 mobo and Intel 510 120 GB and everything works OK- no boot problems or something like this. Your problems could be caused by old BIOS of your ICH9 controller, as far as I know it should be at least equal to 8.xx or bigger, earlier versions have some problems with SSD drives.

          And my Pioneer DVD-writer blocked my Windows boot process after adding the SSD drive to the system. Solution: move the DVD drive to Marvell controller.

          • 2. Re: Intel SSD with ICH9 controllers

            Hi,

             

            Thanks for the advice.

             

            I have the latest official BIOS (1203), how would I know what version of ICH9 BIOS I have?

            Is there a way to separately update the ICH9 BIOS or would I have to find a custom BIOS that includes a newer version of ICH9 within it?

            Would you happen to know where I could find one if needed?

            .

            • 3. Re: Intel SSD with ICH9 controllers
              koitsu

              After some conversations with the product's support I was told that ICH9 is an old controller that didn't work well with SSD.

               

              Utter and complete nonsense.  ICH9 series southbridge are used in enterprise-grade servers and work fine with SSDs; the same goes for the ESB2 series southbridge and the ICH7 series southbridge (even older than the ICH9!).  If you want proof of this I can provide it.  Was this told to you by Asus technical support?  If so, they seem to have employed some morons as of late.

              • 4. Re: Intel SSD with ICH9 controllers
                tbarkan

                Actually it was OCZ support.

                 

                Could it be a problem with the older BIOS version of the ICH9 (and can it be fixed?), or should I just ask for RMA?

                 

                Thanks!

                • 5. Re: Intel SSD with ICH9 controllers
                  koitsu

                  OCZ has no idea what they're talking about.  Furthermore, an option ROM (what you call "BIOS", sometimes called "firmware") upgrade won't necessarily solve something that isn't the fault of the option ROM firmware to begin with.  Unless OCZ can put their money where their mouth is and actually describe in full, low-level technical detail, what the problem is that an upgraded ICH9 option ROM fixes, then it's complete nonsense.

                   

                  Speaking generally about option ROM upgrades -- on consumer-grade boards, any option ROM upgrades usually are packaged with a PC system BIOS upgrade.  Understand that they're two separate things, its just that the option ROM code happens to live in the same flash chip as the PC system BIOS.  There is absolutely no way to determine if the option ROM has been upgraded (or what version is in use) unless the option ROM chooses to disclose that information when it loads (then you compare versions before and after), OR, if the motherboard manufacturer discloses it in a BIOS changelog (~90% of the time they do not; Intel is one of the very few companies who keeps top-notch BIOS changelogs for their motherboards).  For example, on my Asus P5Q SE board, the option ROM (driven by a ICH10D0 controller) doesn't display anything -- Asus chose to hide the text output.

                   

                  So basically what I'm saying here is that another person on this forum has gotten you all spun up about "upgrading your option ROM to fix the problem", yet there is absolutely no hard technical evidence showing there is a problem.  Think about it for a minute: if there was a problem with AHCI support on the ICH9 series controllers, don't you think the issues would be extremely wide-spread given how many consumer-grade AND enterprise-grade motherboards use that model of southbridge?

                   

                  The problem Roman describes in his post is unrelated to yours.  His problem stems from a DVD drive that does not work correctly with AHCI.  This is extremely common.  His solution, rather than to change the controller operation mode from AHCI to Enhanced or IDE or Compatible, was to use a second on-board controller (Marvell) to manage/drive his DVD drive.  Many, *many* SATA controllers that support AHCI do not work properly with ATAPI devices (CD drives, DVD drives, etc.).  Again: separate issue, unrelated to yours.

                   

                  The problem you describe in your original post is pretty common.  The problem itself stems from either a PC BIOS bug (NOT an option ROM bug!) with regards to reading LBA 0 from attached devices (read: finding the boot block and partition table to find out what's active), OR, a drive (SSD, mechanical HDD, it doesn't matter which) that isn't fully ready for I/O commands before the PC BIOS submits reads requests (in attempt to boot).  The most common workaround for this problem is to set in your PC BIOS a delay of 3-5 seconds before actually attempting the boot itself; yes, this slows down your boot process, but it gives the drives time to initialise before the BIOS tries to read from them.  Some PC BIOSes don't offer the configuration setting I describe, in which case there's really nothing you can do other than talk to your motherboard manufacturer (Asus) about the problem.

                   

                  I would strongly suggest at this point in time that you talk to Asus Technical Support about this problem.

                  • 6. Re: Intel SSD with ICH9 controllers
                    tbarkan

                    Koitsu, what you're saying makes sense to me.

                    One of the reasons I started this post was to hear if people with intel drives are indeed free of these troubles, but so far I haven't found anyone here or in the ASUS forums that uses P5KC motherboard with an SSD drive.

                     

                    My main problem is not that my drive can't be found on boot, the main issue that my PC reboots by itself, probably since it loses connection to the drive containing the OS. I never see this happen, for some strange reason it only happens when I'm away (already tried disabling all power saving modes...)

                     

                    I've read in several forums already that older (6.5 and older) versions of the option ROMs for the ICH9 controller can cause these sorts of problem, so I'm fishing for either a way to upgrade that, or for someone that can tell me that he has an older ICH9 ROM and it's working fine with an intel SSD, so I can RMA my OCZ drive and purchase an intel drive instead. So far the only person I found with a P5KC and an SSD drive had the same issue I did, and solved it by buying a PCIe SATA 3 card, but this guy also had OCZ so it could be a problem with OCZ only.

                    • 7. Re: Intel SSD with ICH9 controllers
                      koitsu

                      The first question is: is the machine actually rebooting (as in an abrupt, hard reset?) or is it blue-screening and auto-rebooting (a sign that a device driver is crashing)?  The reason I ask is this: there's a known problem with Intel MatrixRAID drivers for Windows (read: these are the older versions of Intel's drivers) where some devices (regardless of type, meaning SSD or MHDD) can drop off the bus randomly, resulting in problems.  Intel's RST (Rapid Storage Technology) relieve this problem.

                       

                      If the SSD is your OS drive, I guess it's going to be difficult for you to determine if the machine is hard rebooting, since the drive could be falling off the SATA bus -- in which case a kernel crash (minidump) or an event log entry won't be written.  To worka round this, I would recommend you turn off the auto-reboot functionality of Windows on a driver crash (the machine won't reboot in that case, it'll just sit there indefinitely at a blue screen).  I'm not sure where the option lives on Vista or Windows 7, but in XP it's under System, Advanced tab, Startup and Recovery section "Settings" button, System failure section, checkbox "Automatically restart".

                       

                      If the problem happens with auto-reboot-on-panic turned off, then this would indicate some kind of hardware problem with the motherboard or a PSU issue (possibly a combination of the two).  I cease to see how this could be an option ROM problem though; the option ROM can't reboot the system.  It's more likely this is some kind of motherboard defect; there's literally nothing an SSD can do that would cause an entire system to lose power/reset.  Sometimes a full system reinstall can solve weird sporadic reboot issues though; take a look at these two entries on my blog [1] [2] for an example.

                       

                      If you're absolutely hell-bent on trying to get a newer version of the option ROM firmware, then you have only one choice: talk to Asus.  The way you upgrade the option ROM is through a PC BIOS upgrade (honest); a PC BIOS file contains the option ROM firmware, since the flash chip used to store the PC BIOS is also used to store the option ROM firmware.  If Asus tells you there isn't any newer version of the option ROM firmware, then your choices should become clear: you can try replacing the OCZ SSD with a different brand (doesn't have to be Intel), or you can try replacing the motherboard with a different model.  My opinion of OCZ is extremely low so I'm obviously biased, except I'm not an "Intel fanboy" either -- I just really do not like it when supposed "technical support" gurus tell customers things like "the problem is {insert made-up nonsensical excuse here}".  OCZ happens to have a pretty high SSD failure rate to boot (you don't need to read French to understand the numbers).

                      1 of 1 people found this helpful