12 Replies Latest reply on Feb 18, 2012 8:05 AM by guanglier

    D945GSEJT powers on but no display - HELP!

    McBest

      Hi All,

       

      This is my first PC building experience and it's halted at the first hurdle!

       

      I have a D945GSEJT board but can't get it to display anything on the monitor. I've tried 5 different LCD & TFT monitors with no joy.

       

      The power LED comes on, HDD spins up, fan powers on, USB devices light up when power switched on - all seems fine with the board but no display!

       

      When I remove the single stick of 2GB RAM, I get 3 flashes / bleeps as expected but when RAM is re-installed, no errors and no display.

       

      Any ideas?

       

      I'm going nuts here!!!

       

      Thanks,

       

      Jeff

        • 1. Re: D945GSEJT powers on but no display - HELP!
          McBest

          Hi All,

           

          Any suggestions, please?

           

          In addition to the above, I found that when I connect a SATA DVD-ROM drive, the motherboard LED comes on as normal but when I press the switch to turn the system on, the light goes out. I bought a power cord with output 12V 3.5A which should be fine even up to full load.

           

          I disconnected the CMOS battery overnight but that made no difference. I tried putting the board in all 3 jumper states (normal, configure & restore) but again, no difference.

           

          How do I get the system to display something on the monitor?

           

          Thanks,

           

          Jeff

          • 2. Re: D945GSEJT powers on but no display - HELP!
            McBest

            Everybody stumped?

            • 3. Re: D945GSEJT powers on but no display - HELP!
              McBest

              Hi All,

               

              I now have a 2nd new D945GSEJT motherboard and have the exact same problem.

               

              Can anyone suggest a reason why 2 new motherboards won't display on a standard monitor?

               

              Thanks,

               

              Jeff

              • 4. Re: D945GSEJT powers on but no display - HELP!
                mechbob

                Have you tried putting in your OS disk and than restart.

                • 5. Re: D945GSEJT powers on but no display - HELP!
                  McBest

                  Hi Robert and other readers,

                   

                  I've tried a USB stick with the .BIO file and I've tried a bootable USB stick with dos files and also a Ubuntu bootable image but still nothing.

                   

                  I've been onto Intel support and they asked me to try the BIOS update via USB stick and also clearing CMOS battery and moving jumpers to configure mode and without jumpers connected - no joy.

                   

                  I'm told that with the minimum components i.e. RAM with monitor and power supply connected, I should get something on screen but I don't.

                   

                  I can't get a CD drive to work on the board either. When I connect a SATA optical drive and switch the board on, the power led on the board goes out and I need to power off and on again.

                   

                  The 2 PSU that I have purchased are at the upper limits for the board - 12V 3.5A 42W and 12V 5A 60W.

                   

                  I'm sure the board is not faulty but I just don't know what else to try!

                   

                  I guess Intel will offer a replacement but I am on my 2nd board already and I'm pretty sure the next board will have the same issue.

                   

                  Regards,

                   

                  Jeff

                  • 6. Re: D945GSEJT powers on but no display - HELP!
                    hcon

                    I have the same problem.   Nothing from the display on a new board, either on the VGA or DVI outputs.

                    If I disconnect my RAM module I get three short beeps on the speaker which shows there is some life there.

                     

                    This thread seems to document similiar symptoms  - however the contributors fixed their problems by trying different monitors, or else a bios update.

                     

                    http://communities.intel.com/thread/8985?wapkw=%28d945GSEJT+no+boot%29

                     

                    If you can , it seems worth trying some different monitors.

                     

                    I have tried the bios recovery procedure using the latest bios update - but there seems to be no attempt to read the CD. After waiting five minutes anyway, I powered off - replaced the bios config jumper , and powered on again - but ( not surprisingly as the CD was not even read ) found nothing changed.

                     

                    I have also tried to power on with a tested bootable CD ( ubuntu )  - but again there is no attempt to even read the CD.

                     

                    Unfortunately I "only" have 2 monitors to hand to test with - and Acer and a Philips.

                     

                    I will post back if I find anything else.

                     

                    Grateful for any suggestions

                    • 7. Re: D945GSEJT powers on but no display - HELP!
                      McBest

                      Hi,

                       

                      I discovered that I had been too careful inserting the RAM and that a good firm push right into the slot before locking down with the side clips did the trick!

                       

                      So many hours wasted yet so simple a problem! Very embarassing!

                       

                      I was getting blank screen when RAM was in and 3 beeps when RAM was out so I hope this sorts your problem!

                       

                      Let me know!

                       

                      Best regards,

                       

                      Jeff

                      • 8. Re: D945GSEJT powers on but no display - HELP!
                        hcon

                        Hi Jeff

                         

                        That was it!

                         

                        Many thanks for the pointer!

                         

                        Best regards

                         

                        Steve

                        • 9. Re: D945GSEJT powers on but no display - HELP!
                          McBest

                          I'm delighted for you!

                           

                          Honestly, I spent weeks checking everything, suspecting everything and all along it was my own stupid fault!

                           

                          Glad I'm not the only one though!

                           

                          Enjoy your new system!

                           

                          Jeff

                          • 10. Re: D945GSEJT powers on but no display - HELP!
                            hcon

                            Those memory sockets are *very* tight fitting ( in our defence ).   I wasn't happy with the way the memory went in, but , I didn't dare to push any harder.

                            And with the POST indicating the memory was fitted  , I think we needn't be too embarassed!  I built up an ASUS ITX a few days before and there was no question that the memory modules were fitted correctly or not.  Excuses..excuses ;0)

                             

                            Thanks again!

                             

                            Steve

                            • 11. Re: D945GSEJT powers on but no display - HELP!
                              ganesan_iid

                              Hi,

                               

                               

                              You can see that blinking cursor on left top of the screen after the intel logo shown.

                               

                              Problam is your Processor. try to change processor.

                              • 12. Re: D945GSEJT powers on but no display - HELP!
                                guanglier

                                Hi !

                                 

                                i got the same problem.... but without RAM no life sign !!

                                i specially bought stable 12V power supply, had a fan etc....

                                here is my story :

                                 

                                1 : works well for almost 1 year

                                2 : then sometimes doesn't boot, but pressing on reset makes the board to boot up and all ok.

                                3 : one day doesn't boot at all, pressing reset doesn't change anything.

                                 

                                 

                                i tried :

                                - laboratory stabilized power supply and see the current: never above 0.9Amp (normally 1.9 to 1A during tests i made when i bought the board)

                                - buzzer connected : never a bip

                                - LEDs : no ligth for HDD & PWR but standby always ok on the board

                                - i disconnected the RAM : no beeps no light ...

                                - always two screen connected for the tests

                                - i changed the cmos battery, checked the voltage (3.2V)

                                - changed the jumper for bios configuration : no effects

                                 

                                there is no way for me to get this board work again

                                 

                                i checked all voltage at all capacitors of the board with my scope, all seems ok, voltages and ripple

                                +5V +12V +3.3V  +1.9V  +0.9V

                                I also checked the calendar crystal at 32Khz : ok with the scope, even when power disconnected (battery ok)

                                 

                                I build pcs for almost 22 years since i were young. never had a problem so hard with motherboard.

                                i never bought Intel, this was the first time. Regarding the many problems, this was also the last.