2 Replies Latest reply on Jul 4, 2011 10:37 PM by sage99

    TCP packet forwarding issue in router

    dhanya

      Hi all,

       

      I have an issue.

      I have a router with 3 LAN and 1 WAN port.

      I connected one pc to the LAN port and an another PC to the WAN port.

      And tried to ping.I was able to ping the 2 PC's.

      But the problem is when i tried to send some data ,server is immediately closing the connection.When i analysed using ip_conntrack tool i can see the paramater LAST_ACK send by the server.

      That is  data transfering is not happening.

      How can i solve the issue.

      Any help is appreciated

       

      With Regards,

      Dhan

        • 1. Re: TCP packet forwarding issue in router
          sage99

          Hi Dhanya, how about connecting your server to the LAN ports and test the file transfer? this is to isolate the possible restriction of the router on the WAN port.

          • 2. Re: TCP packet forwarding issue in router
            dhanya

            Hi sage,

             

            Thanks for your quick response.

             

             

            My router is having 4 ports.3 are LAN ports and one WAN port.

            I connected one PC to the LAN port 1 using an ethernet cable and one PC to WAN port using an ethernet cable.

            I assigned a static IP address to PC connected to the WAN port.

            Network settings in PC connected to WAN port are the follo.

                      IP address  192.168.2.235

                       Subnet mask 255.255.255.0

                      Default gateway 192.168.2.1

            PC connected to the LAN port will get an IP address 192.168.1.33

            Router IP address is 192.168.1.1

            Ethernet as WAN IP address and remote IP address is 192.168.2.1

             

            Testing Set Up 1:(Sending UDP packets):

             

            Server side(PC connected to LAN port):

             

            i run the application iperf -s -u

             

            Client Side(PC connected to WAN port)

             

            iperf -u -c 192.168.1.33

             

            Result:UDP packets are receiving at the client side.

             

            Testing Set up 2:(For sending TCP packets)

             

            Server Side:

            iperf -s

             

            Clien Side

            iperf -c 192.168.1.33

             

            Result:

             

            TCP packets not receiving at the server side.

            When i analysed using ip_conntrack tool connection is establishing but server is sending LAST_ACK.

             

            My aim is to send some TCP packets or video from WAN to LAN.

             

            Any help is appreciated.