1 Reply Latest reply on Jul 7, 2011 8:20 PM by

    SSD Toolbox not working with x25M G2 - need technical help

    SADyer

      I recently upgraded my computer & added a new 320 series SSD as the Boot/OS drive. I'm trying to Secure Erase & Optimize my old x25M G2 - but the toolbox will not let me.

       

      Intel SSDSA2M080G2GC:

      Intel SSD Optimizer - This tool is not supported on the selected drive.

      Secure Erase - This tool cannot be run on a bootable SSD or SSD with partition

       

      I think the core problem might be that this drive used to be my OS drive & had a hidden boot partition (created as part of the Win 7 install).  I've tried deleting all partitions & the volume in Win 7 (64).  I've tried deleting all partitions using EASUS Partition Master.  The drive is not recognized without a volume - but with a simple volume formatted (only showing one) I still get the original errors.

       

      I've even tried hotswapping the drive with the toolbox running - but that doesn't seem to work either.

       

      Searched all over the internet & other forums, but no solution as yet - very frustrated at this point.

       

      Could this be a BIOS / Mobo problem?

       

      Any ideas/suggestions appreciated!

       

      SYS:

      Asus P8Z68-VPro

      Intel Core i5 2500K

      Win 7 (64) running on new 320 Series 80 Gb SSD

        • 1. Re: SSD Toolbox not working with x25M G2 - need technical help

          After a confab with the good folks at Intel, the problem is solved.

           

          Basically I just ran Diskpart under the DOS shell provided in my Win 7 Disk. The other problem may have been related to which SATA controllers were talking to the SSD's.

           

          In case anyone else runs into this issue, here's what to do: (Caveat - follow these instructions at your own risk!) [Written for those at my tech level or below...]

           

          - Turn your computer off & unplug it.

          - Disconnect all drives except the one you want to Secure Erase (leave your DVD player connected)

          - plug it back in, turn on & insert the Win 7 disk.

          - Boot from the Windows* installer CD, allow it to load the files, and get to the part where it asks you to choose the time and language.

          - At this part press Shift-F10 this will load a DOS environment.

          - Type:

          CD..

          diskpart

          List disk

          Select disk # (no # sign just the number of the disk you wish to clean)

          clean all

          - wait.

           

          - keep waiting

           

          - (even with an SSD clean all under DiskPart takes a while)

           

          - When it is finally finished (+/- 20 minutes... ) turn your computer off, unplug & reconnect all your drives, plug it back up & boot normally.

           

          - note: make sure your SSD drives are connected to an intel controlled SATA port - not, for instance, a Marvell or JMicron controlled port (not saying these are a problem per-se - but I don't think the Intel SSD Toolbox likes to work with them... or, put another way, Intel likes Intel.)

           

          Once you're back in Windows

           

          - Right click on 'Computer' (under Start) & select 'Manage'

           

          - left click on 'Disk Management'

           

          - Assign the wiped drive a letter (give it a simple volume) (right click the drive & choose)

           

          - Exit Computer Management & run the SSD Toolbox.

           

           

           

          Everything should be functional...