3 Replies Latest reply on Jun 25, 2011 7:58 AM by CIBSS

    Error code 139

    CIBSS

      Hallo,

       

      if I running my private application on MARC012 machine, I become Error Code 139 by executing.

      The application is compiled with GORY flag for using of  dynamical memory allocation.

      Same problem I have by running of example application SHIFT.

       

      In the error description is a proposal for this error case a square number of cores to use up to 36.

      But my problem does not solve!

       

      What wrong do I make?

       

      Thanks

        • 1. Re: Error code 139
          aprell

          Error code 139 stands for segmentation fault, which means there is an invalid memory access somewhere in the program. Have you tried to debug it?

          1 of 1 people found this helpful
          • 2. Re: Error code 139
            tedk

            Yes, error code 139 indicates a seg fault.I went on one of our internal systems and ran shift without any problem. I attached my output.

             

            I ran it as

            rccerun -nue 36 -f rc.hosts cshift 10

             

            I built RCCE with icc as

            PLATFORMFLAGS=$(BMFLAG) -DSCC -DSHMADD -static -mcpu=pentium -gcc-version=340 -I../include

            I built cshift as

            make API=gory cshift

             

            If you are still seeing this seq faul, can you post how you built RCCE, how you built SHIft and attach the executable that casues the fault?

            • 3. Re: Error code 139
              CIBSS

              Hello!

               

              Thanks for your assistance. Code runs now without problems. I believe that my error was with compiler flag -DGORY. I added it manually behind of -DSCC flag directly in symbols and don't use option API=gory with make.

               

              Best regards