2 Replies Latest reply on Sep 3, 2011 4:19 PM by amb

    D510MO won't boot from SATA with RAID card installed

    gohanman

      I have a D510MO with one HDD attached to the board and three additional HDDs attached to a SIL3114 PCI RAID card. If I try to boot from the drive that's attached to the board, it just hangs with a single blinking cursor in the upper left hand corner of the screen. If I pull the RAID card, booting from the SATA attached drive works.

       

      * I tried flashing the BIOS to 0516 and that makes no difference.

       

      * If I go into BIOS setup, all four drives are visible with no obvious sign of problems. The boot order menu does have an odd entry. It goes: HDD (the attached one), Legacy PCI device, HDD2, HDD3, HDD4. I'm not sure why legacy PCI gets its own entry that I can move around in the boot order independent of the drives attached to it.

       

      * If I stick the RAID card in a spare machine, it works perfectly fine.

       

      * If I boot the D510MO machine off a USB key (happens to be Fedora), all four HDDs function just fine.

       

      Is there any non-obvious BIOS setting I can tweak here? It doesn't seem like anything's actually wrong with the RAID card. Also, every replacement PCI, 4xSATA card I look at seems to be the same chipset anyway.

        • 1. Re: D510MO won't boot from SATA with RAID card installed

          I have the same problem with a Dawicontrol DC-3410 (SIL3124-2). Two drives are attached to the onboard SATA ports.

          If the RAID controller is inserted but no drives are plugged into it it boots fine, but connecting drives to the RAID controller prevents the machine from booting, although all drives (from the onboard controller and the ones attached to the DC-3410) are detected and listed in the D510MO BIOS boot order list. The only solution I found was disabling the RAID controller BIOS (by removing a jumper on the DC-3410 and therefore preventing the D510MO BIOS from seeing the drives) and booting from the internal SATA controller. The drives are later discovered by the linux kernel. Unfortunately the machine freezes after a while when the DC-3410 is connected, which I suspect it's the board's fault.

          • 2. Re: D510MO won't boot from SATA with RAID card installed
            amb

            I am experiencing the same problem, with openSUSE 11.4 Linux 64-bit.

            I flashed the D510MO motherboard to the latest BIOS (v5.42) and it  does not fix the issue. My boot drive is connected to the motherboard's SATA connector.  The RAID card I am using is an Addonics  ADSA4R-E (4-port PCI-eSATA) with the Silicon Image SiI3114 chip, connected to an external disk array box with four SATA disks drives.

            If the external disk array is connected and powered up when the system  boots, it will get past the POST and the disk drives will appear in the  eSATA BIOS list, but then it will hang when loading the grub bootloader.  If there are no drives connected to the RAID card (or if the disk array box is powered off), the system would boot fine.

            The Addonics card has worked perfectly on other motherboards, so it's not the problem.

             

            A BIOS bug on the D510MO?

             

            This issue has also come up in another forum:

            http://www.tomshardware.com/forum/280392-31-intel-d510mo-si3114-sata-hardlocks