6 Replies Latest reply on Jul 17, 2013 1:58 AM by yf38

    DH67CL Bios Update problem

    Mourani

      hi:

       

      i cant upgrade the bios

       

      my board version is 0076

       

      i have windows 7 x64. when i try the Express BIOS Update. version 0105 & 0110 The PC restart normally without flashing and the express installer says the bios updated successfully. but when i go to the bios its still the same version 0076.

       

       

      when i tried Express Bios Update version 0119. The pc restarted without flashing and the express intaller says the bios did not successfully update.

       

       

      when i tried iflash bios update :

       

      by typing iflash2 /s it shows that the last update was successful\

       

      by typing iflash2 /p bl0119p.bio

       

      the pc restarts and no flashing is done. still same version 0076.

       

      by typing iflash2 /i

       

      iflash2 version 2.4 - build 064

      Port mapper table located at : F000:C940

      Currently installed BIOSID : BLH6710H.86A.0076.2010.1115.1959

      This Bios supports Flash update Method 05h

       

       

      any help ????

        • 1. Re: DH67CL Bios Update problem
          mechbob

          If you are using the express BIOS , Turn OFF all the security software and I mean everything , try again

          • 2. Re: DH67CL Bios Update problem
            yf38

            Hi,

            The simplest and probably the more reliable is to use  F7 flash update.

            You have to go to the bios menu and enable display F7 bios update proposal (at the same place as for F2 and F10).

            Then you copy the file  BL0119P.BIO to an USB key (preferably the root and not to much files on it).

            Then you stop and restart the system and press F7 when proposed.

            The bios is then updated (after you allow the file choice) with all the steps of the process displaying at the screen (it takes 2 to 3mn).

            After a success message  the system restarts itself (two times).

            I suggest also to go to the bios after that and set the standard default values before setting again your own, because I observed bad values reported by IDU not doing this (at bios 105 to bios 110 upgrade).

            • 3. Re: DH67CL Bios Update problem

              thx for the help

               

              i had to enable the F7 function from bios first to appear on boot. and it did the trick.

               

               

               

              thx for the help much appreciated

              • 4. Re: DH67CL Bios Update problem
                miker

                I had the same issue updating my DH67GD motherboard with using the boot to USB stick approach with IFLASH2 and BL0160.bio.  Indicated it was successful, yet IFLASH2 /i also showed the previous version:

                Currently installed BIOSID : BLH6710H.86A.0076.2010.1115.1959.  Are you saying that if I enable F7 function, it will work?

                • 5. Re: DH67CL Bios Update problem
                  miker

                  Tried the F7 update approach.  It seemed to work (per the on screen message), but now the board fails to boot; can't get into bios settings.  Any thoughts?

                  • 6. Re: DH67CL Bios Update problem
                    yf38

                    With  DH67GD I allways used F7 to update bios,  up to bios 132 and it's OK.

                    To reach the bios try first to hit F2 at high rate after power on, or place the bios configuration jumper on the board in the  "configuration" position instead of "normal" (have a look at the quick ref. paper in the box).

                    The boot failing maybe related to bad disk Controler setting.