1 Reply Latest reply: Jun 5, 2011 8:32 AM by cygnus RSS

Solved (in a way): DH57DD + Palit Geforce GTX 550 Ti

cygnus Community Member
Currently Being Moderated

Solution: after a lot of experimenting i found a BIOS downgrade from release 656 to 625 solved my problems for the moment - seems something in the 656 BIOS doesn't like Geforce GTXs...

 

anyway, i hope this doesn't bite me later, but for now i enjoy the new pixelpower...

 

Hi there fellow Intel users,

 

i have a little problem with my DH57DD board since i tried to replace the graphics card. The situation is like this: i originally started my current rig with an i3 530 cpu, 4 gigs of ram, a 550W bequiet PSU, single hdd and single optical drive.

 

The first graphics card i installed was a Geforce GTS250 which worked awesome for the time i had the rig (works like a charm at the moment again). Now i tried to replace the card with a Geforce GTX 550 Ti, that's when my problems started. The system boots fine (no missing video card beeps, fan on graphics card runs, onboard video gets switched off) when the 550 is installed but the problem is that i can't get video from any of the three graphics ports of the card. No video means exactly what i say: no bootsplash, no bios when i press f2, no windows userinterface...

 

Tested the card in a different pc where it works so it's definately not the card that's damaged or anything. Even when i tested a bigger powersupply (shouldn't be needed as the GTX 550 Ti draws even less power than the GTS250 does) it did not change the situation.

 

Currently running out of ideas here, even patched the board's BIOS to the latest release - didn't help. Has anyone else experienced something like this or any pointers what more i could try to get this card to work in my pc?

More Like This

  • Retrieving data ...