10 Replies Latest reply on Jan 12, 2012 9:57 AM by

    RMM3 & S3420GPLX


      bios 47; BMC FW Rev :01.23; SDR Package 0.18

      when in web interface launch console appears: Socket Error "Error opening video socket"
      (KVM remote console not starting)

        • 1. Re: RMM3 & S3420GPLX

          We are in the same boat. Up to date server setup.

          RMM3 worked while plugged into the shop during server build, took it on site and now we are getting the error.

          UPDATE: S3420GPRX + RMM3LITE.


          UPDATE 2011-06-07: Phoned into tech support. They had me remove the RMM, pull the battery, and hold the power button to reset the BIOS. From there I was to boot the server into the BIOS and change the settings then boot the server into the OS without the RMM. The BMC was supposed to reset.


          After booting into the BIOS with the RMM removed and making the necessary settings changes, after saving the BIOS settings the server reset itself and hung on a black screen. Nothing we did on our own or with Intel support brought the board back. An RMA board is on the way.


          UPDATE 2011-06-14: After replacing the board, transferring the existing RMM3LITE, updating the firmware, and getting things connected on-site we ended up with the same Video Socket error.


          We ran through the BMC reset process using the SYSCFG utility. That failed.


          We were not willing to risk killing the server board to run through the reset method we attempted before. We will wait for a server board update that will hopefully fix the problem.


          We just tested two different RMM3 deploys with different BMC firmware levels using both Internet Explorer and FireFox 3.x with all methods producing the same error.

          • 2. Re: RMM3 & S3420GPLX
            Jason Tan

            Intel is aware of the issue around the KVM socket error, my understanding is that a fix is being planned to be released in the next BMC firmware revision. When it is available, I will communicate it to this thread.


            In the meantime, resetting the BMC is needed to recover from this failure, you can use syscfg utility to perform a reset. Also, make sure that when you do update the BMC firmware that you update it w/ the RMM3 installed. 

            • 3. Re: RMM3 & S3420GPLX

              If Intel is aware of the issue, then why did the tech I spoke with not tell me to get the SysConfig utility and use it to reset the RMM3/BMC?


              Perhaps a flag of some sort in tech support's PSA would be a good idea?



              • 4. Re: RMM3 & S3420GPLX
                Jason Tan

                Philip, thanks for the feedback, I will comunicate this back to tech support.

                • 5. Re: RMM3 & S3420GPLX



                  Did you hear back on a date for this fix?





                  • 6. Re: RMM3 & S3420GPLX

                    No apparent fix in the works.


                    It seems that this problem has been around for a while.


                    What we have seen though is that if left alone the RMM3 eventually starts to allow KVM connections. What I am not sure of is whether it was because of a Java update or something within the RMM itself reset.



                    • 7. Re: RMM3 & S3420GPLX
                      Jason Tan

                      Hello, the firmware has been release publicly, please check the S3420GP download site.


                      As for the other systems, the firmware should be available on their respective download sites.






                      Hopefully this fixes the issue.

                      • 8. Re: RMM3 & S3420GPLX

                        Thanks, this is great. Ill try this.

                        • 9. Re: RMM3 & S3420GPLX

                          I had this problem, updated from 01.23 to 01.24 and it solved the problem for a short duration of time.


                          Unfortunately it's back again. Has anyone found a reliable, long term solution.

                          • 10. Re: RMM3 & S3420GPLX

                            Upgrading to the latest firmware and using Chrome on OSX 10.6 seems to work for me (I am on Mac).

                            I have tried with Safari 5.1.2, Firefox 9…


                            With Chrome, I have been able to remotely access the RMM module !


                            Don't know yet if I can access anything else (like BIOS settings at startup).


                            But for the moment this is already ok !

                            I'll try to confirm If I can access It again tomorow.


                            My target OS is FreeBSD 9.