13 Replies Latest reply on Jan 10, 2014 5:52 AM by allan_intel

    D525mw - Hangs on boot with USB devices attached

    PowersL

      Hi All,

       

      I'm using the Intel D525mw Atom motherboard and have discovered these problems

       

      1) When I connect an external bootable devices like an DVD Drive or a USB memory stick, the PC will hang on the BIOS screen showing code 5A in the right hand corner.  If I then power off and on the PC, it will normally work and boot ok from the internal hdd.

       

      2) Another similar problem is that if I have a bootable USB memory drive, the PC won't recognise it and so it doesn't appear in the BIOS boot devices.  Even if I press F10, it just shows the internal HDD.  If I power off and on and hit F10, it will eventually appear.  I have tried differernt vendors of USB drives as well.

       

      3) Even though I have configured the PC to boot to the local HDD first, if a bootable USB drive is inserted, it sometimes (not always) will boot to that first.  This tends to happen when I'm installing Windows Home Server 2011.  It starts ok from USB drive like I've requested.  But once the server wants to reboot to continue the install, it just carries on booting from USB.

       

      All of the above problems can be solved by either warm booting or cold booting the PC.  It's intermittent for sure but easy to replicate.

       

      It's quite annoying as I'm a small system builder who has decided to start using these motherboards.  Whilst I can build up my PC's ok, and for the most part, people will never need to plug in any USB devices like this, it does make me worry that there could be a serious issue.

       

      Reading on the other posts, it seems this seems to be a common problem epecially for Linux users who try and boot from a USB memory drive.

       

      Has anyone see a similar problem or know of a work around?  I'm hoping Intel bring out a new BIOS to fix this as I'm sure that's what is causing the problem.

       

      Many thanks

       

      Leonard

       

      PS:  Just discovered as I'm typing this that when the PC hangs with code 5A displayed, if you leave it for about 10 mins, it will then bring up the boot menu.

        • 1. Re: D525mw - Hangs on boot with USB devices attached
          PowersL

          Hi All,

           

          Just an update on what I've discovered so far just in case it helps someone (or Intel).

           

          When the motherboard is hanging with  5A displayed, if I remove the USB DVD drive or USB HDD, that code flicks through straight away and I can go into the BIOS settings.  So it seems to me that the BIOS is hanging, looking at those devices.  If you don't connect them, it works all ok.  However, I need them connected.  And of course it'll mean most USB devices won't work.

           

          I've also downgraded to the previous v78 of the bios from v80.  That hasn't made any difference.

           

          Thanks

           

           

          Leonard

          • 2. Re: D525mw - Hangs on boot with USB devices attached
            PowersL

            Hi All,

             

            OK would you believe it that after an afternoon of reboot after reboot and every BIOS setting combination.......Intel release a new version 83 BIOS.  Doh!!!

             

            Well lets see if this fixes my problem.

             

            And that answer is Yes and No.

             

            Let me explain.

             

            My current setup is 1 x Western Digitial 2TB external USB HDD connected and 1 x LG External USB DVD drive connected.  Now when I press F10 to choose the boot menu ( I need to boot from DVD), the PC sits there forever.  I have discovered that the PC appears to be scanning the externally connected devices before the keyboard is ready to accept the F10 key.  I know this as the caps light doesn't come on.

             

            Now I can speed up that scanning process by opening up the DVD drive.  For some odd reason the PC doesn't see the DVD and therefore just says "DVD connected" and carries on.  The 2TB is more difficult.  I'm drive I'm using doesn't have any lights on it so I'm assuming that gets scanned after the DVD drive.  For my particular requirement, I want to boot WIndows Home Server 2011 from DVD and then restore the PC from the hard disk.  I can do this by doing the following

             

            1) Disconnect the USB HDD

            2) Power on and press F10

            3) Wait for a while until the boot options appear (you'll hear the DVD being searched for a bit)

            4) Reconnect the USB HDD

            5) Choose Boot from DVD

            6) It works.

             

            So it's not perfect and clearly there is something going on.  I think Intel need to remove the USB device checking code that they have.  It slows down the whole boot process, making the PC unusable.  And what of the USB drive?  Well I think the model I have (8GB Sandisk Cruzer Blade ) is fully compatible with the PC.  If i insert a kingston 4GB usb drive, it appears all the time.

             

            Hopefully you can all see my work around. Not perfect and it certainly won't help me selling solutions with this motherboard to my customers.  But I can tell them to remove the external HDD first before reconnecting it.  A workaround at best.

             

            Regards

             

            Leonard

            • 3. Re: D525mw - Hangs on boot with USB devices attached

              Hi,

               

              A google search brought up your post.

              I'm having a similar problem with my external Western Digital 2TB HDD.

              My PC stopped booting, with a BIOS POST code indicating a problem with the USB devices.

              I disconnected all devices and isolated the problem to WD's 2TB HDD.

              Specifically, if I connect the USB cable from my computer to the HDD while the HDD is NOT receiving power, the PC boots fine. When the HDD receives power, the PC doesn't boot.

              The HDD enclosure is probably jolting my PC through the USB cord, I've heard of many cases of poor quality external HDD enclosures causing such problems.

              Did you try booting your PC with the external HDD turned off?

              • 4. Re: D525mw - Hangs on boot with USB devices attached
                xRQv

                Same problem: any USB2.0 capable device makes the board hang at BIOS splash screen. I mean USB 2.0, because with other USB devices connected (I have a web camera, an ADSL modem and a wireless keyboard connected all the time) I boots just fine. (Though, I am thinking web camera might be also USB 2.0).

                 

                Anyway, any attempt to boot with externally attached certain USB device fails. Yesterday I connected a printer to the board and it hung again at boot screen. Disconnecting the printer makes it proceed to OS boot. At that time it is safe to connect printer back and it works just fine. Absolutely similar situation with USB HDD and DVD and various flash drives.

                 

                When I first installed an OS to the atom based system, I powered the board from a desktop PSU and booted it from a flash drive Ok. (Well, with some tricks: turing on the board with attached USB flash drive doesn't make it boot from it or even show it in a list of boot devices, until you reset the board. On the second boot it sees the drive and can boot from it.) Then I purchased a slim case with 60 watts external PSU. With such configuration I was never succeeded booting from any USB device at all. I thought it might have something to do with the power supply - the only thing that is different in the successful and unsuccessful configurations. However, when the board hung with the printer attached - the printer that has its own power supply unit - I am thinking now that the problem in the BIOS code.

                 

                Any help to overcome the problem is very appretiated. I love atom for its low power profile, its noiseless setup with passive cooling. It serves me as a great workhorse providing many usefull features and even replacing a full powered desktop PC. BUT, the USB problem annoys me very much. Any accidental restart of the atom PC will not bring it to life without someone disconnect all the problematic USB devices, let it boot, and then connect them again. Please help!

                • 5. Re: D525mw - Hangs on boot with USB devices attached
                  Juliuscg

                  Hi,

                   

                  Would you be able to share any information for solution? Is there a workaround? I can't boot D525mw from my USB (windows7) - just can't find usb drive. I tested my USB drive, disconnected all others USB devices, upgraded BIOS but it's the same.

                  What i noticed that sometimes for some conditions, i can boot, but it's very rarely and intermittently, i can't match what causing this behavior.

                   

                  If someone opened case for intel, was it resolved?

                   

                  I really disappointed of this, because i can't keep trying to work with unstable and unpredictable board.

                   

                  Thank you in advance. 

                  • 6. Re: D525mw - Hangs on boot with USB devices attached
                    Diego_Intel

                    What type of USB drive are you using? Were is it connected? to a front panel or to the USB ports in the back of the system?

                     

                    Have you tried disabling boot to USB devices first and disabling boot to Network and boot to optical devices in the Boot menu of the BIOS?

                    You can also try setting a hard disk pre-delay in the Configuration Tab> SATA Drives of the system BIOS.

                     

                    Did you test booting to a regular USB thumb drive instead of a hard drive?

                    • 7. Re: D525mw - Hangs on boot with USB devices attached
                      Juliuscg

                      I tried with two USB sticks (4GB Kingston and 32GB Sandisk) connected to back panel, directly to the board. Both tested with my laptop and were working fine.

                      I checked almost all BIOS settings combinations to test. What I noticed today: in first board startup my USB booted fine, after board reboot i couldn't find usb from boot menu or boot fails. During this time i didn't change bios settings. Any suggestions?

                      • 8. Re: D525mw - Hangs on boot with USB devices attached
                        Diego_Intel

                        Please use the Intel® System Identification Utility using the following site:

                         

                        http://www.intel.com/support/siu_la.htm?wapkw=%28siu%29

                         

                        That will generate an 8 digits code called Report Reference ID.  Please let us have that code, this will provide us information on what is being detected on your system.

                         

                        In addition, please post the full model of the USB devices you are testing with. What operating systems you tested? Also please fill the following information:

                         

                        * Board Altered Assembly Number (AA#):

                        * Board Serial Number (SN#):

                        * Current BIOS:

                        * POST Code:

                        * Power Supply manufacturer and model:

                        * Memory part number and manufacturer:

                        PCI/AGP/PCI Express Video Card:

                        SATA devices connected:

                        • 9. Re: D525mw - Hangs on boot with USB devices attached
                          Juliuscg

                          Hi,

                           

                          Report reference ID: 0209 9409

                           

                          USB device: Kingston data traveler 2.0 3824 MB (also tested with SanDisk 32 GB)

                          OS: Windows 7 (installer flash tested on laptop)

                           

                          Board: D525MWV

                          AA: E93081-400

                          SN: BTMW110001EF

                          BIOS: MQPNT10N.86A.0132.2013.0726.1534

                          Power: mini-atx ro 160 W
                          Memory: elixir 2GB
                          PCI/Video: no external video/PCI
                          SATA: Western Digital (2 TB)


                          Thank you for you support.

                          • 10. Re: D525mw - Hangs on boot with USB devices attached
                            Diego_Intel

                            One more thing I would like to confirm, is this happening with other type of USB devices such just as a printer or USB DVD/CD drive?

                            Does it happen only when the USB device attached has an operating system installed, or it may also happen to another drive with just regular data?

                            Have you replaced this motherboard before? Or you have the issue in more than one motherboard?

                            • 11. Re: D525mw - Hangs on boot with USB devices attached
                              Juliuscg

                              Hi,

                               

                              I noticed that USB is unstable: time to time USB wireless adapter doesn't work after board starts. I need to restart pc to get it back. For regular USB data i didn't noticed, because i didn't use much.

                              I am testing on only one board. If this issue is related with only my board hardware problem, i wont change it. Warranty has finished and I don't want to take a risk for one more unstable board.

                               

                              In conclusion, I hope that this is one board issue, not all series problem. I will consider this, as my unsuccessful investment, which is related with my bad luck buying board

                               

                              Thanks for investigations and your findings.

                              • 12. Re: D525mw - Hangs on boot with USB devices attached
                                Diego_Intel

                                Let me double check on this and reply back as soon as possible. Thank you

                                • 13. Re: D525mw - Hangs on boot with USB devices attached
                                  allan_intel

                                  Thank you for your patient; I just received information from engineering department and according to their findings, this issue was not replicated as it appears to be a problem with your hard drive or the motherboard itself. Please try looking for hard drive firmware update that may help on this matter.


                                  Allan.