2 Replies Latest reply on May 5, 2011 11:38 PM by koitsu

    SSD on SIL3114 Sata2 controller

    Carl

      Initially I did a clean install of Windows XP on my new 80GB 320 Series SSD. I had it plugged into my SATA1 port on my motherboard.

       

      Today I installed a SATA2 PCI controller card (SIL3114 chipset) and with some initial difficulty got it working. (I had to install the Windows driver first using my motherboard's SATA1, then later plug the drive into the the new controller card.)

       

      Now the Intel SSD Toolbox no longer recognises the drive as an Intel SSD, so I can't run any of the functions in the toolbox.

       

      I suspect it's due to the fact that the controller card BIOS insists that the drive be set up in RAID, even though it's a single drive.

      (step 1: Create RAID set. step 2: Choose "Concatenation")   I don't have any experience with RAID since up till now I've always had a standalone IDE drive.

       

      Intel, can you make the toolkit compatible with controller cards like this?

        • 1. Re: SSD on SIL3114 Sata2 controller
          DuckieHo

          Hi, why are you even using a PCI controller for the SSD?  The PCI bus is limited to 133.33MB/s combined.  That means the total bandwidth of all PCI devices in your system will max out at 133.33MB/s.

           

          In addition, native SATA controller provide lower latency and overall better random performance.

           

          The SSD Toolbox issues is due to the controller.  The Intel software can only operate on devices it can identify.  That controller is not presenting the required information to the Toolbox and there is nothing Intel can realistically do.

          • 2. Re: SSD on SIL3114 Sata2 controller
            koitsu

            The Silicon Image 3114 controller operates in AHCI or RAID mode, depending on whether or not you chose to make a drive part of the RAID array.  A single disk -- even in Concatenation mode -- still uses RAID metadata and the RAID functionality.  What you want is effectively JBOD.  What you have done is made the drive part of a RAID setup, which is not what you want.  You should not have gone into the Option ROM ("BIOS") for the controller at all; the disk should have appeared on the bus regardless.

             

            Secondly, I'm assuming you're running 32-bit XP and not 64-bit.  You should be using the Silicon Image 3114 non-RAID driver, version 1.3.11.0, available below:

             

            http://www.siliconimage.com/support/searchresults.aspx?pid=28&cat=3&os=4

             

            Furthermore, the 3114 series has a serious silicon-level bug pertaining to block writes that are greated than 8KBytes.  DMA requests submit to the disk may incorrect return an error status when in fact the I/O operation went through successfully.  Avoid Silicon Image 3112, 3114, and 3152 series controllers like the plague.  Their other controller models (especially the newer ones) are quite nice.  You can read here for confirmation of this bug (see "Product Alerts"):

             

            http://en.wikipedia.org/wiki/Silicon_Image