1 2 Previous Next 18 Replies Latest reply on Jul 6, 2011 12:12 PM by jake_friz

    Remote KVM on Intel DQ67OW

    gentoolicious

      I'm trying to enable Remote KVM on a DQ67OW (BIOS 51) with a Core i5-2400S processor. I've enabled AMT and set the KVM opt-in options inside the BIOS but when I connect to the machine with the Manageability Commander Tool and select the 'Remote Control' tab to finish configuring KVM it reports that 'Remote KVM Settings' are unsupported. I've read other guides which suggest using a password that is exactly 8 characters and that doesn't seem to do that trick.

       

      If I look in the Debug Viewer I can see two 'CallFailed' events relating to KVM:

       

      AmtKVM.fetchCache

       

      WSManFault.Code: a:Sender WSManFault.SubCode: b:DestinationUnreachable
         at Intel.Manageability.WSManagement.DotNetWSManClient.WSManSendReceive(Header header, XmlElement[] bodyIn, XmlElement[]& bodyOut)
         at Intel.Manageability.WSManagement.DotNetWSManClient.Get(Uri resourceUri, IEnumerable`1 selectors)
         at Intel.Manageability.Cim.Untyped.CimObject.Get(CimKeys keys)
         at Intel.Manageability.Cim.Typed.CimBase.Get()
         at ManageabilityStack.AmtKVM.fetchCache()
      AmtKVM.fetchCache WSMAN error
      WSMAN Fault
      Code: a:Sender (subcode: b:DestinationUnreachable)
      Detail:
      Reason: No route can be determined to reach the destination role defined by the WSAddressing To.

       

      Can someone help me out?

        • 1. Re: Remote KVM on Intel DQ67OW
          jake_friz

          I just tried this and it is working for me. So, let's debug.

           

          First, what version of Manageability Commander do you have? I have 6.0.10314.2, just downloaded from here.

           

          Second, try the WebUI (use Internet Explorer to connect to AMT at http://<DQ67OW's_IP>:16992/ just to be sure that AMT is up and responding. You might even take a screen shot of it and post it here if you're still having problems.

           

          Third, check in the Intel Manageability and Security Status tool (start -> All Programs -> Intel -> Intel Manageability and Security Status -> Intel Manageability and Security Status tool). Under the advanced tab, click "Extended system, details". Then expand Intel(R) ME Information and select firmware capabilities. One of the listed capabilities should be Intel(R) Active Management Technology. If it's not, try the next step, then come back and check again. If you can't get it to show AMT, let me know what you do see here.

           

          Forth, try a total BIOS reset by unplugging power, removing the CMOS battery, wait for any LED on the board to go out, and then count to 10. Warning - this will reset ALL BIOS settings, so be prepared to reconfigure everything. This will also reset AMT to it's default password. After re-configuring BIOS & AMT, try everything again. On one of my DQ67 systems I had to do this after a BIOS update to get AMT working again.

           

          Fifth, try an alternate KVM Remote Control tool for comparison. EG: RealVNC Viewer Plus has a 90 day trial.

           

          Let me know what you find.

          • 2. Re: Remote KVM on Intel DQ67OW
            gentoolicious

            Hi Jake,

             

            Thanks for the response. I'm using the latest version of the Manageability Commander tool. It appears I downloaded it from the same website that you did. I'll double check the version when I get home tonight but I'm fairly certain it's the same as yours.

             

            I have been able to access the WebUI and use it to perform basic AMT functionality (power control, event monitoring). It doesn't mention anything related to KVM, however.

             

            On your third point--is the Intel Manageability and Security Status tool something that needs to be installed on the AMT host itself? And if so, is it a requirement? I don't currently have Windows installed on the machine. I have been able to interact with a majority of the AMT technology (SOL, IDE-r, Event Viewing, etc). KVM is the only piece I haven't been able to get working. I've even gone so far as to try a different CPU (Core i7-2600) and it still doesn't work.

             

            I will try the fourth step when I get home tonight and report back. There is a header on the board to reset the MEBx. Will jumping that header be sufficient or will I need to pull the CMOS battery?

             

            Finally, I've actually already tried using Real VNC Plus. When I attempt to connect to the AMT host with valid credentials it will give me this error message: Insufficient privileges for this account. I've done a few Google searches and verified that the user in question has the correct user roles to support Remote KVM (and it does), but I'm still recieving the error message. I've also tried using the 'admin' account to access the AMT host but it gives me the same error message as well.

             

            Do you think this is something that might be ground for a warranty replacement? The Remote KVM functionality was one of the main reasons I bought this board.

             

            -Brandon

            • 3. Re: Remote KVM on Intel DQ67OW
              jake_friz

              The IMSS tool is NOT required for KVM, nor is Windows. IMSS is just a nice tool for info gathering and debug.

               

              There is CMOS clear jumper, but I would recomend pulling the CMOS battery. This way you are sure that ME gets reset. I'm pretty sure this is what will get you up and running. Good luck, and let me know.

              • 4. Re: Remote KVM on Intel DQ67OW
                gentoolicious

                Just an update--I tried pulling the CMOS battery while the computer was unplugged and letting it rest for ten seconds. My BIOS settings were reset and I had to reconfigure the MEBx but Managability Commander Tool still reports KVM is unsupported.

                 

                -Brandon

                • 5. Re: Remote KVM on Intel DQ67OW
                  tomha

                  Same problem here with DQ67SW and Core I5-2300 (Bios 51, even tried 49 and 50).

                   

                  I used to build pc´s with DQ57TM mobos and switched to DQ67SW. With DQ57TM all things worked without problems but on DQ67 ther is no KVM functionality.

                   

                  With bios v 49 and manageability commander tool there is an error when trying to enable the kvm feature, with bios v51 the tool says kvm is unsupported.

                  With Intel system defense utility there is an error when accessing the kvm setting and the log shows the following:

                   

                  System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
                     bei ManageabilityControls.RemoteDesktopEditForm.UpdateInfo()
                     bei ManageabilityControls.RemoteDesktopEditForm..ctor(AmtSystem system)
                     bei AMT_Info_Browser.MainForm.kvmSettingsButton_Click(Object sender, EventArgs e)
                     bei System.Windows.Forms.Control.OnClick(EventArgs e)
                     bei System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
                     bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
                     bei System.Windows.Forms.Control.WndProc(Message& m)
                     bei System.Windows.Forms.ButtonBase.WndProc(Message& m)
                     bei System.Windows.Forms.Button.WndProc(Message& m)
                     bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
                     bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

                   

                  ragards, Thomas

                  • 6. Re: Remote KVM on Intel DQ67OW
                    jake_friz

                    The i2300 does not KVM Remote Control, hence the error. Check this document to see which CPUs do: http://communities.intel.com/docs/DOC-5583

                    • 7. Re: Remote KVM on Intel DQ67OW
                      jake_friz

                      Brandon, I've been thinking on this, but the only other thing I can think to ask is, are you using Intel graphics? Intel graphics are required for KVM remote control. An add-in card will not work.

                       

                      Assuming you're using Intel graphics, if you have access to another motherboard will you try it just to rule out that the board is bad?

                       

                      Ok, assuming the above doesn't help. I'm thinking perhaps if I configure a system similarly to yours I will be able to figure out what is going on. Can you give me as much detail as possible on how you're configuring AMT and how your network is setup? EG: are you doing everything locally in the BIOS or are you using SCS's ACU wizard, or maybe another method of configuration? Also, are you adding other user accounts? How is AMT configured; EG are you setting up TLS, integrating with Kerberos, configuring any other features like alarm clock, etc? Are your console and client systems on the same subnet? Is IPv6 configured in the OS or in AMT?

                      • 8. Re: Remote KVM on Intel DQ67OW
                        tomha

                        Meanwhile i found the document you referred to, many thanks anyway. But the docwas not easy to find and when looking on intels website to find VPro-able CPU´s for DQ67SW mobo it says Core i5 with inetgrated graphics is needed(i5-2300 has integrated GFX)

                        I ordered Core i5-2400 CPU´s for replacement of the 2300´s but i am a little bit afraid that gentoolicious´ 2400s shows the same symptoms and is listed on the document you mentioned.

                         

                        I will let you know

                         

                        Regards, Thomas

                        • 9. Re: Remote KVM on Intel DQ67OW
                          gentoolicious

                          Thanks for the reply, Jake.

                           

                          I am using Intel Graphics (the DVI port on the motherboard, specifically). Unfortunately, I don't have access to another motherboard.

                           

                          I'm configuring AMT entirely through the BIOS. I enter a networking information manually (rather than via DHCP) using the following values:

                           

                          Host Name: server1

                          Domain: mydomain.com

                           

                          IP: 10.0.0.5

                          Subnet: 255.255.255.0

                          Gateway: 10.0.0.1

                          DNS1: 10.0.0.1

                          DNS2: 8.8.8.8

                           

                          I don't use any other configuration utilities aside from Managability Commander. I've added a seperate account (with all permissions) via Managability Commander to try and troubleshoot the issue but it wasn't helpful and I have since reset AMT. It's not configured to do anything fancy like TLS, or Kerberos. No domain integration, either. The only features I changed in the BIOS were the KVM OPT-In options. The AMT system and the host running Managability Commander are on the same subnet. IPV6 is disabled.

                           

                          Let me know if you need anymore informatoin.

                           

                          -Brandon

                          • 10. Re: Remote KVM on Intel DQ67OW
                            jake_friz

                            What are your settings for the KVM OPT-In options?

                            • 11. Re: Remote KVM on Intel DQ67OW
                              gentoolicious

                              I select:

                               

                              User consent is _not_ required for KVM session

                               

                              and

                               

                              Enable Remote Control of KVM Opt-In Policy.

                              • 12. Re: Remote KVM on Intel DQ67OW
                                tomha

                                Core i5-2400 is working.

                                 

                                Regards, Thomas

                                • 13. Re: Remote KVM on Intel DQ67OW

                                  Hi Folks,

                                   

                                  I'm having a similar issue with DQ67EP (the cute mini-itx board).  My processor is an i5-2405S.  There are no cards installed to the motherboard.  I am using the local, non-TLS configuration, and a BIOS only configuration.  I have AMT provisoned: the web server at port 16992 is working.  VNC Viewer Plus gives the dreaded "Insufficient Permissions to access".  Manaeability Commander tool shows KVM as Not Supported.  I don't know why or what I've failed to configure.  Obviously, the new i5-2405S has HD 3000 on chip graphics, and is reported to support KVM, as is the DQ67EP board.  I have flashed latest BIOS, 0052, still no joy on remote KVM.  (Also note that Manageability Command tool seems to crash a lot; I've filed bug report(s) as requested by its crash dialog box.)

                                   

                                  If I use a non-admin and non-permissioned AMT user id added thru port 16992 web server, then I get a different error message: The user account specified does not have the relevant permissions to access the AMT Server -- clearly a different error from when I use an admin or a permissioned user.

                                   

                                  I have Windows 7 installed; haven't tried or found IMSS yet; will give that a shot next.

                                   

                                  Note: my BIOS (AMT 7.x) does not have many of the options that seems to be on other systems.  For example, I cannot find any KVM enable/disable option.  I have KVM opt-in policy (set to <NONE>) and Remote something about adjusting opt-in policy (set to <Enable>).  I also have SOL and IDER settings, soe of which I have tried but not found to help.

                                   

                                  Any thoughts much appreciated.  I thought that with AMT 7 using local non-TLS BIOS only config it would be simple to get KVM working.

                                   

                                  Can anyone help?

                                  • 14. Re: Remote KVM on Intel DQ67OW
                                    jake_friz

                                    Take a look at your webUI again. Even before you login, it should have a banner across the top that looks like one of these:

                                    "Intel Active Management Technology"

                                    http://www.vproexpert.com/E24VZ/amt.png

                                     

                                    "Intel Standard Manageability"

                                    http://www.vproexpert.com/E24VZ/ism.png

                                    "Intel Standard Manageability" is what you get if you have a Q67 but not a vPro processor. "Intel Standard Manageability" does not support KVM. If your system is reporting "Intel Standard Manageability" than it is confused because you do have a vPro processor with intel graphics. In my experience a CMOS clear or a BIOS flash recovery usually cures it: http://www.intel.com/support/motherboards/desktop/sb/CS-023360.htm?wapkw=(BIOS+recovery)

                                     

                                    If that does not cure it, my advice would be to contact Intel customer support:

                                    http://www.intel.com/support/feedback.htm

                                    1-916-377-7000

                                     

                                    Please let me know what you find.

                                    1 2 Previous Next