6 Replies Latest reply on Nov 10, 2012 10:59 PM by physics2007

    raid - Error Occurred(0)

    permidion

      hello

       

      I have a Gigabyte GA-P55-USB3 motherboard with onboard intel raid,

      my array is made or 4x 2Tb drives in raid5

       

      one of the drive was reported as having timeout problem, though the raid array was still ok.

      I decided to put a new spare drive in my computer so the raid array would use it to replace the problematic drive.

      everyting was ok and the faulty drive was automatically replaced by the new spare drive upon completion of the data replication.

       

      at that point I decided to remove the falty drive from my computer, and (which is what I suspect caused my problem), unpluged the sata cable of the new drive to plug it in the old (now removed) faulty drive sata plug.

       

      then, on boot, while the raid bios was getting the disks info, the new drive was listed with the following error in red : Error Occurred(0)

       

      once in Windows 7 (sp1) the array was reported as degraded and only 3 drives were displayed as ok, the new drive was reported as not accessible (or something like that, sorry I was a bit stressed out and forgot to write the exact error message)

       

      as I couldnt understand what could be wrong, I ended reseting the new drive and let the raid software use it to rebuild the raid array anew, which went fine, fortunately.

       

      I discussed the problem with a friend and he told me that, possibly, the raid chipset was confused because I had switched the new drive's sata cable and that he didnt recognise the drive as what it was.

       

      so would this be the problem?

      Intel's raid chipset cant recognise its own drives if we change the cable from the plugs where it was plugged when added to the raid array?

       

      thanks in advance for any info which would enlight this case

       

      Oliver

        • 1. Re: raid - Error Occurred(0)
          millersh

          It's certainly not the case that you can't switch disks to different ports.

           

          On my home computer, I've switched which ports are connected to which disks and there aren't any issues with the Intel RAID software understanding the change.

           

          The cable on that port or the port itself may have issues.

          1 of 1 people found this helpful
          • 2. Re: raid - Error Occurred(0)
            permidion

            thx millersh

             

            I though about the bad cable, so I tried another one, but it didnt solve the problem, I still had the same "Error Occurred(0)" after changing it.

             

            and the port itself is good, as the new spare drive is plugged on it and the rebuild went fine after I reseted the drive.

             

            when I changed the sata cable I also verified it was correctly plugged in the port, but that also wasnt the cause of the problem

             

            but maybe we do not have the same intel raid controller ?

            I couldnt find where to get the exact model version.

            • 3. Re: raid - Error Occurred(0)
              millersh

              You have a 5 series chipset (P55 board).

               

              I have been using the Intel RAID software for a few years on my systems (ICH7R, ICH8R, ICH10R, G45 (4 series)) and I can confirm that changing the ports does not cause my disks to ever go failed.

               

              It most likely was an i/o error that causes an "error occurred" status (maybe a bad sector that the disk remapped)

               

              Then when you reset the disk to normal (as you indicated in you details) it cleared the error status.

              1 of 1 people found this helpful
              • 4. Re: raid - Error Occurred(0)
                permidion

                mmm

                I believe you

                though im still sceptical an i/o error happens "just like that" right after I changed the cables from plugs.

                just wondering, when you changed you hdd cables, did you do it one hdd at time or several at once ?

                • 5. Re: raid - Error Occurred(0)
                  permidion

                  @ Intel, btw, I have rarely seen a more ridiculous and uninformative error message than "Error Occurred(0)",

                  cant you do better?

                  • 6. Re: raid - Error Occurred(0)
                    physics2007

                    I have such error too, I use h57 chipset (Asus P7H57D-V EVO) with raid 0 is made of 2 hdd 640Gb

                    they connected to 5th and 6th sata300 ports, failed hdd's connected to 6th port, however error's port insensitive.

                    I scanned this "failed" hdd in mhdd and victoria - there're no any bad sectors and smart data's the same as "good" hdd.

                    Also, I tried to check array in Win 7 sp1 x64 with no success, too.

                     

                    The only method to fix that error is removing raid array, I found.

                    As to me, I think the problem is caused by intel raid rom only

                    ... were a raid rom update existed  ...