4 Replies Latest reply on Apr 28, 2011 8:08 AM by baud

    RAID 5 says "Initialize" since a BSOD

    baud

      Hello

       

      I hope my english will understandable.

       

      My MB: Gigabyte EQ45M-S2 with Intel Matrix Storage (ICH10).

      My RAID Array: 3*SAMSUNG SpinPoint 1 TB (used for Program Files, Documents, VMs), 2 TB RAID5

      My OS: Windows 7 Pro x64 (installed on SSD)

       

      I don't use my computer for 3 days. I power on my computer. Windows 7 makes BSOD at the beginning and restart the computer. After this restart, i have the following message :

      "A disk read error occurred,

      Press Ctrl+Alt+Del to restart"

       

      I check the RAID 5 status. It's marked "Initialize" (in orange). My 3 disk still member of the array.

      I am unable to use recovery option (press CTRL+I).

       

      I use the Windows 7 DVD to restore Startup. The first time, it don't find the Windows disk. After 30 minutes, i restart.

      Same error (a disk read error...). I do a second restore Startup (it find the SSD). After 30 minutes i restart again.

      Same error (a disk read error...).

       

      With Linux LiveCD, i found my SSD drive with found.000 and found.001 added to my SSD).

      I found my 3 SAMSUNG 1 TB used for the raid array; QParted says no partition on it.

       

      I hope i havn't compromise my data.

       

      Please say me what can i do :

      - delete the RAID array and rebuilt it and try Partition Doctor or testdisk to recover my partitions (Program Files, Documents, VMs) ?

      - repair my RAID (how ?)

      - let the RAID to initialize (i already let i all night long)

      -... other idea ?

       

      Thank you

        • 1. Re: RAID 5 says "Initialize" since a BSOD
          millersh

          Please say me what can i do :

          - delete the RAID array and rebuilt it and try Partition Doctor or testdisk to recover my partitions (Program Files, Documents, VMs) ?

          If you delete the RAID5 volume, all data will be lost. (program files, documents etc) DON'T DO THIS!!

           

          - repair my RAID (how ?)

           

          - let the RAID to initialize (i already let i all night long)

          When you enter the CTRL+I option ROM the status is shown as "Initialize", however I'm pretty sure the option ROM isn't actually doing anything (you will see no hdd disk access lights).  It's simply a status message.  Therefore, no matter how long you keep it on...the status will never change.

           

          -... other idea ?

          Sounds like the partition table is gone on the SSD disk...

          Reinstall the OS to the SSD and copy the data over from your RAID array.

          • 2. Re: RAID 5 says "Initialize" since a BSOD
            baud

            Thank you for you answer.

             

            I have unplugged all SATA ports.

             

            Finally, i have delete the raid volume from the "CTRL+I Rom" (yes, i will lost all my data).

            I have made a memtest : no errors.

            I have made a HDD test in DOS mode with Samsung ESTOOL 3, for each disk : no errors.

            I have created the same raid volume with same disks plugged in the same port (yes, i will lost all my data again). I check the order of the serial number of all disks members to make the EXACTLY same volume than before.

            Intel Matrix Management 8.9 says "Normal" status to my volume.

             

            I run testdisk (on PartedMagic liveCD) but i was unable to see the raid volume. I can access to the 3 hard drives owned by the array. I think Linux havn't driver this raid type.

             

            I have installed a temporary Windows 7 on a 4th disk, run testdisk for Windows and restore the partition table of my array.

            I mount the "documents" partition, and i was able to read all files on this.

            My raid is 64KB strip size. I was able to read picture of 1 MB. This proves the data still here.

             

            I think (please confirm ?) the "Initialize" state is a read-only state where the Intel Matrix wait for the Intel Matrix Console (running on Windows) check the consistency of the raid. But how to do when we are unable to run Windows...

             

            My problem now is my bootmgr of my SSD is corrupt and i was unable to fix it (i have a Startup repair loop even in Safe Mode).

            I think my data of my SSD still here.

            I have delete the partition of my temporary Windows 7 and re-install Windows 7 on it, with the SSD connected (which include the bootmgr of my system).

            Unfortunatly, this don't repair the bootmgr. This Windows Boot Manager offers to boot on the temporary Windows7 (and it works) or on the SSD Windows 7 (still Startup repair loop).

            The Windows Boot Manager screen is strange, it missing some letters (all "e", "d", "l", "m" and "t").

            So what next ?

             

            PS: i don't know why my raid 5 was passed to "Initialize" state.

            • 3. Re: RAID 5 says "Initialize" since a BSOD
              baud

              I have repaired the Windows Boot Manager (I use PartedMagic to rename the file c:\boot\bcd to force Startup Repair to do something).

               

              After that, Windows try to boot but says the C:\Windows\System32\Drivers\iaStorV.sys is missing or corrupt (Intel Matrix Storage driver).

              I have replaced this file, by the same file in my Temporary Windows 7 which it works (SSD Windows 7 and Temporary Windows 7 are 64 bits, but SSD is SP1).

               

              I try to boot again. No errors, but i get a black screen during 10 seconds, when i can hear my disk working, and got a reboot without bluescreen.

               

              I have wait the end of "Initialize" state. My RAID is in "Normal" state now. Nothing changes.

               

              Any idea ?

              • 4. Re: RAID 5 says "Initialize" since a BSOD
                baud

                I close this topic, because my problem is away from the start. I open a new topic!

                Thank you.