2 Replies Latest reply on Apr 16, 2011 1:13 PM by amcfarla

    I cannot update the Intel DX58SO Bios

    amcfarla

      For some unknown reason I cannot update my Intel DX58SO motherboard bios.  I tried running the windows .exe tool, to update the the new bios(SOX5810J.86A.5559.EB.EXE) well it runs and reboots my machine and says it was successful but then going to look at the bios my machine it is still at SOX5810J.86A.4196.2009.0715.1958.  I have tried running the windows tool numerous times and it still doesn't update the bios.  I tried installing the bios files on a flash drive and used the F7 tool and when it comes to select the drive it is just frozen at that point and I cannot do anything(arrow keys and enter key does not respond).  I also tried to use the bootable cd-rom way and it comes up and tells me that I don't have a bootable cd-rom drive(after it loads about half the way through from the CD).  At this point I don't have any idea how to update my bios since all the intel instructions say these methods should work, but for some reason they are unsuccessful for me.  If anyone has any suggestions it would be appreciated.