5 Replies Latest reply on May 9, 2011 9:58 AM by tedk

    Unable to use sccGUI

    viveks

      Hi,

       

      I am newbie to the SCC and I just started using the SCC platform and I seem to have run into some problems. I tried running a slightly modified version of the pingpong application - mine tries to do a pingpong from core 0 to every other core on the board. This ran fine for two cores (essentially doing the same as the pingpong application), but as soon as I tried it on three cores the program just hung (also on the performance meter the arrows on the three cores that I was trying to use turned red). Rebooting linux on those cores solved it the first couple of times, but after that I wasnt able to boot linux on it as well. I kept getting

       

      ERROR: Timeout while waiting for DMA transfer to complete! Cancelling request...

       

      I saw another post of the forum with similar error in which it was reccommended to run the memory test (the swiss army knife). I tried that and pop-up saying progress showed up, after which the GUI just froze. I closed the gui and now when I try to start the gui again and now I get an error which says:

       

      "Failed to connect to PCIe driver. Aborting..."

       

      Can you please help me? Or am I doing something completely wrong that is causing this?

       

      Thanks,

      Vivek

        • 1. Re: Unable to use sccGUI
          tedk

          I saw that you filed a bug (bug 201). It's probably best to continue the discussion there. Can you post the code you used there? When you lose the crbif driver, the most rliable resoponse is a power cycle.

          1 of 1 people found this helpful
          • 2. Re: Unable to use sccGUI
            viveks

            Ouch! I was praying there was an easier thing. I shall attach the code that I last ran there on the bug.

             

            Thanks.

            • 3. Re: Unable to use sccGUI
              viveks

              I am using one of the DataCenter systems, so I guess it will have to be done by the folks over there? I found posts and discussions about similar issues which needed to reinsert the driver and I don't have permissions to do that.

              • 4. Re: Unable to use sccGUI
                zaliwskia

                Hi,

                I am also unable to use sccGUI after running pstencil (standard program included in APPS folder of RCCE library). I have received a long stream of messages like that: ERROR: Timeout while waiting for DMA transfer to complete! Cancelling request... . I filled up an error 217 in Bugzilla. (MARC014).

                All the Best

                Andrew

                • 5. Re: Unable to use sccGUI
                  tedk

                  Unfortunately, the only way we know to deal with this issue is to retrain and reboot Linux. If we cannot retrain successfully, then we power cycle. If repeated powercycles do not work, we replace the SCC chip.

                   

                  I put more information under bug 217.