5 Replies Latest reply on May 6, 2012 1:51 PM by quadcore4

    Intel DH67CL - Windows 7 (x64 professional) fails to start up after bios update.




      Yesterday my brother bought an Intel DH67CL motherboard with an i5 2500 (which is awesme btw).


      Everything worked ok, except for the DVD drives (1 external usb2.0 and 1 internal sata) which acted a bit strange (pc didnt pass the intel startup screen if no disc is present in drive, which is strange...). But no other problem, and we were quite happy since we upgraded from an old AMD athlon 64 system.


      Today we updated to the latest bios, since thats always a good idea and we read there were some changes towards the SATA controllers (so we hoped this might help with our DVD drive issues).


      We used following methid; installing the included cd put 2 shortcuts on the desktop. One of the links brought us to the bios update software on the intel site. Thats the program we used.


      So we used this program to download the latest bios and told it to start updating.

      We got a short summary of what was being updated and everything seemed to go well, no errors.

      After this was finished the system needed to restart and thats when the trouble started.

      Windows begins to start up (so its not the boot sector or something) but just when the animated logo comes on screen, short after that the system suddenly reboots and with the next attempt we get a notification that windows didnt boot well last time and we need to do some check because windows encountered some hardware or software change. So it runs a check and attempts to fix the problem, but no succes.


      I tried installing the previous bios again by using an external usb stick. But this also fails. At first it seems to work... the first 5-6 steps shown on screen report as succesfull but then one of the steps fails and the system reboots... I hope this is normal?? (some form of prevention to stop users from accidently downgrading?)


      I tried taking the battery out for 5 minutes (while powercable is plugged out). No success.


      I tried taking the battery out for 5 minutes (again no powercable) and taking the bios jumper off on the mobo (bios recovery mode) and rebooting with a usb stick that has a bios file on it. No success. The intel guide showed there should be text on the screen during this, but nothing came on screen (was black all the time).


      I tried windows restore points. No success.


      Booting in safe mode also doesnt work, same problem.


      So it seems the disk drive is working and the system can read from it (booting starts and windows can run some restore utility which uses a windows gui).


      I 'think/hope' the bios is also fine? Since i think the system wouldnt be able to get past the intel screen and partially start booting windows if the bios was broken?


      After some searching using google we did find some pages with ppl having simular problems but not 'exactly' the same and didnt find any solution.


      My guess is the bios update did some major adjustments to the extend that windows 7 sees it as an hardware change and fefuses to start.

      Since they use this computer as a secondary server for printing and some networking stuff, its pretty important to get this system up and running again asap. Re-installing windows 7 is really a last resort since we need to reinstall allot of programs and there are some verry important files on the disks.

      Also, some of the other ppl having this issue reported that reinstalling windows didnt help (windows fails to install).


      Prior to the bios update the system worked, so im pretty sure this is in some way the cause of the problem.


      Maybe its helpfull to know we upgraded from version 0076 to 0105.

      Downgrading to 0076 again doesnt work.


      Also it apears to be a stepping 3B mobo (we checked it using the gigabyte tool) so not the problematic 2B.


      Help would be verry much appreciated!!