1 Reply Latest reply on Apr 5, 2011 3:44 PM by tedk

    sccKit 1.4.0 tarball issue

    ziyad

      I am attempting to update the sccKit. But when I tar the provided package I get an error message:

       


      bzip2: Data integrity error when decompressing.
              Input file = (stdin), output file = (stdout)

       

      It is possible that the compressed file(s) have become corrupted.
      You can use the -tvv option to test integrity of such files.

       

      You can use the `bzip2recover' program to attempt to recover
      data from undamaged sections of corrupted files.

       

      tar: Unexpected EOF in archive
      tar: Unexpected EOF in archive
      tar: Error is not recoverable: exiting now.

       

       

       

      I tried this on a different local machine and it gave me the same error. I am assuming there is something corrupted with the files themselves and would like some guidance on what to do to update to 1.4.0.

       

      Thanks

        • 1. Re: sccKit 1.4.0 tarball issue
          tedk

          Sorry, the file was corrupted. I made a new one and uploaded. Our current version of svn doesn't allow you to check out individual files. So when I want a single file I check out an empty project (tarballs) and then update the file I want as below.

           

          tekubasx@marc005:~/tar_test$ svn co http://marcbug.scc-dc.com/svn/repository/tarballs/ --depth empty
          Checked out revision 184.
          tekubasx@marc005:~/tar_test$ ls
          tarballs
          tekubasx@marc005:~/tar_test$ cd tarballs
          tekubasx@marc005:~/tar_test/tarballs$ ls
          tekubasx@marc005:~/tar_test/tarballs$ svn update  sccKit_1.4.0.tar.bz2
          A    sccKit_1.4.0.tar.bz2
          Updated to revision 184.
          tekubasx@marc005:~/tar_test/tarballs$ ls
          sccKit_1.4.0.tar.bz2
          tekubasx@marc005:~/tar_test/tarballs$ bunzip2 sccKit_1.4.0.tar.bz2
          tekubasx@marc005:~/tar_test/tarballs$ ls
          sccKit_1.4.0.tar
          tekubasx@marc005: tar xvf sccKit_1.4.0.tar

           

          and the files now appear as they should.