4 Replies Latest reply on Apr 4, 2011 10:00 PM by parsec

    Decreased access times...

    m1979

      I was very happy with my new PC and my Intel SSD 80GB x25-M

       

      Fresh installation. I put the latest RST drivers under my Win7 32bit. Access time (wr) was around 0.05, write was around 0.08, all speeds were ok comparing to pictures on the Internet...

       

      Two days later, after working on this PC for a while, access times dropped to 0.1ms... Tools to messure: Assd and Sisoft Sandra

      I checked in safe mode - the same...

       

      Read/write: SisoftSandra showed 200MB/s only, two days ago it was 250...

       

      I am just a little woried it will get worse :-(

       

       

      I do not know why, but cant see my REPLIES, so I am posting some more details here:

       

      .

       

      so trim is enabled (got 0 after typing this command).

       

      1. As i said, I had put RST drivers, but when I go to  device manager in Windows, it shows Microsoft ahci drivers, even though  RST is running in the background and e.g. As SSD recognizes that it is  an Inter driver??? might it be the reason???

       

      2. All I did in the last 2 days was SP1 for Win7

       

      3. I have more thatn 50GB of free space on this HDD and ran 'quick check' using intel toolbox

        • 1. Re: Decreased access times...
          parsec

          Usually a SSDs performance deteriorates due to lack of TRIM support by the OS, but if you have Win &, you have TRIM.  You can verify that by typing this command in a cmd window:

           

          fsutil behavior query DisableDeleteNotify

           

          If the result is 0, TRIM is enabled, if it is 1 it is disabled.  If you need to enable TRIM you can enter this command:

           

          fsutil behavior set disabledeletenotify 0

           

          It is unusual to see that much of a drop in performance in just two days, even if you didn't have TRIM enabled.

           

          Do you use the Intel SSD Toolbox?  That has the SSD Optimizer, which  is essentially running TRIM manually and keeps the SSD performing at its  best.

           

          I have four X25-M 80GB SSDs, which I have been using  for up to a year now, and testing with AS SSD shows I have not suffered  any performance loss at all.  My scores are consistent over weeks and  months.  I have seen variations in the access times, but those are not  greater than 0.03ms in either direction, which I think is due to  variations in what processes are running in the background during the  testing, among other things and don't worry me at all.  If the access  times approached 0.5ms, then I would start wondering what was causing  it.  The drop in read or write speeds that you quoted would concern me,  and it would usually be strange for it to drop that much in such a short time.

           

          How much unused space in on your SSD?  I would do a Windows Disk Cleanup and download the Intel SSD Toolbox and run the SSD Optimizer and then run your tests again.

          • 2. Re: Decreased access times...

            Weird... cant see my reply????

             

             

            Thx Parsec

             

            Checked with this command, trim enabled (got 0 after typing this command)

             

             

            A few things:

             

            1. When I go to device manager, I can see that the driver is still Microsoft, not Intel, even though I installed RST (it was like this from the beginning, I just ignored it as  it was working fine). RST is running in the background and it says eveyrhing is ok. Is it ok?

             

            2. The only big change I made in the last two days was SP1 for Win7. I also copied a lot of files between hdds

             

            3. I downloaded Intel Toolbox and ran a quick test - the same results

             

            4. I have 50 gb free space on this hdd

             

             

            This is my second Intel SSD, this time with a new motherboard as well (P67) and problems again...

            :-(

             

            I am especially concerned about the access times as it shows 1ms right now... :-(

            • 3. Re: Decreased access times...
              m1979

              That is weird... today I got 250MB/s again, but access time is still around 1ms, it used to be 0,6ms

              • 4. Re: Decreased access times...
                parsec

                If you are looking at your SSD/HDD/Optical drives in Device Manager, you won't see the IRST driver associated with them.  The IRST driver is used by the device that controls the SATA interface, in your case the P67 Platform Controller Hub (PCH) chip.

                 

                In Device Manager, look for "IDE ATA/ATAPI controllers".  Double click that and you should see "Intel Desktop/Workstation/Server Express SATA AHCI Controller".  If you double click that the Properties will appear for that device, choose the Driver tab, and click on Driver Details.  If IRST is installed, you will see the driver file iaStor.sys.

                 

                Next question, what is your SATA mode set to in the BIOS?  You should have it set to AHCI or RAID to get the benefits of AHCI with your SSD.  New mother boards like yours might have AHCI as the default.

                 

                You said you downloaded the Toolbox, did you install it?  It's not a driver but a program for use with your Intel SSD to keep it running like it is new.  The User Guide should be available on the same download page as the Toolbox software.

                 

                I'd like to see a screen shot of an AS SSD run if you can post that.