7 Replies Latest reply on Apr 28, 2011 8:24 PM by

    Problem switching to AHCI mode

    gyster

      Hello, I just completed this build: Opteron 6170 x 2 on Asus Kgpe-D16, 24gb Kingston ECC ram, Quadro 2000, Intel X25M 120gb, 3tb on one internal and one external hdd, Win 7 ultimate.  I didn't check bios for ide/ahci mode prior to installing windows, and it was set for ide.  Last night I editted registry and changed bios to ACHI.  System rebooted, and everything seemed ok.  On second (or maybe 3rd) reboot, the system hung at windows start up screen.  I pressed reset, and now after post, I get a brief what looks like bsod, and system starts boot process again. I have not applied any firmware updates nor run any optimization tools on the drive.  Can anyone please help get this system up again?

        • 1. Re: Problem switching to AHCI mode
          Al_Fairclough

          AMD motherboards are notorious for AHCI problems. I couldn't get any of mine to work and finally switched to an Intel CPU on an Intel motherboard. It has been clear sailing ever since.

          • 2. Re: Problem switching to AHCI mode
            gyster

            Thanks Al,

             

            Oh great.  No wonder they set the default to IDE.  Well, this is a brand new system, so switching to an intel-based system isn't an option at the moment...anyone have successful experience with this?

            • 3. Re: Problem switching to AHCI mode

              Using the most recent BIOS.

               

              On my first reboot after switching to AHCI, the system hangs. I tried a fresh install and installed the AHCI drivers from the disk, and that too failed (cannot use this disk for installation - or some such similar message).

               

              Still trying more things - if I have luck, I will let you know.

              • 4. Re: Problem switching to AHCI mode
                parsec

                Changing to AHCI mode after installing Windows has a little trick to it, but is really not bad at all.  I must say I have not done this on an AMD PC, but that should not be a problem with Windows, and I would be surprised if the Microsoft AHCI driver did not work on an AMD chipset.  The symptoms you are describing are not uncommon given the situation, you are set to AHCI in the BIOS but the AHCI driver has not been loaded.

                 

                Here is a link to the description of the fix for this problem:

                 

                http://windows7themes.net/switch-to-ahci-after-install-windows-7.html

                 

                I am not familiar with AMD chipsets, but once you have the MS AHCI driver loaded and the BIOS in AHCI mode, you can update the driver to the AMD driver of your choice, that supports AHCI of course.  Up until very recently, it was standard for the default SATA mode in any BIOS to be IDE, since the mother board manufacture must allow for all potential OS's (XP does not have an AHCI driver) and all kinds of drives (PATA!) and IDE is the (lowest) common denominator.  Let us know how it goes.

                • 5. Re: Problem switching to AHCI mode

                  Let's see, I've had some major issues since my last post (had the system completely apart three or four times), but the system is up and running now.  I posted initially after completing the procedure described in parsec's post.  I don't know why, because after taking a wide detour, I ran the exact same procedure again with success.

                   

                  I'm not sure however, whether or not the firmware update worked.  If it did, what should I see in device manager>disk drives>intel ssd>details>hardware ids?

                   

                  Thanks for taking time to post!

                  • 6. Re: Problem switching to AHCI mode
                    parsec

                    The latest firmware update is 2CV102M3, the previous firmware is 2CV102HD.

                     

                    I'm glad your PC is running fine again.  IMO, the new firmware is not essential for these SSDs, I have two with 02M3 on them, and two with 02HD.  With 02M3, you lose a small amount of sequential read speed but gain in IOPs, and some issues are fixed that I never encountered.  See for yourself:

                     

                    http://downloadmirror.intel.com/18363/eng/Release%20Notes.PDF

                     

                    Just wondering, which driver are you using, msahci, or an AMD driver?

                     

                    Message was edited by: parsec

                    • 7. Re: Problem switching to AHCI mode

                      I'm using an AMD driver now.