1 2 Previous Next 23 Replies Latest reply on Jun 30, 2011 2:32 PM by

    DH67BL LAN problems

    energywave

      Hello to all,

       

      I have a DH67BL motherboard and it seems that the Intel 82579V LAN controller mounted on board has some problems that need to be fixed by Intel...

       

      The problem is related to link speed. I've connected it to a 10/100 switch with a cat.5 cable and if I set the link speed (from Intel driver) to:

      • "autonegotiate": the OS says me that the cable is disconnected.
      • 100 Mb/s: OS says again cable disconnected but then PC becomes locked for 10-20 sec and responsive for 1-2 sec and so on. Eventually there comes out a popup saying that video car stopped to respond and it was recovered (seems some IRQ or phisical address problem?!?!). It remain so until I can, in those 1-2 sec. of responsiveness with much patience, change the link speed settings.
      • 10 Mb/s full duplex or half duplex: it works correctly, but on the detected speed it says 10 Mb/s Half duplex, even when set Full duplex.
      • 1000 Mb/s: not tested, I don't have gigabit hardware to test with.

       

      That said here some fact:

      • OS: Windows 7 64bit but tested with a live cd of Ubuntu 10.10 64 bit and it does exactly the same things.
      • Drivers and BIOS: all the latest, updated the 25th march 2011 with latest releases found on Intel website (they where all 1-2 days old!)
      • The cable is a cat.5 connected to the main company switch.
      • If I connect another PC to the same ethernet cable it works without problems at 100 Mb/s Full Duplex
      • I've tested to connect the same PC in cross to an Asus laptop and the problems remains the same. The strange thing is that even the laptop says that there is no cable...
      • I've tried to disable al power management features from the intel driver as I've read that there could be incompatibilities but nothing changes
      • I've had those problems with the first DH67BL, then I've managed to change it in warranty from the reseller (getting also the new batch without the infamous SATA problem...) and the symptoms of LAN controller are the same! So we cannot says that it's an hardware defect, it's the same with two different motherboards.

       

       

      It seems so strange to me that no one wrote that before, it should be so for all boards? Isn't it?

      Can someone help me to understand what's going on? Must I buy a PCI lan adapter because the internal one is buggy?

       

      Thank you in advance to all that want to help me!

      Henrik

        • 1. Re: DH67BL LAN problems
          yf38

          Hi Henrik,

          I have a DH67GD motherboard with core i5 2500 and  it is connected to an internet box (switch) at 100Mb/s without any problem.

          This is running (64 bit windows 7) from mid- january (with the B2 rev.) and this motherboard is the same as DH67BL populated with display port and firewire on board. I have updated the bios from initial 076 to 105 as they were available, and the same for all the drivers, without a visible difference at LAN level.

          The cable to the switch is a 20m length cat. 6.

          Maybe your system is affected by some other problem, such as a marginal PWS or something else ?

          • 2. Re: DH67BL LAN problems
            energywave

            Hello and thank you for your feedback.

            If for "marginal PWS" you mean Power supply too weak let's say that I have on the system a 500W Cooler master power supply, considering that there is no "external" video card I believe that's more than adeguate.

            And I cannot believe there is "something else" because the system is yust installed and if I boot from Ubuntu or UBCD4Win CD it's the same, the problem is the same before and after the motherboard substitution (with different revision), if I plug the ethernet cable in the same place in another device all is right...

             

            My conclusion is that there must be something wrong with ethernet controller in that motherboard. Maybe something different on engineering respect your board? I don't know but this seems a very serious problem to me.

            That PC is for office use in a LAN and I cannot work in 10 Mb/s half duplex honestly...!

             

            Should I buy a PCI-express LAN card??? That would be a pity...

            • 3. Re: DH67BL LAN problems
              yf38

              Hi Henrik,

              Your PWS is of course enough sized for your system, and should not be the cause of trouble, provided it is in good working conditions (good voltage, no ripple).

              My DH67GD is exactly the same motherboard as your DH67BL, same PCB, same chips, same bios, same drivers, and so on, except it has a firewire controler and a displayport connector which are not populated on the DH67BL.

              LAN hardware / firmware / driver are OK with these boards, at least for typical 100Mb/s network.

              No later than this morning I moved à 3GB file from a DG45iD port to DH67GD port thru the internet box switch at 100Mb/s (2x 20m cat 6 câble) and got a sustained 11,3 MByte/s, told by explorer, ok, more or less reliable measurement, but meaning  a not so bad 90Mb/s.

              We are not the only owners of these hardware, so I think it is hard to assume a design flow in the motherboard LAN area.

              • 4. Re: DH67BL LAN problems
                energywave

                Yes, I'm also aware that we are not the only owners of these motherboards but... how can you explain my issue? There seems to be no logic explaination...

                I've also been in chat support session with an intel techician. He wanted me to do various tests (like connecting in cross with another PC, etc). His conclusion was that I have a defective hardware... That was with my previous motherboard (the one I had previous of warranty swap)

                 

                I don't know more what to think and what to do...

                 

                I've ever been an Asus motherboard customer and this is my first Intel MB. Maybe the last one...

                • 5. Re: DH67BL LAN problems
                  yf38

                  Maybe that the board you got back from support... was the same you sent, because they did not find any problem.

                  Did you check the serial number ?

                  About Intel boards this is my fourth one and I never had problems, except the B2 H67 chipset...

                  If everything is good in your system, should we conclude that there is some incompatibility with your câble and switch ?

                  even if they seem to work with another PC ?

                  The more obvious was the energy saving options, but you said they are disabled, maybe you can check again, restarting windows and so on to be sure that everything in this area is for sure disabled and you use the good windows profile.

                   

                  As serial number you can use the MAC address, it is printed on the board box label, and should be the same you can observe with any utility on the card.

                  IPSCAN32 freeware is good to observe any device on the network and their MAC address

                  • 6. Re: DH67BL LAN problems
                    energywave

                    That was the first thing I've thinked too (service not changing the motherboard, even because I was worried they didn't knew about B2-B3 facts). I've not checked the serial because I don't have the old one. But on the box of the new MB there is a label with "B3" in the code, and the packaging was closed.

                    Furthermore when I've turned on the system after motherboard susbstitution Windows reinstalled all the system devices, so I think that it was a real new one.

                     

                    I can confirm that energy saving options in ethernet controller properties are all disabled, that was one of the first thing I've read in internet reading about my issue.

                    Furthermore I have to say that the same happens booting from Ubuntu LiveCD and UBCD4Win (XP SP3 live CD).

                     

                    Today I'll test connecting with different cable and to a different switch, but that will not be for sure the problem even because all seems more a hardware/drivers problem, cause at 100 Mb/s all the system is locked, then working, then locked, then working and so on, graphic driver crash and get resumed by windows. All this let me think about a IRQ or something problem.

                     

                    It's so strange that I'm the only one with these problems...

                    • 7. Re: DH67BL LAN problems
                      yf38

                      About the serial number I edited the end of the last post to explain that the MAC address can be used as serial number (printed on the box).

                      Now you are speeking about strange things like system temporary freeze.

                      Things like this can be the result of either memory DIMMs problems, or disk with defective sectors, or processor running at too high temp.

                      You can check the memory using one the the various utilities for that, and the disk can be checked using the manufacturer's test.

                      Western Digital provides a diagnostics utility you can download, which has a quick, non destructive, and fast test which can help.

                      I passed the quick test even with a Seagate disk (I have a Seagate and a WD in the system).

                       

                      Are you also sure that you installed the "management driver" ?

                      • 8. Re: DH67BL LAN problems
                        energywave

                        The system freezes are one of the first things I've said in my first post (point 2 of the first post). The system freeze itself and unfreeze in a time regular manner ONLY when I manually set 100 Mb/s as the link speed. If I set 10 Mb/s the system works perfectly, if I set autonegotiate the system works perfectly, excluding ethernet HW that reports no cable connected.

                        I've already tested the 2 DIMM with Microsoft diagnostics (not UBCD because it does not work on this hardware) however no problem reported for DIMM.

                        HD problems are excluded because the same LAN problems (excluding system freezes) happens in Ubuntu Live CD and XP SP3 live CD (no HD involved). I believe that Ubuntu LAN driver is much different from the Windows one and it does not freeze the system but it continue to try connecting and keep saying "cable disconnected" every 30 seconds or so, like it can't establish a connection and then retry. No communication can be done, however, using LAN in ubuntu. I've not tested to change the link speed because I don't know where to do it in Ubuntu.

                        Last thing: when I've done the tests in Windows 7 64bit (OS installed on HD) I was running all the time CoreTemp and the temperature was never high, the cooling seems normal.

                         

                        But these system freezes happens only when I set 100 Mb/s in link speed... That's the point. And that happened even with B2 motherboard...

                        Even graphic board driver crash and resume by windows happens only while manual 100 Mb/s link speed and while the system keep freezing and working, freezing and working.

                         

                        Better explained what happens in ubuntu and some more, edited by Henrik Sozzi

                        • 9. Re: DH67BL LAN problems
                          yf38

                          I checked my lan properties for 82579 and the main ones are:

                          general:  Bus PCI 0, périphérique 25, fonction 0

                          link speed:  autonegotiate, 100MB/s full duplex

                          power, energy savings: 3 first enabled (includind energy saving)   4th disabled (reduce speed when system idle)

                          wake options: none enabled

                           

                          I am not so confident about the fact that checking with another system is very significant.

                           

                          Maybe something became wrong in windows registry, did you try to remove everything about the LAN and reinstall ?

                           

                          Also, in the registry, old controlers which are no more present will stay, but are hidden. If you want to be able to see them in the devices management window and clean what is better to clean you can do like this:

                          - define a new system environment variable with name DEVMGR_SHOW_NONPRESENT_DEVICES

                          - assign the value 1 to this variable

                          - in the device management windows menu select to show hidden devices.

                          • 10. Re: DH67BL LAN problems
                            energywave

                            First of all thank you about your effort to help me, you are the only one!

                            That said I'll check the values I have and I'll write them or make a screenshot. For what I remember my parameters are the same as you said.

                            Thank you for explaing the NONPRESENT_DEVICES but I already knew that and that was the first thing I did when I've booted windows for the first time with new MB, when windows reinstalled all the drivers (creating #2 of all). I've deleted the old, not more present drivers, even the LAN one, so that at next reboot all was perfectly clean.

                            One small note: Windows 7 64 bit just installed and updated with all updated till SP1. No other things installed, only Intel drivers, CoreTemp and CPU-Z, nothing more. A very very clean just installed system.

                             

                            I'll post some screenshots.

                             

                            Merci beaucoup pour ton temp!

                            • 12. Re: DH67BL LAN problems
                              energywave

                              Yes, I'm Italian and I've studied french for some years at school

                              I'll write in english, however, so that all the people can have this post as a reference.

                               

                              I've understood some more with this issue. It's very strange but.... It's an incompatibility with some ethernet devices!

                              I was using a 3com 10/100 switch and it had all the issues I've described before. I've also tested another device, thinking it could be a device related issue, using a 3com 10/100 hub this time but... no luck.

                              I've tested with a cross cable with an Asus laptop and it was no difference: (cable disconnected at both ends. Yes, I've tried several cables and I've connected laptop to another PC in cross and it worked).

                              At this point I've assumed it was an Intel device problem... Wouldn't you?

                              But then I've connected, during my 1001 testes, the cable to a D-Link home router/switch device (10/100) and... it worked normally using autonegotiate at 100 Mb/s!!!! Then I've connected directly to a 10/100 port of our corporate firewall (D-Link too) and... it worked!

                               

                              So I must assume there is an incompatibility with certain ethernet devices and I believe that Intel should work on it, it's not normal... All other devices here (we have tons of ehternet devices, industrial devices and consumer devices) works without problem when connected to our 3com switch / hubs.

                               

                              This is the resume of devices to wich I've connected:

                              • 3com OfficeConnect Dual Speed Switch 8: DON'T WORKS
                              • 3com OfficeConnect Dual Speed Hub 8: DON'T WORKS
                              • Asus i5 Laptop with cross cable: DON'T WORKS
                              • D-Link DSL-G604T (old DSL router with onboard 10/100 switch): OK
                              • D-Link DFL-200 (our firewall with onboard 10/100 switch): OK

                               

                              That said I'll connect the PC directly to the firewall and I've resolved my problem, but this leave a big question mark on the Intel ethernet controller...

                              • 13. Re: DH67BL LAN problems
                                yf38

                                Hi Henrik,

                                Thanks for the report, maybe you found an interesting issue.

                                In this case I suspect more a driver incompatibility at some level of the protocol than a hardware problem, because the physical layer is an old story and less subject to mistakes than a more or less newer driver.

                                What is strange is it's OK with a Dlink and not with a 3COM.

                                I'll survey this story on the web and come back if I find something.

                                Yves

                                • 14. Re: DH67BL LAN problems

                                  Hi Henrik and Yves,

                                   

                                  I have a DH67CL with the same issue. It's connected to a AVM Fritz!box 7170, CAT5e, cables from 1 to 20mtr tested.

                                  Os's tested: W7x64 and W2008R2;

                                  - with both there is the no cable problem after boot,

                                  - when I swap cable to a different port on the Fritz!box there is a connect!

                                  - when I reboot there is no connect!

                                  - when I swap the cable back to the original Fritz!box port there is a connect!

                                  - swap back and no connect!

                                   

                                  My workaround is to reboot the system when it reports no cable after boot, then when booted again there is always a connect!

                                  So each time I cold boot the system there is the no cable problem, then after reboot the problem is gone, then after reboot the problem is back, and so on!!!

                                   

                                  This is also my second H67 board, the previous one had the same lan-cable issue, so it's not exemplary

                                  I´ve had no LAN issues with the Fritz!box while using 10+ systems with it.

                                   

                                  I can't explain this problem and hope Intel can fix it, has anyone reported it to Intel yet?

                                   

                                  Reinier

                                  1 2 Previous Next