1 Reply Latest reply on Mar 15, 2011 12:39 PM by mark_h_@intel

    e1000e: probe of 0000:02:00.0 failed with error -2

    ethernall

      Hello,

       

      I am trying to use a rig with Gigabyte GA-880GA-UD3H mother board and Intel 82574L based NICr (EXPI9301CTBLK) under CentOS 5.5. Unfortunately I have issue with the NIC - during boot it fails to initialise:

       

       

      Intel(R) PRO/1000 Network Driver - 1.3.10a-NAPI
      Copyright(c) 1999 - 2011 Intel Corporation.
      ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 19 (level, low) -> IRQ 16
      PCI: Setting latency timer of device 0000:02:00.0 to 64
      e1000e 0000:02:00.0: Using NUMA node 0 for memory allocations
      ACPI: PCI interrupt for device 0000:02:00.0 disabled
      e1000e: probe of 0000:02:00.0 failed with error -2
      

       

      I receive the same result with both the original e1000e driver from the distribution and the latest driver from Intel site (as seen in the example). I have tried also 2.6.37 kernel version - with the same result. The adapter however works fine under Windows and with Ubuntu 10.10 LiveCD. Please help me rsolve the issue. Thank you very much in advance.

       

      BR,

      ethernall

        • 1. Re: e1000e: probe of 0000:02:00.0 failed with error -2
          mark_h_@intel

          I asked our engineers about a possible resolution, but this looks like it might be a new bug. This issue is worth tracking down, but there is a better place for help with LInux driver bugs. Your best bet is to open a bug on SourceForge. The support page at http://sourceforge.net/projects/e1000/support has a link for creating a new item in the Bugs Tracker.

           

          I received the following information about what to include in your bug report from one of our software engineers: 

           

          This is a useful set of information that we almost always ask for when trying to solve a problem:

              * Summary of bug (one line):

              * Detailed description of bug:

              * Reproducible with steps:

              * Distribution and version:

              * Kernel version:

              * Intel Network Driver version (ethtool -i ethX):

              * Dmesg info with modprobe e1000 debug=21, or at least any relevant dmesg info:

              * 'ethtool <ethx>' output:

              * 'ethtool -i <ethx>' output:

              * 'ethtool -e <ethx>' output:

              * 'lspci -vvv' output:

              * 'cat /proc/interrupts' output:

          Also please see the file REPORTING-BUGS included in your kernel source.  One possible location is here: http://www.kernel.org/pub/linux/docs/lkml/reporting-bugs.html

           

          I hope this helps.

           

          Mark H