1 Reply Latest reply on Aug 30, 2011 5:13 AM by Microkid

    DQ45CB GPT formatted USB data corruption during boot

    randomcoww

      "Test PC" running the DQ45CB. Tried firmware versions 123 and 129 (latest).

       

      Booting the PC with a GPT formatted USB drive plugged in seems to cause data corruption on the USB drive. Tested with multiple USB drives and on multiple motherboard ports. Stopping boot before the OS starts loading causes the same issue so the OS is most likely not the problem.

       

      I found two indications of data corruption:

       

      - Listing GPT partitions running "parted -l" brings up the following error on the USB drive:

      "Error: The backup GPT table is corrupt, but the primary appears OK, so that will be used."

       

      - The drive can be mounted and read but accessing some files causes input/output errors.

       

      No other PCs have this issue with the same USB drives.

      MBR partitioned USB drives seem to not have any of these issues on the test PC.

      Also plugging in and working with GPT formatted USB drives on the already booted test PC seems to cause no issues.

       

      Is this a compatibility issue? Setting error? Hardware issue?

       

      Thanks.

        • 1. Re: DQ45CB GPT formatted USB data corruption during boot
          Microkid

          Similar problem here. My DQ45CB has been running as ESXi 4.1 server fine for 2 years, booting from an USB stick. I created a new ESXi 5.0 stick (partitioned with GPT). When booting, I only see a flashing cursor. Is this mobo capable of booting from GPT partitioned drives?

           

          Update: Found a workaround: Press F10 during boot and select the USB stick. The boot then goes fine and ESXi 5.0 starts happy. if you let the machine auto-boot, it won't boot from the same USB stick. So it seems there is a problem in the BIOS when booting from GPT partitioned USB sticks. I use bios 133 (latest). Tried with and without UEFI boot, no change.

           

          So Intel, can you please fix this in a new bios version?