1 Reply Latest reply on Mar 6, 2011 11:43 PM by millersh

    Intel Matrix Storage Console RAID 1 Question

    Prosumer1

      Hello,

      I have a Lenovo W700 with Raid 1; two 320GB Hitachi drives. Intel Matrix Storage Console was marking one drive as bad. Turns out it wasn't an enterprise class drive (apparently consumer drives can time out on large file transfers or in recovering sectors). I have two Enterprise class (RAID) drives now, that both have my mirrored old Windows 7 image working (call these Drives A & B). However, I also have two non-E class drives that are also successfully mirrored, but with a clean, patched Windows 7 SP1 install image - call these drives

      C & D (don't ask, but part of my validation process in troubleshooting the original Raid Array problems included a clean install on two new drives, so these are a separate RAID 1 array from the working old windows 7 image). What I want to do now is migrate the clean install image from drive C or D to one of the original Enterprise class drives (drive A). So the old good drive would have a new image from the non enterprise class drive. Then I would manually copy some data from Drive B or a backup to that drive. Then I would wipe drive B and resync. Result = two enterprise drives with clean install plus data migrated from old drives syncing. At least that is the theory. When I try to reformat one of the drives, and try to add it to the array, I either get "Not enough space" or I can't boot into Windows. I am not doing something right when adding a used drive back into the array. I have tried deleting data and repartitioning - no luck. I have tried low level format and inserting it raw. no luck. I have formatting and partioning and inserting. No luck. I seem close, but I am missing something basic. Steps are: shut down PC; pull battery and cables. Do I need to yank one good drive, and reboot so Intel Matrix storage console thinks it has a problem, or can I just pull drive 1, and insert blank drive? What state must the drive be in (Raw, formatted, partitioned?) to make it work? It keeps creating a new Raid Array, so I have one disk in each array, and can't get them back together as a single array for some reason. Any suggestions?

        • 1. Re: Intel Matrix Storage Console RAID 1 Question
          millersh

          The reason you can’t add the disk is because a RAID1 volume can only have a maximum of 2 disks in the array.  That is why you are being presented with the error, you can only add the disk to the array if you are going to change the RAID level type (to RAID0 or RAID5 for instance).

           

          Here is how I would recommend doing this, pay very close attention to details or you will lose dataAlso before starting, you must make sure that the size of disk (GB) A and B are at least as big as disk C or D or this process will not work.

           

          You have a RAID1 with disks A,B (let’s call the array oldWin7) that are Enterprise Disks with old install and all the data files you want.

          You also have a RAID1 with disks C,D (let’s call the array Win7SP1) that are non Enterprise disks but have clean install.

          You want the image from disk C/D to be on disk A, then you want to manually copy data from disk B over to Disk A so it will have new image and old data files.

          In order to do this, you will need to degrade both volumes.

          step1-4.png

           

          step5-11.png

           

          step12-15.png