8 Replies Latest reply on Oct 20, 2013 8:45 PM by Vako

    Help: Can't install Intel PROset, but can't un-install it either!


      Okay, I've got an Intel DQ35MP mobo, which includes an Intel 82566DM Gigabit Ethernet Device onboard, and I'm running 32-bit XP Pro/SP3 on an Intel E8400 Core 2 Duo CPU.  Several driver-scanning tools have been telling me for quite some time now that I need to update my networking drivers, and all those driver tools as well as the Intel site for the mobo tell me that what I need is to update them with the latest Intel PROSet updater (filename is PROWin32.exe V15.3).  But...


      When I run the updater, it always complains:


      Intel PROset upgrade message.png

      (The installed version of Intel PROSet is not supported for upgrades. You must uninstall it before installing this version.)


      Okay, fine, right?  I'll do as it asks and uninstall it first.  But...


      Not only is PROSet nowhere to be found in the full "Add/Remove Programs" list, Revo Uninstaller Pro -- a truly great tool -- can't find it either!


      I don't recall where I found this info (maybe in the readmes or examining the plaintext installation files), but I located what was supposed to be the path to the actual installation location (one of those system path names with curly braces), but there was nothing there either.  Therefore, I figured maybe one or more of the installed PROSet files got damaged or deleted, or maybe it wasn't even installed in the first place.


      But what's the standard trick to fix a damaged installation or flawed un-installation?  Try to install it again so that there's enough information in the system to allow a clean repair or un-installation.  But, Martha, there's a hole in that bucket!

      What do I do now?  I'm pretty handy with a registry editor, but I've been unable to determine what needs to be changed, and so I'm obviously not going to guess my way through it.



      Suggestions, please?




      BTW: I've searched these forums and several others to try to find a working solution, but as you can see from what I've already tried, nothing I've seen there actually works.  One piece of advice I found was to uninstall and/or update just the NIC drivers, but while that particular driver update worked fine, the driver-scanner tools still tell me to update PROSet, so that didn't solve the problem.


      Edited To Add (3:44 pm EST same day):  I should have explicitly mentioned that I'd already tried the steps described here titled "Phantom adapters may prevent your adapter from teaming": http://www.intel.com/support/network/sb/CS-016722.htm, which an Intel tech support agent or other poster linked to in response to someone else's complaint about the same problem I'm having.  It didn't solve the problem.

        • 1. Re: Help: Can't install Intel PROset, but can't un-install it either!

          Under Windows programs, look for Intel(R) Network Connections. That is the program you need to uninstall.


          If Intel(R) Network Connections will not uninstall, then take a look at http://www.intel.com/support/network/sb/CS-029916.htm.


          I hope this helps. 


          Mark H

          • 2. Re: Help: Can't install Intel PROset, but can't un-install it either!

            Thanks for your reply, Mark!

            However, there's no "Intel(R) Network Connections" installed either!


            Here's a screen shot of every Intel item that shows up in "Add/Remove Programs" (the same list appears in Revo Uninstaller Pro, as well):


            Installed Intel Software.png


            (I included the apps immediately before and immediately after the Intel entries to show there are no other Intel entries there.)


            Once again, I can't uninstall an Intel software product because there are no install entries anywhere I can find!  We're right back at square one in that regard.


            What do you suggest now?


            Thanks again!

            • 3. Re: Help: Can't install Intel PROset, but can't un-install it either!

              I do not have any easy answers. Something in the Windows* registry must be making the installer think a previous version of the software is installed. There are several approaches you can take for the next step. I hope at least one of these ideas will be helpful.


              Your could try the manual registry cleanup detailed at http://www.intel.com/support/network/sb/CS-029916.htm. Creating a Windows restore point first might be a good idea. That way, if you accidentally create new issues, you can atleast restore your system to where you were at.


              By the way, do you have the extra tabs that Intel(R) PROSet adds to the network connection properties? You should have a "Link Speed" tab that will include the current software version of Intel(R) PROSet. If that tab is not there, then PROSet is probably not installed even though something in the registry makes the installer think the software is installed.


              If Intel(R) PROSet is not installed and you only want to upgrade the driver, you could extract the files in prowin32.exe and point to <folder where you extract the files>\PRO1000\Win32\NDIS5x folder using the have disk option for upgrading the driver.


              I know you said you are handy with the registry editor, but before editing the registry, try this. I am not confident this will work, but this is an easy thing to try:

              1. Make sure you have a copy of prowin32.exe. The latest copy is available at http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18717&lang=eng.
              2. Open Windows* device manager
              3. Right-click the network connection and choose uninstall
              4. Run the prowin32.exe software.


              Is your Ethernet connection working OK? Unless you are trying to fix a network issue, then you probably have nothing to gain by upgrading the software.


              There are some commercial registry cleaners out there that might also help you. I do not have experience with any of those products, so I cannot say what the end result of using one might be.


              As a last resort, you could reinstall Windows to get back to a clean registry.


              Let me know what you end up trying and what worked for you.


              Mark H

              • 4. Re: Help: Can't install Intel PROset, but can't un-install it either!

                HI Mark,


                Is it possible that Intel is giving him the wrong file to download and install. For instance, I first uninstalled the network connection in device manager and only that. Then I tried again to install (second time) and it had the same problem. I downloaded a unistaller since I could not "remove" it in the add/remove section. That worked for uninstalling.


                So, by this time, I've done the registry deletes from your intel recommendation. I deleted any (I think) association in driver cache since I originally had the problem of it reinstalling on me whenever I restarted. And I also tried disabling it in bios. So, long story short, nothing is working and I am convinced that it does not in anyway have any compatibility with my machine.


                The real snag here is that I have done already one other update which was for my chipset and it worked and always works without question, this however was not made to work.

                • 5. Re: Help: Can't install Intel PROset, but can't un-install it either!

                  Hi Ryan,

                  When you cannot uninstall the software, the most likely reason is that some expected file or registry setting is missing that is keeping the uninstaller from working. Sometimes you can restore the Windows state to an earlier date (if a restore point exists) where the uninstall will work. The new version of the software will not install, because of the same issue that prevents uninstalling the old software.


                  Intel Customer Support might be able to help you figure out a way to install the newer version of the softare. If you contact them, make sure you tell them everything you did up until now.


                  As a last resort, you might end up doing a clean install of Windows. That will get your registry back to a clean state where everything should work again. If you go with the clean Windows install, make sure you have all your personal files backed up.


                  I hate the time involved in doing a clean install, so I usually look for some additional benefit from spending the time. The last time I did a clean install of Windows, I took the opportunity to upgrade my hard drive to one that was larger and faster. I purchased an external drive case with a USB interface so I could have access to files on my old hard driver by plugging in the drive via USB. That gave me some assurance that I would not lose any personal files because I missed backing up something important.


                  I wish I had a straightforward solution for you, but this is the best I could think of. I hope this helps. Good luck.


                  Mark H

                  • 6. Re: Help: Can't install Intel PROset, but can't un-install it either!



                    I just solved the same issue in a Win 2008 R2 server by running the Fixit utility from Micxrosoft:




                    In my case, Recuva and Windows itself were not able to detect the installation of the Intel PROSet tools. The Fixit tool found it and uninstalled it.


                    Hopefully it helps someone else in the future.

                    • 7. Re: Help: Can't install Intel PROset, but can't un-install it either!

                      Running the Fixit utility from Micxrosoft worked for me as well. Told it to uninstall the Intel Network adapter and hen I was able to install the update driver. Thanks Chbarg.

                      • 8. Re: Help: Can't install Intel PROset, but can't un-install it either!

                        I have the same issue with a Lenovo ThinkCentre desktop.  New (clean) install of Windows XP SP3 from retail copy of Windows.  Downloaded the drivers from the Lenovo site, all drivers worked fine, except for the Ethernet driver. The system couldn't install the drivers giving me the same "intel proset is not supported for upgrades..." message and there are no adapters to be uninstalled in device manager and no Proset software installed in Add-Remove programs!!


                        If I call Intel support, surely they will refer me to Microsoft or Lenovo and my system has past the warranty period and they will ask me to use the recovery CDs or something, which I don't have.


                        If the downloadable drivers won't work, then something's wrong.....