10 Replies Latest reply on Mar 15, 2011 8:35 AM by edwardzh

    s5000pal srcsasrb gpt and efi




      I have a s5000pal motherboard, with a srcsasrb raid controller, with 5x 2Tb disks attached in raid 6


      Currently, I have a 32Mb usb stick plugged in as my boot drive, to load grub and my kernel, which then mount my linux root partition on the GPT partitioned 6 Tb array


      I want to get rid of the dependance on the USB drive


      On the array, I have a 256Mb FAT partition which hold my various grub/efi utilities


      In the EFI shell, when I run map, I do not see the Raid array at all, though


      If I run 'drivers', I don't  see any driver associated with the raid card.


      If I connect a USB stick formatted as FAT, with grub utilities on it, I can run grub in the efi shell, but grub can't see the raid partitions either.




      How can I see the raid array in the EFI shell - even better, how do I access the FAT partition on the RAID array in the EFI shell?


      Hope somebody can help...

        • 1. Re: s5000pal srcsasrb gpt and efi

          Well, I don't know a lot about this, but I hate to see anyone go unanswered.


          When you boot off your USB stick, that kernel loads the RAID driver for the SRCSASRB, therefore you can see everything


          When you boot to EFI, it's a fairly primitive shell, with no RAID driver loaded, so you can't see the RAID volume


          However, since you're using hardware RAID, you should be able to set the primary hard drive partition as bootable.  You'd have to edit your grub files inside that partition, naturally, but you could then boot straight up to the kernel installed on your RAID 6 hard drives, without using any USB.


          Am I coming close?

          • 2. Re: s5000pal srcsasrb gpt and efi

            You have the right idea, but not the right solution 


            I had not set the partition as bootable, so I have just tried that, with exactly the same results


            It seems like the EFI shell cannot see the raid array at all.


            Should the raid bios pass an EFI driver to the EFI subsystem? 

            Is there a way to load extra drivers in the EFI shell so I can see the raid array?


            A 'map' command only shows USB devices, and no PCI attached devices


            Any extra insight?

            • 3. Re: s5000pal srcsasrb gpt and efi

              I think what you need is booting from a GPT partition right?


              Since EFI can only access FAT partitions, normally an EFI-aware OS will create a small EFI partition (like 100MB) and install the EFI boot loader on that partition.


              Take a look at the white paper below. It's for Windows but Linux should work the same way. Note that when installing the OS, do NOT boot from the CD directly. Instead, enable "EFI Optimized Boot" from BIOS and boot to EFI shell, and then launch the boot loader from the CD. Then the OS installation program should take care of the rest. Hope that helps.



              • 4. Re: s5000pal srcsasrb gpt and efi

                Hi Edward


                I had already read the indicated white paper.  It states that it is for uEFI, whereas the S5000PAL only supports EFI as far as I can tell.


                In my BIOS, I do not see the options referenced in the paper:

                EFI Optimised Boot

                Use Legacy Video for EFI OS


                In my bios, those options do not appear at all.  I am using the latest available update for my motherboard.


                I had manually created a 256MB FAT partition as the first partition on the raid array (using GPT), The EFI shell cannot see this partition at all.

                • 5. Re: s5000pal srcsasrb gpt and efi

                  Oh sorry I missed the server board part... Indeed the white paper doesn't work with EFI. EFI doesn't have embedded RAID driver and thus can't see any partitions on the RAID array.


                  One workaround is to create a small VD on the RAID controller and make it a MBR disk. Install OS on it, and then create a second VD with the rest of your drive capacity, and make it a GPT drive for data storage.

                  • 6. Re: s5000pal srcsasrb gpt and efi

                    Hi Edward


                    I had thought of creating a smaller VD in the raid device, but could find no options to do that in the raid bios, or via the MegaCLI command


                    I have a single RAID6, taking up all 5 drive slots in the chassis.


                    Does the SRCSASRB raid controller support breaking a large RAID logical device into smaller virtual devices?


                    Many thanks



                    • 7. Re: s5000pal srcsasrb gpt and efi

                      Yes SRCSASRB does support breaking a large RAID logical device into smaller virtual devices.


                      When creating the VD, you can type the size of the VD:



                      For example, type 100 and select MB, and then click Accept to create a 100MB VD. Now click Back, and then Next to go to this screen again, you'll be able to create a 2nd VD.

                      • 8. Re: s5000pal srcsasrb gpt and efi

                        I did some more researches and found that for Linux, uEFI is not really required to boot from a GPT disk. Instead, what you need is a kernel supporting GPT, and a GPT-aware boot loader.


                        See if the following links are helpful for you:




                        • 9. Re: s5000pal srcsasrb gpt and efi

                          Hi Edward


                          Your suggestions have been most helpful


                          Splitting the raid device would would work, but I don't want to redo the entire installation


                          What I have done instead is create  a Bios Boot partition: http://en.wikipedia.org/wiki/BIOS_Boot_partition


                          This allows me to install grub2 directly to the device  and boot directly into grub


                          Thank you

                          • 10. Re: s5000pal srcsasrb gpt and efi

                            Good to know it worked