14 Replies Latest reply on Mar 3, 2011 5:34 AM by Arnis

    12.0 GB (3.93 GB usable)

    builderling

      Hello

       

      I've installed two modules of 4GB(2x2GB was) and now System properties shows that only 3.93 GB usable. BIOS shows all 12GB. Resource Monitor shows that 8259MB Hardware Reserved. How I can fix this and get all my amount of memory?

      Thanks advance!

      CPU i5 750, Windows Server 2008 R2 Enterprise x64

        • 1. Re: 12.0 GB (3.93 GB usable)
          builderling

          Sorry, forgot to specify: Motherboard DH55TC

          • 2. Re: 12.0 GB (3.93 GB usable)
            Doc_SilverCreek

            Are you sure you are using x64?

            (This would be the expected for the x32 version)

            • 3. Re: 12.0 GB (3.93 GB usable)
              parsec

              builderling wrote:

               

                    "I've installed two modules of 4GB(2x2GB was)...  BIOS shows all 12GB."

               

              I must say that there is an error in both the Product Guide and the  Technical Product Specification, which is identical in both documents.   They state that a maximum of 16GB of memory can be used, but then state  that only 1GB or 2GB DIMMs may be used in the total of four DIMM  sockets.  There are other discrepancies regarding memory in these manuals.

               

              Please see pages 9 and 15 of this document for details:

               

              http://downloadmirror.intel.com/18505/eng/DH55TC_TechProdSpec.pdf

               


              Your mother board might not support 4GB DIMMs.  You should contact Intel technical support to find out what the correct specifications are.


              If 4GB DIMMs are not supported, the values displayed by the Resource Monitor, etc, for the amount of memory will be unpredictable.  It might make a difference which DIMM sockets are used for the two different DIMMs.  Are they from the same manufacture?

               

              Also, with the correct memory modules installed, you will never see all of it available, as it may be used by several different things, including video cards, etc, that is normal.  The amount of memory displayed can be different depending upon the tool or hardware monitor you are using, and I have seen incorrect values shown in some of them.

               

              I hope we are not seeing a similar "missing memory" issue that is seen with i7-900 series CPUs with triple channel memory.

               

              Message was edited by: parsec

              • 4. Re: 12.0 GB (3.93 GB usable)
                Doc_SilverCreek

                The manual is referring to the individual memory IC on the DIMM.

                A  4096 MB Double Sided DIMM would contain 2 Gbit Technoligy x8 bits (2Gbyte) X 2 Sides = 4G DIMM.

                Since BIOS is seeing the full 12G he has installed (4g, 4g, 2g,2g), this does not appear to be a mother board or BIOS issue, which is why my suspicion is that somehow he loaded the 32 bit version of W2008 which is limited to seeing .......... 4G (less what the OS & BIOS steals for option ROMS space)

                 

                • 5. Re: 12.0 GB (3.93 GB usable)
                  parsec

                  OMGosh, how did I miss that?  Doh! (duh!)   My apologies, Doc is correct.

                   

                  One question that might provide a clue, do you recall what amount of memory that was listed when you just had the 2x2GB modules installed?

                   

                  Resource Monitor is a Windows tool, and with my 6GB of memory, it states 9MB is "hardware reserved".

                   

                  builderling's memory in Resource monitor seems to be 8259MB Hardware Reserved, and if the "Available" amount he quotes is also from Resource Monitor (not what he said) is 3.93GB, the total of those two is just over 12GB.

                   

                  This is a screenshot of Resource Monitor from my PC, Windows 7 64 bit, 6GB of memory:

                   

                  ResMon.PNG

                   

                  Perhaps builderling can post the Memory tab of his Resource Monitor.

                   

                  Does Windows 32bit list memory beyond 4GB as Hardware Reserved?

                  • 6. Re: 12.0 GB (3.93 GB usable)
                    builderling

                    Here is my x64 bits OS screenshots:

                    PCproperties.JPG

                    PCproperties1.JPG

                    taskManager.JPG

                    resourceMan.JPG

                    resourceMan1.JPG

                    please help, thanks!

                    • 7. Re: 12.0 GB (3.93 GB usable)
                      Arnis

                      I think it is Microsoft's not Intel's case

                       

                      For Win7-64 I found this

                       

                      Check the advanced boot options.
                      1. Go to Start, in the search bar type msconfig and press enter.
                      2. System Configuration window will open on the screen.
                      3. Click on tab named "boot".
                      4. Click on "Advanced Options" and uncheck the box for "Maximum Memory".

                      • 8. Re: 12.0 GB (3.93 GB usable)
                        builderling

                        Thanks Arnis, I tried to do this steps. "Maximum Memory" box already unchecked.

                        • 9. Re: 12.0 GB (3.93 GB usable)
                          Doc_SilverCreek

                          So it apears that Windows does see the memory, but has it marked as hardware reseved.( I don't think you could add enought hardware to use 8G of memory)

                           

                          Try a screen shot of this :

                          launch "devmgmt.msc", select Resources by Connection in the View Menu, and expand the Memory node.(and all the nodes under which ever one has a huge range).

                          The memory range of each device is listed in hex (which I slightly better than binary i guess)

                          With windows calculator in scientific mode (under view) you can click hex then enter the second number and subtract the first number.

                          Then click decimal to get a number folks can relate to.

                           

                          i.e

                          My laptop on windows 7 shows:

                          00000000e0000000 -- 00000000effffffff Mother board resources

                           

                          which would  be

                          0000 0000 efff ffff - 0000 0000 e000 0000 = fff ffff or 268435455 decimal or 268M memory being used by my laptop mother board.

                           

                          Someplace you have a device claming a range of about 2 0000 0000 (8G)

                          (most likley a driver error)

                          • 10. Re: 12.0 GB (3.93 GB usable)
                            parsec

                            Doc, I checked out Windows Server 2008 R2, and it is available only in a 64 bit version.  That from Microsoft's web site.

                             

                            A simple search revealed that large amounts of installed memory in the Hardware Reserved state is a common problem.  Some of the causes and fixes were:

                             

                            1. Improper seating or mounting of the CPU, or dirt between the socket contacts and CPU contacts.  Remount CPU and/or clean contacts (carefully!!!)

                             

                            2. Bent or damaged CPU socket contact.  Repair contact or replace mother board.

                             

                            Note:  An improperly mounted CPU cooler can cause both 1 and 2 to occur.

                            Note:  Over-clocking CPUs on socket 1156 platforms (more accurately, over-volting the CPU) has been known to cause melting/burning and deterioration of the socket's contacts

                             

                            3. Memory modules (DIMMs) not installed in appropriate slots.  Consult mother board manual for instructions.

                             

                            4. Different types of DIMMs installed together.  Use same type of DIMMs.

                             

                            5. Mother board chipset does not support amount of memory installed.

                             

                            6. Incorrectly configured BIOS or Windows settings.

                             

                            From what I read about this, the majority of the successes in overcoming this issue were due to having and fixing problems 1 or 2.  Inappropriate combinations of DIMMs was a distant third.

                             

                            Doc, apparently it is not a problem to use a Windows Server type of OS on a mainstream mother board?  Would any of the virtual memory management features those OS's support cause an issue, since the BIOS of a mainstream mother board might not support the OS appropriately?

                            • 11. Re: 12.0 GB (3.93 GB usable)
                              Doc_SilverCreek

                              Possibly.

                               

                              Desktops do not normally qualify or certify on server OS versions and likewise, servers do not normally qualify the desktop OSes.

                              (Workstations are kind of a cross over and do test both.)

                               

                              Stranger things have been know to happen.

                               

                              Mixing DIMMs can also cause some very strange issues. It would be interesting to see what is reported with just the 2 new 4G DIMMs installed

                              1 of 1 people found this helpful
                              • 12. Re: 12.0 GB (3.93 GB usable)
                                builderling

                                I've tried to install only 8GB and it's works!

                                So, the answer for my situation is: Always install modules with bigger capacity in first channel sockets only.

                                I've installed 2x4GB in Channel A and 2x2GB in Channel B and all works correctly. All 12 GB are visible and usable.

                                Thanks for your time guys and especially for you, Doc

                                • 13. Re: 12.0 GB (3.93 GB usable)
                                  Arnis

                                  Interesting that Intel didn't mention this.
                                  I have an old single memory channel AMD system from SUN where is mentioned that largest memory module must be placed at first slot always.

                                   

                                  P.S. You can now try to swap slots again to see if the problem returns (Maybe Windows somehow reinitialized memory configuration when 4GB was missing and now it works both ways). If problem returns, Intel definitely must upgrade their documentation.

                                  • 14. Re: 12.0 GB (3.93 GB usable)
                                    Doc_SilverCreek

                                    You betcha.

                                     

                                    (A guy has to have something to do while watching Hulu at night. )