5 Replies Latest reply on Feb 26, 2011 11:58 PM by Infra_HDC

    DH55HC + 4 x 2GB DDR3-1333 with 4Gb Memory Limit Problem

    Infra_HDC

      Hello all !

       

      My system:

      1. Mainboard Intel DH55HC

      2. CPU i7-860

      3. RAM 8Gb: 4 x 2Gb DDR3-1333MHz Kingston 99U5403-003.A00LF

      4. uname -a

      Linux infra 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:44 UTC 2011 x86_64 GNU/Linux

      5. CMOS SETUP, main menu says that Total Memory is 8192M

      6. "dmidecode --type memory" also says that 4 x 2048M modules installed

      7. POST reports NO memory problems

       

      Problem is e820 says to my memtest86+ 4.20 and my 64-bit OS that memory size is 4029M, thus 50% of memory in use.

      BIOS update from 0037 to the 0044 latest version doesn't solve a problem.

       

      Prev. usage of these CPU and RAM with other vendor mainboard were without such problems.

       

      Your suggestions?

        • 1. Re: DH55HC + 4 x 2GB DDR3-1333 with 4Gb Memory Limit Problem
          Infra_HDC

          Up: temporary freeing all of PCI Slots (except PCI Express VGA) doesn't solve problem:

           

          temporary lspci -n is:

           

          00:00.0 0600: 8086:d131 (rev 11)
          00:03.0 0604: 8086:d138 (rev 11)
          00:08.0 0880: 8086:d155 (rev 11)
          00:08.1 0880: 8086:d156 (rev 11)
          00:08.2 0880: 8086:d157 (rev 11)
          00:08.3 0880: 8086:d158 (rev 11)
          00:10.0 0880: 8086:d150 (rev 11)
          00:10.1 0880: 8086:d151 (rev 11)
          00:16.0 0780: 8086:3b64 (rev 06)
          00:16.2 0101: 8086:3b66 (rev 06)
          00:16.3 0700: 8086:3b67 (rev 06)
          00:19.0 0200: 8086:10f0 (rev 06)
          00:1a.0 0c03: 8086:3b3c (rev 06)
          00:1b.0 0403: 8086:3b56 (rev 06)
          00:1d.0 0c03: 8086:3b34 (rev 06)
          00:1e.0 0604: 8086:244e (rev a6)
          00:1f.0 0601: 8086:3b06 (rev 06)
          00:1f.2 0106: 8086:3b22 (rev 06)
          00:1f.3 0c05: 8086:3b30 (rev 06)
          01:00.0 0300: 10de:05e2 (rev a1)

           

          at the moment lspci -n is:

           

          00:00.0 0600: 8086:d131 (rev 11)
          00:03.0 0604: 8086:d138 (rev 11)
          00:08.0 0880: 8086:d155 (rev 11)
          00:08.1 0880: 8086:d156 (rev 11)
          00:08.2 0880: 8086:d157 (rev 11)
          00:08.3 0880: 8086:d158 (rev 11)
          00:10.0 0880: 8086:d150 (rev 11)
          00:10.1 0880: 8086:d151 (rev 11)
          00:16.0 0780: 8086:3b64 (rev 06)
          00:16.2 0101: 8086:3b66 (rev 06)
          00:16.3 0700: 8086:3b67 (rev 06)
          00:19.0 0200: 8086:10f0 (rev 06)
          00:1a.0 0c03: 8086:3b3c (rev 06)
          00:1b.0 0403: 8086:3b56 (rev 06)
          00:1d.0 0c03: 8086:3b34 (rev 06)
          00:1e.0 0604: 8086:244e (rev a6)
          00:1f.0 0601: 8086:3b06 (rev 06)
          00:1f.2 0106: 8086:3b22 (rev 06)
          00:1f.3 0c05: 8086:3b30 (rev 06)
          01:00.0 0300: 10de:05e2 (rev a1)
          02:00.0 0200: 10ec:8185 (rev 20)
          02:01.0 0480: 1131:7134 (rev 01)

          • 2. Re: DH55HC + 4 x 2GB DDR3-1333 with 4Gb Memory Limit Problem
            JasonACS

            As you probably already know, the DH55HC supports up to 16GB and can use 2GB modules with either 1 or 2 Gbit densities.  I have the DH55TC (they share the same BIOS) running with two 4GB Kingston modules, and 8GB is shown in memtest86+.  What Kingston model are you using?

             

            If you google 8GB and an Intel board, you will actually find several threads where people describe random restarts.  They are using four 2GB modules, and claim the problem goes away when using two 2GB modules.  Nothing about not detecting the 8GB.

            • 3. Re: DH55HC + 4 x 2GB DDR3-1333 with 4Gb Memory Limit Problem
              Infra_HDC

              JasonACS wrote:


              What Kingston model are you using?

              Thank you for reply!

               

              Memory modules model is Kingston KVR1333D3N9/2G

               

              UP: this model is in 3rd Party Tested Memory* list:

              http://www.cmtlabs.com/mbTestSummary.asp?bNav=True&sTestNum=017230

              also see head of the list at link: http://www.cmtlabs.com/mbSearchResults.asp?sManuf=Intel&sMem=DDR3&sMN=DH55HC&oSubmit=Search

              that is from link: http://www.intel.com/support/motherboards/desktop/dh55hc/sb/CS-030953.htm

               

              Message was edited by: Infra_HDC

              • 4. Re: DH55HC + 4 x 2GB DDR3-1333 with 4Gb Memory Limit Problem
                JasonACS

                We've built and sold 51 desktops with a DH55TC and two KVR1333D3N9/2G.  In all that time I never tried adding two more.

                 

                Anyway, you shouldn't be having this problem.  I take it you don't have another set of memory or another board to troubleshoot with?

                1 of 1 people found this helpful
                • 5. Re: DH55HC + 4 x 2GB DDR3-1333 with 4Gb Memory Limit Problem
                  Infra_HDC

                  Problem solved ?!

                  ... after I replace modules by each other:

                  CHANNEL B DIMM 0 <--> CHANNEL B DIMM 1

                  CHANNEL A DIMM 0 <--> CHANNEL A DIMM 1

                  To replace modules I temporary remove VGA Card and CPU FAN.

                  Now memtest86+ shows 8125M amount.

                  Under OS it also shows correct memory size:

                  $ free -m
                               total       used       free     shared    buffers     cached
                  Mem:          7934       2367       5566          0         65        715
                  -/+ buffers/cache:       1586       6347
                  Swap:        32773          0      32773

                  It is two strange things:

                  1. System uptime with problem was about 16 days without other problems (except slowdown when I ran guest Win7 32bit with 2G RAM under Virtualbox)

                  2. After problem solved, i ran memtest86+ 4.20 it shows some unusual values:

                  Chipset: Core IMC (ECC: Disabled) / BCLK: 10 MHz

                  Settings: RAM: 54Mhz (DDR3-109) / CAS: 9-9-9-24 / Dual Channel

                   

                  0th Pass WallTime was 0:50:50

                   

                  May be were bad contacts between memory modules and slots ? 0_ะพ

                   

                  Now system works fine!

                   

                  JasonACS Thanks for attention!

                   

                  Message was edited by: Infra_HDC