0 Replies Latest reply on Feb 23, 2011 6:08 AM by penartur

    Slow sequential HDD transfer speed on H55 AHCI for some HDDs

    penartur

      Currently i experience a strange problem on my system, i'm not sure if this is right place to ask about it, but i cannot think of any other possible reason.

       

      The system is based on Intel H55 chipset plus Core i3 CPU (with integrated graphics enabled); 6GB RAM, swap/pagefile disabled; there are 5 HDDs connected to the integrated Intel SATA controller, which is set to be in AHCI mode. OS is Windows Server 2008 R2 SP1 (RTM), Standart edition, with Hyper-V installed and used.

       

      The problem is that with some of that 5 HDDs i experience terribly slow transfer speeds. When testing HDDs with HD Tune, i'm getting:

       

      • about 60MB/s for Western Digital WD1600BEVS (160GB 2.5" SATA1)
      • about 100MB/s for Samsung HD103SI (1TB 3.5" SATA2)
      • about 100MB/s for Western Digital WD15EADS (1.5TB 3.5" SATA2)
      • 5MB/s for Samsung HD203WI (2TB 3.5" SATA2)
      • 2MB/s for another Samsung HD203WI, purchased in another time and another place

       

      Also, HDD "Highest active time" in Resource Monitor is about 80-90% for all HDDs speed tests except HD203WIs; when testing any of HD203WIs, "Highest active time" goes up to 100%.

       

      I installed WS2k8R2 SP1 just recently, before that i've used Windows Server 2008 x64 SP2 (because of infamous Hyper-V R2 and Core i3 GPU incompatibility problem); and as far as i remember transfer speeds were normal under that old OS.

      I thought that maybe some other software is putting some random load on HD203WI, which conflicts with HDTune testing, so i put both HD203WI in an "offline" mode. The problem persisted.

       

      Then i thought that maybe HDDs are dying (although this is hardly probable because i purchased these two in different places and in different time; and HDTune says that their S.M.A.R.T. is okay), but i tried to connect these through USB-SATA bridge, and when testing sequential read with HDTune, i got 30MB/s (i guess this is limitation of either USB or that chinese USB HDD enclosure i've used). I guess that eliminates the possibility that the problem is caused by HDD.

       

      Then i thought that maybe there is some problem with corresponding SATA ports on the motherboard or with SATA cables, so i interchanged (hot-swapped) one of that HD203WI with HD103SI. But still 5MB/s on HD203WI (despite using other cable and port) and still 100MB/s on HD103SI (despite using the same cable and port which HD203WI used).

       

      I also tried to replace the AHCI drivers that came with windows "out of box" with ones Intel packs with their "Rapid Storage Technology" software, still with no success.

       

      So, the problem is clearly caused not by HDD (or transfer speeds through USB-SATA bridge would be significantly lower). It is clearly caused not by HDD seat (or after interchanging HD203WI and HD103SI, the former would work faster and the latter would work slower).

       

      Currently, i only can think about some HD203WI, Intel 5 Series SATA controller and Windows Server 2008 R2 SP1 incompatibility.

       

      What are another reasons you can think about? How can i do some further diagnosis?