0 Replies Latest reply on Feb 21, 2011 9:38 AM by dhar

    Bug in SSD Optimizer involving doskey.exe(!)

    dhar

      I just installed a 120GB X-25M G2 into my Asus P7P55D Pro system, and after patching to firmware 2CV102M3, installing Windows 7 x64 w/ SP1 and a bunch of programs, including the INF update and Rapid Storage 10.1.0.1008 first thing, after a couple of days I decided to run SSD Optimizer from the SSD Toolbox 2.0.1.000. It made it to 7% before proceeding to crash 17 times in Doskey.exe before finishing successfully. This is reproducible, and it's due to my using an obscure but useful cmd.exe feature, of all things. I always set "HKCU/Software/Microsoft/Command Processor/AutoRun" to a batch file that currently happens to contain exactly 17 Doskey macro definitions, such as "DOSKEY LS=DIR /O /X /N $*". This gives me some Unix-like command name synonyms as well as other useful command synonyms I made up. Putting it in the registry ensures it runs for all command prompts, no matter how they're started, and it has always worked fine for both normal and elevated prompts. But somehow Intel's SSD Optimizer doesn't like it, even though it doesn't visibly run cmd.exe. I can avoid the problem by renaming the AutoRuns value to "zAutoRuns", but when I rename it back to "AutoRuns", I get the 17 doskey crashes again when I run SSD Optimizer. Doesn't seem to hurt anything, but it gave me a scare, and obviously, it shouldn't be happening. Here is a sample event log entry for one of the identical 17 crash entries:

       

      Log name: Application

      Source: Application Error

      Event ID: 1000

      Level: Error

       

      Faulting application name: doskey.exe, version: 6.1.7600.16385, time stamp: 0x4a5bbffe
      Faulting module name: doskey.exe, version: 6.1.7600.16385, time stamp: 0x4a5bbffe
      Exception code: 0xc0000005
      Fault offset: 0x00001bd3
      Faulting process id: 0x1368
      Faulting application start time: 0x01cbd1e04715caf4
      Faulting application path: C:\Windows\SysWOW64\doskey.exe
      Faulting module path: C:\Windows\SysWOW64\doskey.exe