2 Replies Latest reply: Feb 21, 2011 8:13 AM by gustaav RSS

The "Advanced" tab of the Intel 82566DM-2 Ethernet adapter driver is missing

gustaav Community Member
Currently Being Moderated

I'm managing a computer laboratory. I have some issues with some software that requires changing some advanced configurations of the network driver. The problem is that when I go into Device Manager and open the network adapter driver, there is no "Advanced" tab. It's really strange because, sometimes the "Advanced" tab shows up, but after rebooting, it dissapears again. The problem is with all the 28 computers in the lab. They all are running on Windows XP and has the Intel 82566DM-2 Ethernet adapter. I've downloaded the last driver available and even the "Administrative Tools an Diagnostics" v16, and no luck at all.

 

Any ideas to solving this annoying issue? It's really urgent! Thanks in advance!

  • 1. Re: The "Advanced" tab of the Intel 82566DM-2 Ethernet adapter driver is missing
    MARK HANNA Community Member
    Currently Being Moderated

    I cannot think of any obvious reason why the Advanced tabs are not showing up on your computers. I have a few questions that might help with narrowing down the issue.

     

    Are you logging in locally to the computers or using a remote connection? If you are logging in remotely, does the tab show up when you login locally? If you do not have administrative permissions on the remote connection (or on the local connection for that matter) some configuration items will not be available.

     

    Are you running Windows XP as a guest in a virtual machine?

     

    Have you disabled any Windows services on the lab computers that are normally enabled by Windows? Windows management instrumentation must be enabled for tabs to display correctly.

     

    Do you have any teams or VLANs configured on the adapters? Here is something you can try if you do not need to configure teams or VLANs. Uninstall Intel Network Connections from the control panel. Completely remove all components including the base drivers. Then do a fresh install without Intel PROSet and without Advanced Network Services. Does that bring back the advanced tab? If yes, then at least your issue is resolved even if we do not know the root cause.

     

    If you cannot figure out a way to make the Advanced tab appear, you could use command line tools to configure the advanced setting that you want to change.

    How do I configure advanced features in Windows Server 2008* core installations? has information about prosetcl command line utility. The command line utility will work on any version of Windows even though it was meant for core installs that do not have a GUI. You do have to install PROSet and not just the base drivers for this utility to be available and work on your computer.

     

    Check out this reply for an example of using prosetcl to set speed and duplex.

     

    I hope this helps you find a solution.

     

    Mark H

  • 2. Re: The "Advanced" tab of the Intel 82566DM-2 Ethernet adapter driver is missing
    gustaav Community Member
    Currently Being Moderated

    Hi Mark! Thanks for your response.

     

    I'm logging locally in the computers with the administrator account. I've not disabled any Windows services. I even tried once to uninstall completely the driver and reinstalled again.

     

    Let me explain a little more details of the lab use. Each computer has 2 partitions, one that is free and any student can use it and the other is controlled. This other partition is used to run economical experiments under a controlled environment, and the software that we use to run this experiments has problems with Intel Pro1000 network cards (https://www.uzh.ch/iew/ztree/ssl-dir/wiki/index.php?n=Main.Bugs), so the software manufacturer recomends to disable "Performance options" on Advanced Tab. When I check the computers, the driver installed was too old and the "Advaced" tab didn't includ any "Performance options" item, so I downloaded the latest PROSet and installed in all computers. The rare thing is that in some computers, after installing the ProSet, the "Advanced" tab apperas among othe new tabs normally, but not in all computers, in other computers, the "Advanced" tab just dissapears. Then, the computers that have the "Advanced" tab working well, after rebooting... the tab dissapears. I don't really know what's happening, because, with the older driver at least it was showing the "old" "Advanced" tab. I don't know if I explain myself well... my english is not 100% good.

     

    If nothing works we are planning to install Windows 7 in all machines hoping that there will be no problems then.

     

    I will try to use command tools as you mentioned and I'll let you know if that works.

     

    Thanks in advance!

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points