0 Replies Latest reply on Feb 16, 2011 1:19 AM by allexch

    i/oat int xeon 7500

    allexch

      Hi. I have a question related to i/oat on Xeon 7500 chipset.

      My company bought supermicro server with :

      • Intel® 7500 (Boxboro-EX) chipset
      • ICH10R

      I installed 2 10G intel NICs(82599EB) and the latest ixgbe driver (v3.2.9).

      When bandwith crosses threshold of  3 Gbit/s the packet loss appears. Such behavior looks like that I do not use i/oat.

      I found it in "Accelerating High-Speed Networking with Intel® I/O Acceleration Technology" pdf document.

       

      That is the dmesg ouput:

      ----------------------------

      ixgbe: eth3: ixgbe_probe: No DCA provider found.  Please start ioatdma for DCA functionality.

      ----------------------------

       

      In the README file of ixgbe driver I found:

      DCA - Direct Cache Access

      -------------------------

      Valid Range: 0, 1

      0 = Disables DCA support in the driver

      1 = Enables DCA support in the driver

      Default Value: 1 (when IXGBE_DCA is enabled)

      See the above instructions for enabling DCA.  If the driver is enabled for

      DCA this parameter allows load-time control of the feature.

      ----------------------------

       

      And the last one output is from my kernel:

       

      cat /etc/kernels/kernel-config-x86_64-2.6.37-gentoo | grep IXGBE_DCA

      CONFIG_IXGBE_DCA=y

      ----------------------------

       

      Unfortunately i could not find how to enable this feature in BIOS, there is no sign of it. The Supermicro support team said that this feature is enabled by default in this chipset.

       

      I use gentoo OS and i tried 2.6.35, 2.6.36, 2.6.37 and 2.6.38 kernel versions, but it did not help.

       

      By the way on another server lspci shows:

      ----------------------------

      System peripheral: Intel Corporation 5520/5500/X58 Chipset QuickData Technology Device (rev 22

      ----------------------------

      I guess it is i/oat.

       

      And on new one I do not see such string.

       

      So I am wondering how to enable this feature and how to determin that it works?