1 2 3 Previous Next 91 Replies Latest reply on Nov 27, 2011 2:25 PM by swamphawk

    Marvell (RAID) SATA 6 Gb


      I've been trying to use the Marvell SATA 6 controller to setup a boot raid drive.


      I have been unable to find any useful documentation about this chipset.

      Nearly every motherboard manufacturer has this Marvell SATA 6 chipset on their latest boards, and none of them work.


      Intel's documentation mentions the Marvell eSATA controller, but not the SATA 6.

      The documentation available about the SATA 6 chipset is incorrect and does not cover how to create a bootable RAID array.


      It's as if the Marvell chipset is the crazy uncle in the basement nobody wants to talk about.


      I've tried every combination of settings and sequence of installation procedures imaginable without success.

      Every attempt to create a boot array ends with Windows failing.


      Is there a document or thread that explains how to use the 6 Gb/s chipset so proudly featured in the product description?

        • 1. Re: Marvell (RAID) SATA 6 Gb

          Rob,  You didn't really explain what software or interface (BIOS?) that you are using to configure your RAID system.


          Intel uses the Marvel 88SE9128 controller on some of their mother boards, which is a common one.  There is a link to the Marvel Raid Utility on those mother boards Downloads page.  Intel also has a link to a Marvell document that might be what you are looking for:




          Is this what you are looking for?

          • 2. Re: Marvell (RAID) SATA 6 Gb

            Ok. Less rant, more info.


            I'm attempting to configure a DX58SO2 to boot to a RAID 0 array using the Marvell 6Gb SATA ports.


            Using two identical Western Digital Caviar Black SATA 6 Gb/s I created one RAID 0 array using the Marvell bios configuration utility.


            Booting to a Windows 7 Ultimate installation DVD, I run the install utility (custom mode), load the 64bit mv91cons driver (have also tried loading the mv91xx driver, then both drivers in sequence, also tried install without either) and continue the install routine.


            Windows install proceeds to copy files, unpack them, then fails. The hard drive led flashes once per second continuously for 10 minutes or so, then Windows displays an install failure message (sorry, don't have the displayed message in front of me but can supply it later today.)


            I've tried booting to a freshly installed Windows 7 hard drive connected the Intel SATA port 1 (DVD drive on 0), then creating the RAID 0 array in Windows, rebooting, then attempting to run the install routine again, still fails.


            The CPU is the Intel Core i7-980X Extreme 3.33GHz BX80613I7980X running at default speed.

            All of the DX58SO2's settings are default.


            Lastly, if I install Windows on one of the WD drives without creating a RAID array, the other drive cannot be initialized.

            The Marvell SATA controller cannot be used for JBOD.


            Have I left anything out?

            • 3. Re: Marvell (RAID) SATA 6 Gb

              One other item to mention, going back to my original rant, is that the documentation you reference is not for the Marvell controller in question. The documentation covers RAID 10 arrays and a windows GUI I have so far been unable to locate on the properly configured (using the Intel install DVD) drive.

              I can't imagine why Intel engineers would go through the trouble of integrating the SATA 6Gb/s Marvell chip into the I/O controller (through PCI Express x1) then not mention it in the documentation. I know the eSATA interface is mentioned, but doesn't cover the SATA 6Gb/s part.



              • 4. Re: Marvell (RAID) SATA 6 Gb

                Ok, so what is the Marvell controller that you have on your mother board?


                I thought I mentioned previously that the Marvell utility is available on the Downloads page for your mother board.

                • 5. Re: Marvell (RAID) SATA 6 Gb

                  I discovered that the marvell tray app doesn't work with Google Chrome. Using IE I was able to start the GUI.


                  I created a RAID array using the Marvell utility. So far so good.

                  I then opened Windows disk manager, created a partition, then attempted to format the new drive.

                  The format failed. The drives "disappeared". Windows system log file simply stated the drives had become unavailable.

                  Marvell utility basically said, "What drives?"

                  Both hard drives became invisible to the Marvell tray app and the OS.

                  I achieved the same result twice more after rebooting the system.


                  Either I'm clueless about how to configure this board, or this system is unstable for reasons I can't fathom.

                  I'm hoping the problem is the first, because ignorance can be cured. An unstable system is a lot harder to fix.



                  • 6. Re: Marvell (RAID) SATA 6 Gb

                    I've checked out your DX58SO2 mother board's Technical Specification, and it does use what is usually simply called the Marvell 9128 chip, with support for SATA 6Gb/s on two SATA ports.  That chip does support RAID.


                    I have an ASUS mother board that uses the Marvell 9128 chip, and the BIOS has a section for the initial configuration of drives connected to the Marvell SATA ports.  The Marvell Raid Utility (MRU) comes on the mother boards driver disk, and is accessed by pressing <Ctrl> M during POST.


                    I noticed in the DX58SO2 manual, that a RAID array using external HDDs via the Marvell eSATA interface is described, and the BIOS configuration for the drives is accessed by pressing F2 during POST, and the MRU is accessed by entering <Ctrl> M during POST, just as with my ASUS mother board.


                    I don't see in the DX58SO2 manual how to configure RAID on the Marvell controller via it's 6Gb/s SATA interface, it is not mentioned at all.  My ASUS mother board does have the Marvell RAID on the SATA interface connections.  The question now is, can you even do what you are attempting on the DX58SO2.  But, you know that.  It is not described in the manual that I can see, as you know.


                    Unless someone here knows the answer (I don't), you should directly contact Intel technical support to answer your question.  Don't wait for tech support to reply in the forum, that's not how they do things.  The download page for the DX58SO2 will have all the drivers, utilities, BIOS, etc, that it is intended to be used with it, which will give you a clue as to what it can and cannot do.


                    It seems it is possible that the Marvell RAID via it's standard SATA connections is not available on this mother board.  The Intel RAID interface is available, and even if it is implemented with the SATA 3Gb/s connections, I doubt that the Marvell interface would be faster.  Anyway, good luck.

                    • 7. Re: Marvell (RAID) SATA 6 Gb

                      Marvell 88SE91XX controller, bios ver


                      First, the latest Intel BIOS 0752 fixes the problem with initializing and formatting the Marvell RAID array under Windows 7.

                      I can now create a RAID 0 or 1 array and use it as a data drive.

                      That's the good news (and I'll take all the good news I can get.)


                      Windows 7 Ultimate and Ultimate with SP1 still cannot install a bootable system configuration on a Marvell BIOS configured RAID array.

                      If I create a new virtual array (as Marvell calls it) with no MBR and then run the Windows 7 install routine, it will create two partitions (Windows 7 configures two partitions on new systems) and then halts.


                      Error messages can vary. Windows 7 Ultimate generated three different error messages and Windows 7 Ultimate SP1 displayed it's own.

                      I have a Microsoft TechNet Plus subscription that gives me access to all of their operating systems, server software, and applications. I can download and cut to DVD any Microsoft OS. This is just to explain that I am using the latest available version of Windows 7 and not a pirated or system specific install disk.


                      I also have two new Asus boards. Their Marvell chipset is exactly the same, only worse. I can boot the Asus board once and it sees both drives. I reboot and it only sees drive 0, then the next reboot is sees only drive 1. Most of the time it fails to find either drive. That's why I decided to give the Intel board a try.


                      Intel's products are exceptionally well engineered. The board layout is beautiful. Everything is well marked and the documentation is excellent. There is no "but" to this statement. I am truly impressed with this motherboard.


                      I'm also very impressed with Intel's updated BIOS that fixed the problem I mentioned at the top of this post. I feel confident that Intel is working to make this board a winner.


                      I will follow your advice and contact tech support. I wanted to wait until I could provide detailed information about the installation failure modes. Now that I can configure the Marvell array as a data disk, I can use the board.



                      • 8. Re: Marvell (RAID) SATA 6 Gb

                        I have a similar issue with these blue SATA connector on the BX58SO2 board. I am using an Intel SSD on a 'regular' black SATA Intel SATA port for the system (Win 7 Pro). That worked without any issue, and my system is up and running.

                        Then I had 2 identical WD Caviar Black 1TB disc on these blue port and configured them as RAID1. After discovering and fideling with the Ctrl M (on a non-english keyboard, it is something else ! Ctrl ,), I was able to set up the 'virtual' disc as Marvell calls it. Seems to work fine until I start using it. I put some data on it, and when I reboot, I have chkdsk that runs every time. When it terminates (screen goes away very fast) I think I have seen that there is still an error. Then when I try to check the disc from within Win7 (right click on the disc, porperties, tools, check disc now), that window vanish without leaving any status screen. When I go to Defreg, the virtual Marvell disc does not appear anylonger !


                        I am using all the latest drivers, ... that I can think off. Please help. I was hoping to get a fast redundant storage with that board! I am getting nowhere right now.




                        • 9. Re: Marvell (RAID) SATA 6 Gb

                          RobK, the symptoms or errors you describe, the missing disk drives upon reboot, is the usual complaint of users of the Marvell interface, as I have read many times in the ASUS forum for a mother board of theirs I own.   I have never experimented with the Marvell RAID configuration, but I now have two identical HDDs that I will test on the Marvell interface on my ASUS board.


                          How is your RAID setup doing on the Intel board, is it functioning well?  Are you seeing any of the missing drives again?  Just checking on how things are going for you.

                          • 10. Re: Marvell (RAID) SATA 6 Gb

                            On the DX58SO2, I am not seeing the drive disapear, they always show up, but so is Chkdsk everytime I boot up the system, and it does terminate on an error. Then I tried to run chkdsk from within Win7. Chkdsk lists many many errors on index mostly, tells me they are all fixed. I restart chkdsk, and I get even more errors, sometimes it terminates correctly, most of the time, the screen disapear without notice! The files seems to be there... but how can I rely on this redundant disc that generate so many, random errors? this is a real disaster, Marvell is not marvellous ! and I don't know what to do.

                            I guess, I'll put a jumper to limit the speed to 1.5G (instead of 6G) on those 2 discs, and check if the RAID from Intel works better. I had so many RAID issues with Intel previously that I was hoping to get better performance and more reliability with those SATA III bule ports.


                            Any hint from Intel? any advices?

                            Thanks Francois.

                            • 11. Re: Marvell (RAID) SATA 6 Gb

                              parsec, did you see the date of that document? 2006 !! I guess it is a little outdated.

                              And I have not been able to get any utility to manage that Marvell RAID from within Windows. The only way to access some sort of console, is during the boot process, by pressing Ctrl M at exactly the right time.

                              Do you have an utility that load into Win7 to help manage that RAID?



                              • 12. Re: Marvell (RAID) SATA 6 Gb

                                Francois, All I could do is supply a link to the document that Marvell and Intel provides, users said they lacked such a guide, and I found one.  Whether or not it is up to date, I can't tell you.  Marvell provides nothing on their web site.  Which implies it is up to the manufactures that use Marvell's products to provide the correct documentation.  It is possible that the UI for Marvell's RAID software has not changed since 2006.  The manual for an ASUS mother board I own has a section on the Marvell Raid Utility (MRU), and is only four pages.  The MRU is what you access by pressing <ctrl> M during POST, there is nothing else I am aware of.


                                Why would I have software for use with the Marvell interface, and not share it with everyone?

                                • 13. Re: Marvell (RAID) SATA 6 Gb



                                  I appreciate your contributions. I was just wondering if I had missed something, as you were metionning a utility than I did not seemed to have, but I misunderstood that the 'utility' is in fact what I have in the BIOS, and that there is nothing else. And I apprecite your cross expertise with the Asus board that I do not have.

                                  Thanks, Francois

                                  • 14. Re: Marvell (RAID) SATA 6 Gb

                                    May I inquire why you actually want to use the Marvell controller? I can't see any good reason for it - your HDs may have an SATA3 interface, but they do not in any way benefit from using it.


                                    The Marvell controller is generally crummy for anything beyond additional sequential transfer capability on single SSD drives versus SATA2... and the reduction in other performance areas generally makes up for it. The Marvell can't even sustain full SATA3 speeds on a single port, never mind two, since it's only connected via a single PCIe lane, which means it maxes out at ~350MB/sec or so.


                                    If your concern was lack of trim for your SSD when hooked up to the controller in RAID mode, then Intel's new drivers now pass trim to SSDs that are on the RAID controller, but not part of a RAID array.

                                    1 2 3 Previous Next