1 2 3 Previous Next 30 Replies Latest reply: Jan 24, 2014 2:25 PM by joe_intel Go to original post RSS
  • 15. Re: I keep getting "Could not obtain network address" msg
    Community Member
    Currently Being Moderated

    @Rick The virtual miniport should get an IP address from the Intel My WiFi technology software, which includes a DHCP server and DNS. The 192.168.16.* address range sounds correct; that is the default.  As I stated previously, the laptop serves as the AP for the Netgear device to connect into so the Netgear should receive an IP in that range from the laptop.  There is connection security using WPA, but WiDi sets the key. If you've changed the key on the Intel Wireless PAN profile, you definitely see the problems you're describing.

     

     

    @Guest You can find the DHCP properties for the WiDi connection in the  My Wifi technology UI. You can get to that by pressing the windows key and typing "my wifi"; the application should appear in the selection box.  Click "Options" in the upper right and select DHCP tab. It's usually set to 192.168.16.* but yours may be something different.  With respect to the wireless driver version, 13.5 should work as well as 14.x.  The former is here and the latter should be available on downloadcenter.intel.com.

     

    Shashi

    Intel WiDi - Applications Engineer

  • 16. Re: I keep getting "Could not obtain network address" msg
    Currently Being Moderated

    I would say the cannot obtain network address is a pretty common issue.

    Several of my collegues have the adapter - and I am the only one with my adapter left - the other's binned their adapters.  All of us have Sony Vaios.

     

    Such a shame - I won't be getting an Netgear product again as I am so disappointed that this product has only worked the first couple of times I used it.

  • 17. Re: I keep getting "Could not obtain network address" msg
    garryweil Community Member
    Currently Being Moderated

    Make sure you have the Intel PROSet/Wireless WiFi driver 13.3 or later installed. Last year some of the Sony systems had a BIOS issue that conflicted with the WiFi driver. This was resolved in the WiFi driver 13.3. Look and see what BIOS version you have. Also laptop make and model number do you have? What is the graphics driver version?

  • 18. Re: I keep getting "Could not obtain network address" msg
    TTN Community Member
    Currently Being Moderated

    hi,
      I found the same problems with driver versions right up to 14.2.
    There is a new version 14.3 from January 2012 which fixed the problem for me.

     

    This page (works best in IE)
    http://www.intel.com/p/en_US/support/detect/wireless

    checked my installed Intel drivers and updated the Wifi to the latest version.

     

    The current driver is found here:
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20791


    HTH

  • 19. Re: I keep getting "Could not obtain network address" msg
    chatopruf Community Member
    Currently Being Moderated

    After  Reinstalling Intel(r) proset/wireless  to 14.03 and intel(r)widi to the last version 3.0.13.0, and following the steps you recomended like reseting the computer, the netgear, unblocking the signal,  checking the firewall setting I still get the message: "Could not obtain network address... Intel wireless display help".

    The only thing that I couldn't  find was,( on the firewall): Wireless pan dhcp server. Only can see WiDiapp, and i put check to both

    Any suggestions?

    Thanks

  • 20. Re: I keep getting "Could not obtain network address" msg
    Paul_P Community Member
    Currently Being Moderated

    Chatopruf,

     

    Thanks for the question.

     

    Can you tell me the make and model of your computer. I want to make sure that we have all the hardware or software issues worked out first.


    Thanks,

     

    Paul

    Intel® Product Support Engineer

  • 21. Re: I keep getting "Could not obtain network address" msg
    Frank Community Member
    Currently Being Moderated

    Hello, I have the solution for this issue. "could not obtain network address" .

    Okey , all you got to do is go to the my" wifi technology" a panel is going to pop up then go to options and hit DHCP now change the range of the ip address to starting ip 192.168.1.2  ending ip 192.168.1.254 if you are under a class C network.

     

    if you need further support contact me by email

    4pcgeeks@gmail.com

    -Frank .P-

  • 22. Re: I keep getting "Could not obtain network address" msg
    EderA Community Member
    Currently Being Moderated

    I had the DHCP issue and was looking everywhere for the root cause.

    Maybe you have the same issue that I had.

    The Intel My WiFi uses the "Wireless PAN DHCP Server"  service.

    Trying starting the services and look at the PanDhcpDns.log file contents for clues that might tell you why the service doesn't start.

    In my case I had to assign a fixed IP address to the interface used by the My WiFi software.

    So if you selected the 192.168.1.2  thru 192.168.1.254 range in the My WiFi configuration utility then assign 192.168.1.2 to the interface.

     

    Hope this helps.

    Eder A.

  • 23. Re: I keep getting "Could not obtain network address" msg
    Sailor.in.Florida Community Member
    Currently Being Moderated

    Jain,

    I had WiDi working intermitently.  99% of the time it would not find the adapter and time out, but some times it would connect OK.  I have Belkin screencast adapter, Asus i7 cpu 64 bit laptop win7-64bit. When it would connect, it worked perfect, until I would shut it down.

    I have been at this problem with Intel for 8 months now. (I have 25+ yrs as a software developer). Tonight I run the Widi update checker,  it finds new updates, and installs them to;

    "Proset/wireless wifi software version 16.7.0"     Widi now finds the adapter immediately  and makes the handshake, the adapter says connected to intel WiDi, but then the WiDi software says "could not obtain network address".  I never had this error before the update, so now it is introduced with the latest intel software update. Through out this thread responses also talk about "My WIFI" panel and my wifi program? what is this?  Is it the Widi app, or is it the Dashboard app? These are the only 2 apps I use?  Never heard of "MY Wifi  Panel" ?  If I type "my wifi" in the win7 start button cmd box,  it only return my 2 apps mentioned above. simply called, intel widi, and intel widi wiget?

    I am amazed that open source android uses the same WiDi protocol (ie miracast) flawlessly, and works on my Samsung 8.1 tablet, every time. I never get an error. While a different  cpu architecture, the software communications protocol is the identical, to the degree that the Belkin adapter thinks it is Intel and even responds with msg "Intel WiDi connected", it has no idea it is connected to android. So what do I do now, an please do not ask to uninstall/reinstall.    Why would the new update not be able to obtain the network address when the old version of the software did.  99% of the people trying Widi seem to have serious (NOT WORKING)  problems. Network address problems in Intel software, running on an Intel i7 quad CPU and Intel centrino chipset, come on guys!  I could find this problem in a few days if I had the code. I had also recommended in the past for Intel to  implement a debug option, to allow dumps of variables or instruction steping, even allow Intel programers to login remotely (with customers approval of course) and let them run in debug mode. They would find every problem in 1 day. Since android is open source the Widi protocol must not be propritery, I guess I could look at the android code.

    A very frustrated programmer. Guys lets get this working.

  • 24. Re: I keep getting "Could not obtain network address" msg
    joe_intel Community Member
    Currently Being Moderated

    I know you have probably uninstalled and reinstalled all related drivers and software but how about uninstalling the virtual WiFi adapters and restart?

  • 25. Re: I keep getting "Could not obtain network address" msg
    Sailor.in.Florida Community Member
    Currently Being Moderated

    do you mean the microsoft virtual wifi adapters? see below my system only shows microsofts   or is there something special that Intel installs that I do not see with normal device manager?,

  • 26. Re: I keep getting "Could not obtain network address" msg
    Sailor.in.Florida Community Member
    Currently Being Moderated

    Same problem after uninstalling the 2 microsoft virtual mini wifi adapters, and uninstalling widi software again, then reinstalling widi software. then shutdown then cold start. See below screen shots showing it connected to belkin but then cannot obtain network addr?

    Then Get Message "unable to obtain Network address" on the TV screen. Then the screen below on PC .

  • 27. Re: I keep getting "Could not obtain network address" msg
    Sailor.in.Florida Community Member
    Currently Being Moderated

    Finally I got WiDi working perfect after 6 mos. of trying.

    What I diid 

    1- control Panal and Uninstall Intel Pro-wireless

    2- Uninstall Intel WiDi

    3-Get/download  WiDi Update checker from;

    http://supportkb.intel.com/wireless/wireless-display/templates/selfservice/intelwidi/#portal/1026/article/16168

    it will re install all current wifi WiDi apps.

    4- Shutdown, and Re-boot an d it worked perfect no out of sync audio or choppy video just PERFECT


  • 28. Re: I keep getting "Could not obtain network address" msg
    Carscott Community Member
    Currently Being Moderated

    Unfortunately this did not work for me.  After following the steps in post 27 it still provided me with the "Could not obtain network address" and red screen on the TV.  argg...

     

    I have a new ac-7620 wireless adapter and a D-link Mainstage DHD-131.

     

    This used to work with my computer and no longer does.

     

    Intel support could you please help me?

  • 29. Re: I keep getting "Could not obtain network address" msg
    joe_intel Community Member
    Currently Being Moderated

    If you already tried a clean installation of Intel® Proset and Intel® WiDi software I suggest restarting the computer, router and resetting your TV adapter in order to make sure all devices reinitialize the IP addresses assigned.

     

    Just in case, please remember that if you are trying to connect at 5 GHz band you will need to use non-DFS (Dynamic Frequency Selection) channels in your router.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points