10 Replies Latest reply on Feb 15, 2011 1:55 PM by mbrodeur86

    Intel DP67DE won't post after bios update!!! HELP!!!!

    mbrodeur86

      Hello everyone!!

       

      New to the forum here. I've been a custom builder for the last 5 years and a tech for about 10 so for me to be here asking this question.....I'm really stumped!!

       

       

      First the specs;

       

      CPU: Intel I5-2400

      MoBo: Intel DP67DE

      RAM: G.Skill Sniper 8 gb

      SSD: OCZ Agility 2

      HDD: Seagate 750GB sata

      Vid: XFX ATI HD5830

      PSU: Antec 520w Neo Eco (80 plus 40a 12v rail)

      Opt: Samsung 24X dvd burner w/lightscribe

      Case: Coolermaster 430

      OS: Windows 7 Pro 64 bit

       

       

      Put it all together today, started it up and posted no problems. Installed windows, downloaded latest drivers (and bios) and installed the drivers. I tried doing the update through windows which it went through and restarted. I went to check the bios number and it didn't change. I tried setting bios defaults and trying again - it didn't work. I ended up doing it the flash drive method and it went through the steps and said it was successful. It asked to restart which I did and it hasn't posted since. No beep codes or nothing. Truly stumped. Any suggestions? I would try the recovery option but if it doesn't post???

       

       

      Help!!

       

      Thanks,

      Lou