3 Replies Latest reply on Feb 7, 2011 1:11 PM by woodan

    DP67BG dual channel memory status not displaying.

    woodan

      I have the DP67BG motherboard, i7-2600K, and G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800).  I was able to get the memory running at 1600 MHz. by activating XMP in the extreme tuning utility.


      My problem is that in windows or the BIOS (running latest version BGP6710J.86A.1815) it does  not say that I am runnung in dual channel mode.  All my other intel motherboards would say dual channel in the BIOS, but I cannot find were that would be displayed at all with this one.  CPU-Z 1.56.3 shows nothing in the channels # field (the field is grayed out).  Does that mean I am running single channel?


      Another thing that has me very confused is at first I installed the memory sticks in the blue slots.  The BIOS showed the memory installed to channel A slot 1 and Channel B slot 1.  That conflicts with what I was told to do on this page:


      http://www.intel.com/support/motherboards/desktop/sb/cs-011965.htm#?iid=subhdr+dnlds


      This page says that you want two memory sticks in channel A slot 0 and channel B slot 0 (blue slots).  I moved my memory to the black slots and the motharboaord shows the memory installed to channel A slot 0 and channel B slot 0.  Either the motherboard is colored wrong or the bios has the DIMM numbers mixed up.  The support article shows the blue slots in different positions than what I see on my board too.


      What is the correct memory placement for this specific motherboard using two identical memory sticks and how do I know if I'm running dual channel or not? 
      I am very confused.  Thank you for all your help.