13 Replies Latest reply on Apr 27, 2013 1:43 PM by Ilia

    S3420GPRX RMM3 Keyboard problem


      The keyboard doesn't seem to work properly *some of the time* prior to the OS booting. i.e. I can't get into the BIOS setup or use our PXE boot menu. Sometimes however, it'll work fine and I can do both. It seems to work most of the time immediately after the AC cord was pulled. Power cycling or resetting from the web interface doesn't make a difference.


      Once the OS has booted, then things work fine all the time.


      We just got a few of these servers a few weeks ago and all of them have this problem, so I don't think it's a hardware failure... They're all running the latest firmware, the firmware update was performed after the RMM3 lite modules were installed. There are no IP address conflicts (nic5 is dedicated to the BMC) or other network issues, we're connecting to the web interface over LAN.


      Any suggestions or ideas?

        • 1. Re: S3420GPRX RMM3 Keyboard problem

          Is this just the RMM3 virtual keyboard, or physical keyboard as well?

          • 2. Re: S3420GPRX RMM3 Keyboard problem

            Just the RMM3 keyboard, whether using the pop-out virtual keyboard or typing into the window.


            Using a USB keyboard that's plugged into the machine works all the time. The RMM3 keyboard has the same chance of (not) working whether or not a physical keyboard is plugged in.

            • 3. Re: S3420GPRX RMM3 Keyboard problem

              I have seen a simular issue, but always blammed it on the network infrastructure I am using. Maybe not?


              My RMM3's are on a local management network conected to a management system

              I do a remote desktop to the management system and from the management server to the RMM3's.

              (VPN to Remote Desktop to RMM3 -- 3 steps of keyboard encoding to mess up the key sequence)

              On occusion, I see the lack of vitural keyboard responce.


              My work-around is press and hold a key (I ususlly use right arrow but pressing F2 many times should work also.)

              It floods the interface with keyboard commands and the keyboard will return to full function after ~ 3 seconds of holding the key.

              1 of 1 people found this helpful
              • 4. Re: S3420GPRX RMM3 Keyboard problem

                It's definitely not network infrastructure in my case. This is a straight up + simple setup desktop to a switch to the server.


                Thanks Doc, holding down a key does help; the only problem is that that seems to either hang the BIOS (presumably it's beeping or something while processing the invalid input with F2) or cause it to cycle through menus for a very long time (if I hold down an arrow key). It does result in our PXE boot being usable which helps a lot.


                I'd like a proper solution if possible though =)


                We've also got gear from some other vendors, it's our first time with Intel servers and I have to say I'm a little disappointed in things that don't just work.

                • 5. Re: S3420GPRX RMM3 Keyboard problem

                  Same here. S3420GP, RMM3, current software. It is completely impossible to change any setting in the System BIOS or RAID controller, the system is pretty much unresponsive to RMM3 keypresses on the second or third step (getting into the BIOS usually works). This affects both the "hardware keyboard" in front of the management station (using the Console Redirection) and the soft-keyboard of the JViewer itself. Even using the Ctrl Alt Del softkey macro takes ages.


                  We have (had) Dell, Supermicro, Sun and other vendors. We had no issues with any of those. This is extremely disappointing.

                  • 6. Re: S3420GPRX RMM3 Keyboard problem
                    Jason Tan

                    One thing that I did which worked for my case was to change the bandwidth option under the JViewer, this can be found under Options-> Bandwidth -> Auto Detect.


                    After the JViewer detected the actual bandwidth I was in, the keyboard responded to the commands & I did not run into the issue again.

                    • 7. Re: S3420GPRX RMM3 Keyboard problem

                      And... months later, after many rounds of back and forth with support.


                      Apparently, engineering is "aware of the RMM3 lite performance issue" and are investigating for possible solutions, but there's no fix and no ETA.


                      I would encourage you guys to contact support and get tickets open as well.


                      For reference, my ticket is 8000206814.

                      • 8. Re: S3420GPRX RMM3 Keyboard problem
                        Jason Tan

                        My understanding is that Intel is investigating the actual root cause of the issue. If I hear anything, I will pass it along.

                        • 9. Re: S3420GPRX RMM3 Keyboard problem

                          The Intel has reproduced the issue and is working on the fix.

                          I will update when I have the specific BMC FW package that contains the fixes.

                          • 10. Re: S3420GPRX RMM3 Keyboard problem

                            I also have run into this; with an RMM3 (not RMM3 lite). Holding a key does indeed fix it at the bios, but later on it stopped taking any input while is was editing a config file


                            Did you ever hear back & get a patch?

                            • 11. Re: S3420GPRX RMM3 Keyboard problem

                              Not fixed for ovver then 1 yeear.


                              BTW, for users who have the same trouble:

                              Supermicro IPMI Viev can do just reset of intel RMM3.

                              After it this truble usually fixed for a some time.

                              • 12. Re: S3420GPRX RMM3 Keyboard problem

                                I have RMM4 on my Intel 2U R2308GZ4GC and I have faced the same issue after doing some changes in BIOS. It worked perfectly before! I guess I have disabled onboard USB Support? Could that be an issue? How to get it back? I have syscfg on my Linux installed! Any recommendations please! I need it urgently, please help!



                                P.S. Besides, when tech support in my data-center (where my server is located), plugs external IP-KVM into my server (VGA port + usb) - just absolutely the same issue happening - keyboard is not working??

                                • 13. Re: S3420GPRX RMM3 Keyboard problem

                                  I have finally found out why keyboard problem happens with Intel's RMM!! It's not really a bug!


                                  The reason was, that I have disabled USB support in BIOS and after that BMC's JViewer stopped seeing keyboard and mouse, as they are initialized as USB devices! You must remember to leave this feature on for proper IP-KVM functionality!


                                  Besides I had an error in logs which is gone for now (as USB enabled when using RMM):

                                  Error. ,,,,,,,,,,,,,,,,,,,,,,,,Serial port component was not detected -Major ,,,,,,Serial port component encountered a resource conflict error -Major - Asserted


                                  You can use syscfg utility to turn on USB support from operation system (OS), e.g.:


                                  /usr/local/bin/syscfg /bcs "EnterYourAdminPasswordHere" "USB Controller" 1  

                                  (in case you don't have your admin password set just leave it blank, like this "", e.g.: /usr/local/bin/syscfg /bcs "" "USB Controller" 1).


                                  This solves the problem completely and now my RMM4 module works like charm!!


                                  Just wanted to share with you as it took a lot of my time and I hope it will be helpful for someone!