5 Replies Latest reply on Jun 1, 2011 11:55 PM by DuckieHo

    Problems with SSD Optimizer

    jimh

      Since I have rebuilt my PC with a new Sandy Bridge MB I'm having intermittent problems running the Intel SSD Optimizer.

      I'm running Windows 7 (64) and have a X25-M Mainstream 160GB 2.5" SATA-II Solid State Hard Drive (SSDSA2MH160G2C1) installed as my boot drive, it has 85GB free space. Windows was installed from the CD formating the SSD drive first from the installation options.

       

      PC details are:

      Asus P8P67 PRO Intel P67 (Socket 1155) DDR3 Motherboard

      Intel Core i7-2600K 3.40GHz (Sandybridge) Socket LGA1155

      Corsair Vengeance 8GB (2x4GB) DDR3 PC3-12800C8 1600MHz Dual Channel Kit (CMZ8GX3M2A1600C8)

      SSD is running on one of the Intel SATA III ports on the MB.

       

       

      The problem is that occasionally when I run the Optimizer it runs fine and the green progress bar moves to complete in say 15 seconds and the status is updated to Passed.

      Then another time I will run it and the progress bar completes virtually instantly but the status remains as running. If I look at the C drive I will see a number of ***.Bin files.

      I have left the Optimizer running for hours and hours and it never seems to complete.

      I can shut it down and reboot and it may or may not work correctly, it just appears to be random.

       

      Has anyone else had this problem and does anyone know what is causing it?

        • 1. Re: Problems with SSD Optimizer
          Snakeyeskm

          I am not sure, but I believe that as long as you see the bin files the optimizer is running fine. You will notice, if you refresh the window that shows the bin files, they will disappear. Just shut the toolbox and then reopen and rerun the optimizer and it should run and close properly.

          • 2. Re: Problems with SSD Optimizer
            etgerknight

            When I run the optimizer I see gigs-worth of bin files appear immeadiately, and the status shows 'running'. But it never completes. I have left it for as long as 15 hours and it still said 'running'. Whe I close the Intel Toolbox all the bin files disappear (which is a good thing). It used to work fine, but after March 23rd, 2011 at 10:06:49PM it started getting wonky. I remember the exact time because the 'last ran' timestamp will no longer update. I just installed the lastest FW (2CV102M3) and ran the optimizer again, but I still see this phenomenon.

             

            My drive is an SSDSA2M0800G2GC. Currently it has 18GB+ free space (down to about 6GB when the optimizer is running).

            • 3. Re: Problems with SSD Optimizer

              I'm having the same issue:

               

              I've got two Intel SSDSA2M160G2HP's in my computer and the SSD Optimizer will run fine on my first one (Windows 7 x64 system and C partitions) but won't run (never finishes) on my other (storage and swap file). wtf....

              • 4. Re: Problems with SSD Optimizer
                DuckieHo

                Have you tried disabling the swap file and reboot.  Then run the Optimizer?

                • 5. Re: Problems with SSD Optimizer

                  I've had my paging file (i.e. swap file) disable since I got my drive. From what I understood at the time, that was best practice for SSDs. In any regard, I still cannot get the optimizer to finish.