9 Replies Latest reply on Dec 9, 2011 7:21 AM by Dziadzi

    2500K stuck on 1.6GHz?

    Mockasin

      I recently got a Core i5 2500K and Asus P8P67 PRO motherboard. The problem is, I can't get it to use turbo boost or anything! In CPU-Z and heaps of other programs, its 1.6GHz with no change!

      The programs i have used is:

      Asus AI Suit
      CPU-Z
      Intel Burn Test
      Real Temp
      CoreTemp
      TMonitor
      CPUID Hardware Monitor
      AIDA64
      Intel Turbo Boost Technology Monitor

      Intel Processor Diagnostic Tool

       

      The Turbo Boost Tec Monitor doesnt move. The Processor Diagnostic tool fails at BCLK test.

       

      Even when i have turned off speed step and the thermal features in BIOS, it is still at 1.6GHz. Shouldn't it atleast be at 3,3GHz, which is the stock frequency?

      I have tried everything i can think of! Updated BIOS, Installed Windows 7, 4 times! The max temperature is only 33 degrees Celsius.

       

      I cant see Turbo Boost in msconfig->services either.

       

      I feel i have tried everything for 3 days now! And I still don't know whats wrong!

       

      Help me please!

        • 1. Re: 2500K stuck on 1.6GHz?
          Doc_SilverCreek

          From your discription, I suspect this is not a Speed Step or Turbo boost issue.

           

          Fist off I would clear CMOS and restore any default setting in the board BIOS.

          Most anafactures default setting should give full turbo and speed sted operation.

           

          Next up , What is the multipler reported by a uttlity like CPUZ and does it change at all?

          Does you BIOS have the ability to set a mutliplier or if it fixed?

           

          Does your mother board claim to support this processor?

          If the BIOS does ot reconize the processor it may lock the multiplier to the lowest setting to allow the system to run until a BIOS update is loaded that does add support for the new processor.

          • 2. Re: 2500K stuck on 1.6GHz?
            Mockasin

            I have tried to clear the CMOS several times, and using the CLRTC jumper too. The multiplier is stuck on 16, hence 1.6GHz because the BLCK should be at 100 on these processors. Yeah, I can set the multiplier, but for the basic speed (33 in multiplier), and the turbo boost. It wont make any difference.

            The motherboard fully supports this processor.

            • 3. Re: 2500K stuck on 1.6GHz?
              rachit2588

              in bios  make sure that intel speed step is on. turbo boost is on

              also their will be some option to keep your cpu on high performance . by default its in low power (power saving mode)

              also if your mobo can support OC, then try to change the multiplier values to their upper safe limits.

              also make sure your Power supply unit is of recommended current , voltage and power values..

              • 4. Re: 2500K stuck on 1.6GHz?
                Mockasin

                I have checked all those things, at least quadrouple-checked them! I have a 600W 80plus PSU, it should be more than enough for my current system.

                • 5. Re: 2500K stuck on 1.6GHz?
                  Doc_SilverCreek

                  Any change if you step the mutiplier up slowly? Since it on 16 now, try 18, 20, 22 etc and see if it makes any change.

                   

                  Check you speed while burn-in is running to make sure speed step is out of the picture.

                  • 6. Re: 2500K stuck on 1.6GHz?
                    rachit2588

                    i think your cpu is stuck at c1e state, in the bios make sure its set to c0 ..see if this helps..all the best

                    • 7. Re: 2500K stuck on 1.6GHz?
                      Doc_SilverCreek

                      Try these settings in the CPU configuration tab

                       

                      CPU ratio =  auto

                      Intel Adaptive Thermal Monitor  = enable

                      Hyper-threading = enable

                      Active Processor cores = all

                      Limit CPUID Maximum = OS dependent = disable

                      Execute Disable Bit = enable

                      Intel Virualization Tech = disable

                      Enhanced Intel SpeedStep Technology = Disable for test – enable for operation

                      Turbo Mode = enable

                      CPU C1E = enable

                      CPU C3 report = enable

                      CPU C6 report = enable

                      • 8. Re: 2500K stuck on 1.6GHz?
                        Dziadzi

                        Hi, Mockasin, I have a similar problem. Mine is stuck at 2.3. I don't see any resolution to your thread. May I ask what has happened regarding your problem?

                        • 9. Re: 2500K stuck on 1.6GHz?
                          Mockasin

                          Oh, sorry I haven't updated this thread. I sent my motherboard + CPU back to the store and they found the motherboard faulty. I got a new one and the system is running fine ever since.