1 Reply Latest reply on Jan 21, 2011 12:56 PM by

    DX58so2 / SSD / BSOD's

    mann

      I have an Intel BOXDX58so2 with a Crucial C300 SSD and have been having lot's of problems with BSOD's and "no bootable media" messages.
      They are not reproduceable or predictable but seem more likely when Internet Explorer is running.
      Most recent BSOD identified "mv91xx.sys" so there's the smoking gun. The Marvell HD driver or something that it interacts with, like the SSD or the OS.

      I'm making this post to provide others with a resource to compare with if they are having the same problem but if anyone has answers or opinions I'd be greatfull.
      I've cruised several forums and it's an endless circle with no clear answer.
      This post has nothing to do with RAID.

       

      HERE'S THE SYSTEM,,,
      Intel BOXDX58SO2 MB. This is the same as the Intel DX58so but now has 6GB/s SATA and USB 3.0 support.
      Intel Core I7, 950 Processor (box version so it's using Intel supplied cooler)
      kingston 3 X 4GB 240 Pinn DDR3 SDRAM 1333. (PC3 10600), Kingston P# KVR1333D#N9K3/12G.
      Crucial Solid State Hard Drive, M# C300, P# CTFDDAC256MAG-1G1, This is a 256GB,  6GB/s SATA drive.
      Nvidea GTS450 Video card.
      MK Power 750watt power supply. (This is a modern and fairly high quality power supply and has all the correct connectors for this motherboard)
      Windows 7 64bit  (Just to make it harder)


      HERE ARE THE BIOS SETTINGS.
      I've changed several things while tweaking so I don't remember which ones are default.
      I only included items which I think are relevant AND that I may have changed from the default here.

       

      MAIN SCREEN::::
      Bios version = sox582oj.86a.0603.2010.1117.1506
      This is the latest (and first) bios version as of the writing of this blog,, 1/15/11
      4096MB, DIMM 1,2, and 3 (This is a typical 3 channell memory configuration for this MB)
      memory speed = 1067MHz (yeah the memory is supposed to be 1333MHz but I think this the correct reading anyway)

       

      CONFIGURATION SCREEN::::
      ONBOARD DEVICES
      Secondary LAN  = Disable
      Front Panel Audio = Disable
      USB CONFIGURATION = All ports enabled but only a couple used.
      SATA DRIVES
      Chipset SATA Mode = AHCI  (yep, this is probably good)
      SATA Port 0  = bla, bla, bla, DVDR drive
      SATA Port 1 thru 5 = Not installed   (Hmmm, 1 SATA DVDR drive and 1 SATA SSD = 2 SATA devices. what does this mean? No info found on which internal plugs on the MB are which port. Only know that the BLUE plugs are 6GB/s SATA and the BLACK plugs are 3GB/s SATA

      Discreet SATA Controller configuration:
      Internal 91xx Blue SATA (Gen3) = Enable (Here's a hint that it's using the Marvell "88se91xx" driver at least during boot.)
      SATA controller mode  = AHCI (yep, think this is correct)
      Detected discrete SATA drives = SO C300-CTFDDAC256MAG (yep, it sees the Crucial SSD,, usually)
      back panel SATA   = disable
      hard disk pre-delay  = 0 (just used to make BIOS screens flash slower during bootup)

       

      PERFORMANCE SCREEN::::
      CPU VR current override = Enable

       

      POWER SCREEN::::
      Deep S4/S5 = Disable
      PCIe ASPM LOs = Disable (not sure what this does)
      PCIe ASPML1 = Disable (not sure what this does)

       

      BOOT SCREEN::::
      Boot menu type   = disable
      Boot device priority  = 1) Hard disk drives
           2) Optical drives
      Hard drive order  = SO C300-CTFDDAC2 (The BIOS see's the SSD , usually)
      Optical drive order  = bla, bla, bla,, DVDR drive
      Removeable drive order  = No removeable drive
      Boot to Optical devices  = Enable
      Boot to removeable devices = Enable
      Boot to network   = disable
      USB boot   = disable
      Boot USB devices first  = disable
      UEFI boot   = disable
      hyperboot   = disable

       

      Intel DX58SO2 MB NOTES,,,,
      This MB comes with SATA cables that appear to be for 6GB/s because they are indented down the middle and they are blue which matches the color of the 6GB/s SATA connectors on the MB.
      Have gotten a few "No bootable drive" messages
      Tried fiddling with the SATA cables and tried a couple of aftermarket cables but can't tell if this makes any difference yet. Suspect poor connection on MB or SSD, or maybe not.
      Tried to install an internal SD card reader and the MB will not boot thru BIOS,, just hangs. Tried 2 different brands of Internal SD card reader, no difference. If I plug an external SD card reader into an external USB port it works fine.
      Called Intel but they couldn't help.

       

      Crucial C300 SSD Notes,,,,
      Called Crucial about problems and they had me do the following,
      1) Run "AS SSD Benchmark.exe". This showed the Marvell driver being used even though device manager says it's a SCSI driver dated 2006.
      Crucial guy said this is just a MS WIN 7 quirk.
      Running AS SSD Benchmark.exe produced BSOD's a couple times.
      2) Verified that firmware on SSD is 0006,, the latest version.
      3) Was told that the BIOS hands over the SSD driver work to the OS at some point. hmmmmm,,,,

      Then I made some more changes per MS Technet forum,,
      Ran "Services.msc" and changed "superfetch" from auto to manual.
      Changed disk defrag from auto to manual.
      Never found the "trim" thing. Anybody know?
      Ran Regedit and verified that AHCI is enabled.

      Something is just not right with the SSD, can't figure it out.


      Memory Notes,,,,
      Intel web site has vague info on memory here,, or maybe I just missed something.
      I bought the RAM from Kingston and they said to use P# KVR1333D3N9K3/12G.
      This is 3 channell 240 pin DDR3 DRAM (PC3 10600) and runs at 1.5v. (This is below the MAX 1.65volts allowed by the MB and processor)
      One thing that was confusing in the Intel MB manual was the "Installing DIMMs" picture on page 41.
      It shows a graphic of DDR3 memory with the new fully encased chips, then a pic of DDR2 memory with open/visible chips and says not to use the latter.
      However, the memory that kingston recommended has exposed chips. Folks at crucial said that the encased chips are for improved cooling and are usually only found on high MHz (overclocked) RAM.
      Intel website shows 4GB, Double sided, 2 Gbit, 256M X 8 / 256MB X 8, 16 DRAM devices, etc, etc.,  under tested memory but the Kingston stuff says 3 X 4GB. Don't even know where to begin with this one.
      Ran "Memtest.exe" for hours and hours,, no errors reported.


      Video Card Notes,,,,
      I'm using an Nvidea GTS450.
      This is a fairly good video card but doesn't have the "extreme" stuff going on.
      It will show 4 audio devices in device manager but unless you are using the HDMI output on the card you should disable them.

       

      My best guesses at this point,,,,,,,,,, but I don't really know!
      Drivers for SSD's are not very polished yet.
      Crucial SSD is quirky.
      6GB/s SATA is quirky,, not polished yet.
      Marvell, Intel, Anyone who wants to make SSD's, and Microsoft should have a meeting in Vegas and get this ironed out.

        • 1. Re: DX58so2 / SSD / BSOD's

          I'm using a DX58SO2 mobo with i7950 and GTX 460 and a couple of Vertex LE SSDs plus 4 HDDs without any problem. From my experience with several SSDs including the Crucial C300, the important thing is to set the Bios to use AHCI, plug in just the SSD on port O (the bottom one of the first two ports - as shown on the mobo label just above it), put your DVD on port6, and then install your system using default Bios settings except for the AHCI. After getting everything installed, you can plug in the rest of your drives to the intel ports and the extra Marvell ports. Again, make sure you set the Marvell ports to AHCI BEFORE connecting the drives. Make sure you install all the stuff on the Intel disk before connecting the extra drives or using the Marvell ports.

           

           

          The sata cables make no difference; sata 3 was specifically designed to use the same cables as sata 1 and 2.

           

           

           

          Works fine for me, overclocking at 3.8-4.0 currently with just host clock = 160. Using Crucial Ballistix 1600 memory 2GB each(6)

           

          Bob Frost