1 Reply Latest reply on Jan 10, 2011 8:00 AM by

    AMT SDK RemoteControlTyped/Untyped.exe aborts during enumerate

    cpu.sudarsan

      Hi experts,

         I have two laptops - one is a vPro enabled and another is a non-vPro laptop. I successfully built the RemoteControlTyped and RemoteControlUntyped.exe applications that are part of the SDK on my non-vPro laptop. Here is what I tried:

       

      remotecontroltyped.exe -c -verbose -host <ip address of AMT> -user admin -pass <passwd>

       

      What I see is a "Debug Assertion Failed"

       

      Expression: map/set iterator not dereferenceble.

       

      So I tried to pass the arguments into the IDE(visual studio 2008) and run in debug mode where I set breakpoints. I see that it hits this error when attempting to perform an Enumerate on Cim_RegisteredProfile.

       

      Since I am fairly new to this stuff I am looking for help on what could be causing and what I can do to get past this. Is there some other application I need to run before running the remote control? I did not quite figure out what it is trying to enumerate.

       

      Appreciate your help.

       

      Regards,

      Sudarsan VS.