5 Replies Latest reply on Jan 5, 2011 12:37 PM by kuyatsushiro6

    ICH10R, Raid 5, replaced harddrive won't add to raid

    aaa88

      Hello,

       

      I have a raid 5 setup on ICH10R, and I'm using IMSM 8.8. I have 6x Western Digital 1,5 TB disks, and the raid has worked more or less fine for a year until one of my harddrives failed. And the harddrive has really failed, i can't format it or do anything with it.

       

      Luckily i have 2 extra hard drives as spare, identical to the ones in the raid. So i thought it would be easy to swap the failed drive with a new one, and rebuild the raid.

       

      After i swapped out the failed harddrive with a new one, it won't add to the raid. In IMSM the new harddrive appears underneath "Non-RAID Hard Drives", and in the raid it says "Port 1: Missing Harddrive".

       

      Here is a screenshot of how it looks:

       

      raidfailure.JPG

      And the problem is when i right click the Non raid harddrive, the only option i have is to "Mark as spare". So i tried that, but then again, the only option i have is to "Reset Hard Drive to Non-RAID".

       

      I also tried to right click the missing hard drive, but it only says "No actions available".

       

      I've also tried to boot up the raid bios, but it's the same story there. The only options i have there is to delete raid, create new raid etc. No rebuild option.

       

       

      So I'm clueless at this point. I'm praying that I will still be able to rebuild the raid. Isn't the whole point with Raid 5 that one drive can fail, and you should still be able to recover all your data? Any ideas at all will be much appreciated.