5 Replies Latest reply on Jul 10, 2011 9:57 AM by TheShadowRunner

    Intel Rapid Storage 10.1.0.1008 on XP: "drives don't go to sleep" bug is back :/

    TheShadowRunner

      Hey all,

      A few months ago I described a bug that occured with Intel Rapid Storage 9.6:

      http://communities.intel.com/thread/15943

       

      In effect, if the time set for "Turn off hard disks" (in XP "Power Options") was HIGHER than 45 minutes, the drives never went to sleep anymore.

       

      While Intel Rapid Storage versions 10.0.0.1043 beta and 10.0.0.1046 WHQL corrected this bug beautifully, I'm sad to report the bug is back with Intel Rapid Storage 10.1.0.1008 :/

       

      Here's the relevant data:

      The board is Asus P5K-VM with Intel ICH9 controller.

      OS is Windows XP SP3 32bit. In Bios, SATA is set to AHCI.

      The Intel Rapid Storage driver (iaStor.sys) installed version is 10.1.0.1008.

      The HDDs are Samsung HD103UJ, there exist no firmware update for those drives.

       

      How to reproduce:

      On a system similar to described above, just set the following settings in XP "Power Options":

      http://communities.intel.com/servlet/JiveServlet/showImage/2-102373-25883/poweroptions.jpg

      For exemple; set to "Turn off hard disks" after 1 hour, any amount higher than 45 minutes will do to trigger the bug.

      Then wait and see for yourself: the drives NEVER go to sleep after the specified time.

       

      Re-installing Intel Rapid Storage v10.0.0.1046 solves the problem right away.. which clearly shows the bug is back in v10.1.0.1008. :/

      Thanks for your support!

      Regards,

       

      TSR

        • 1. Re: Intel Rapid Storage 10.1.0.1008 on XP: "drives don't go to sleep" bug is back :/
          PeterUK

          Ok lets look at it another way...so higher then 45 minutes will not make the drives sleep but low will put the drives to sleep yes?

           

          The whole point is to save power when not using that array or drive for the drives to sleep so when you do use that array or drive the timer resets and the drives don't power down until this 45 minutes or less is used with the array or drive not in use for that time for the drives to power down.

           

          My point (which your not going to like) is why have a long wait for the drives to power down after 45 minutes when not in use when they could be off to sleep sooner?

           

          But if it really bugs you report it to Intel.

          • 2. Re: Intel Rapid Storage 10.1.0.1008 on XP: "drives don't go to sleep" bug is back :/
            TheShadowRunner

            Peter, thanks a lot for your answer, but that's completely beyond the point.

             

            If I set drives to sleep after 2 hours in XP Power Settings, I expect them to do so.  Something is broken.

             

            If you want to know the reason, I only want HDDs to go to sleep when I do too, setting 2 or 3 hours ensures that they won't go to sleep while I'm working.

             

            But actually, I did more testing and it's worse than I thought : Intel Rapid Storage 10.1.0.1008 completely prevents SYSTEM Standby too !

            Yes, you read right, with IRS 10.1.0.1008 installed, the system just won't go to standby anymore if time set for "System Standby" is higher than 45 minutes! [on XP at least]

             

            Please test for yourself.

            Reinstalling 10.0.0.1046 solves those 2 issues right away.

             

            I really hope the IRS Dev team is reading this or that someone will forward them the info, it's an important issue!

            Thanks for your support,

             

            TSR

            • 3. Re: Intel Rapid Storage 10.1.0.1008 on XP: "drives don't go to sleep" bug is back :/
              PeterUK

              If you want to know the reason, I only want HDDs to go to sleep when I  do too, setting 2 or 3 hours ensures that they won't go to sleep while  I'm working.

              But don't you ensure that by using your the HDDs and having the timer reset within 45 mins?

              Reinstalling 10.0.0.1046 solves those 2 issues right away.

               

              I really hope the IRS Dev team is reading this or that someone will forward them the info, it's an important issue!

              If your sure it was ok with 10.0.0.1046 send it off here no good hoping someone will find it here.

              http://supportmail.intel.com/scripts-emf/welcome.aspx?id=

              Family: Chipsets

              Line: Chipset Software

              Product: Intel ® Rapid Storage Technology

              1 of 1 people found this helpful
              • 4. Re: Intel Rapid Storage 10.1.0.1008 on XP: "drives don't go to sleep" bug is back :/
                TheShadowRunner

                >  But don't you ensure that by using your the HDDs and having the timer reset within 45 mins?

                 

                Sorry, I didn't get that part.

                 

                > If your sure it was ok with 10.0.0.1046 send it off here no good hoping someone will find it here.

                 

                Thanks for the tip, I submitted a proper bug report there.

                Later,

                 

                TSR

                • 5. Re: Intel Rapid Storage 10.1.0.1008 on XP: "drives don't go to sleep" bug is back :/
                  TheShadowRunner

                  Sadly after all this time Intel still hasn't fixed the problem.

                   

                  A little résumé:

                  On a system with Win XP SP3 32bit and ICH9 southbridge in AHCI mode, I set the HDDs to sleep after 3 HOURS in Windows' Power Settings.

                   

                  (1) With RST 10.0.0.1043 beta or 10.0.0.1046 WHQL, the HDDs go to sleep after set time, all OK.

                   

                  (2) With RST 10.1.0.1008, 10.5.0.1027 and 10.6.0.1002, the HDDs NEVER go to sleep.

                   

                  Extra info: With the RSTs mentioned above that won't let the HDDs sleep (2), the issue only shows up when the time set for HDDs to go to sleep is MORE THAN 1 HOUR.

                   

                  To Intel: - HOW TO REPRODUCE-

                   

                  1. On a system running Windows XP SP3 with ICH9 Southbridge, please install any RST builds from (2), so for exemple 10.6.0.1002.

                  2. In the BIOS for this system, set SATA as "AHCI".

                  3. In Windows "Power Settings", set the HDDs to go to sleep after 3 hours.

                  4. See for yourself, the HDDs will NEVER go to sleep = bug.

                   

                  Please by all means fix this bug Intel.
                  Thank you very much,

                   

                  TSR