14 Replies Latest reply on Jun 17, 2011 5:30 PM by

    DX58SO (Bios - SOX5810J.86A) ver. 5506 - Bug Ridden BIOS Release

    intel-za

      I've had this board since it was released 2 years ago. In that time I have been through several versions of BIOS without problems. Recently installed Kingston Hyper-X 1600 DDR-3 memory which was causing the system to take forever to POST, decided to apply the latest bios update ... BAD IDEA !!!!

       

      - The system now takes 3 times longer to POST

       

      - The USB keyboard does not work until Windows has loaded

       

      - If I place the jumper on the keyboard to get into BIOS I can do absolutely nothing when I am in there because the keyboard is not detected

       

      This is a major step back in the progress of a really great desktop board, this firmware version really should be pulled from the downloads immediately and a new one with a "simple" fix to make the USB keyboard work made available ASAP for download. How can this update be published without being tested properly on a simple thing like a keyboard? and before anyone asks ... it's NOT the keyboard .... had the same keyboard for 18 months which has been through several bios updates on this board .... just SOX5810J.86A messed it up so it won't detect it

        • 1. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
          intel-za

          Not that it matters because the keyboard as I mentioned has worked for a good 18 months through several bios updates .... but it is a logitech illuminated keyboard and I see other people have problems with this keyboard not being detected by bios - http://communities.intel.com/thread/16958?tstart=0

          • 2. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
            intel-za

            This latest Bios just keeps getting better.

             

            Historically the DX58SO has always been slow to POST if USB drives are plugged in. On older versions of the BIOS (all prior to this one) it would take 10 seconds longer to POST with the USB drives (Seagate) plugged in than when they were plugged out.

             

            With this latest BIOS version it now takes ... wait for it .... almost 200 seconds to get past POST before loading the OS. I have confirmed this bug by removing my 4 external USB drives and then it takes 3-4 seconds to get past POST and a further 12 seconds to load my OS (Intel SSD). So with USB drives plugged in over 3 minutes to boot to OS login, without USB drives plugged in 20-25 seconds max.

             

            Plus lets not forget the Logitech illuminated keyboard is not detected .... again confirmed this bug by using a different USB keyboard which works fine.

             

            Obviously there is a major problem with this version of the BIOS and what it has done to the USB controller and strangely enough one of the "supposed" fixes in this version is the following "Fixed issue where enabling UEFI causes all USB ports to stop working" ... haha .... seems they got the "all usb ports to malfunction very nicely at POST with this "fix" !!!!!

            • 3. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
              intel-za

              There appears to be so much more wrong than right with this version of BIOS which was hastily released without ever being tested properly. I downgraded back to ver 5020 and everything works fine again. Really annoying to see such poor software releases pushed out which cause more harm than good. Not the first time this has happened and probably not the last either. Seems everyone an Intel is on holiday or just don't care to respond on this issue.

              • 4. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
                Doc_SilverCreek

                USB scanning can cause several strange effect, including the loss of keyboard and slow boot times.

                Each USB device is discovered on each boot. If that device is a HDD, it has to get polled, spin up , and respond and each one is done individually.

                The BIOS usually contains time-outs so that after a bit, it quites looking for more USB devices during POST. (the OS will find them later)

                It becomes a balancing act, do you want a faster POST or all the USB devices (like the keyboard) to be active during POST?

                 

                You might try removing all the USB devices except the keyboard and see if your BIOS set-up works.

                I don't know if the desktop BIOS has the feature or not, but disabling USB boot or USB priority can also increase boot time since the system will no longer look for a USB boot device. (Does not help with the keyboard if it is down the scan chain, behind bridges.

                 

                Connect the USB Keyboard directly to the mother boards USB connector and try different connectors to get it to the top of the scan chain..

                If you get the USB keyboard in the top of the USB scan chain, it should work in BIOS set-up.

                 

                Another handy hint, make sure you know all your BIOS defaults, then select the Load Default \ clear CMOS option in set-up.

                Reboot back to BIOS set-up and reset your personalized defaults.   (Loading Defaults configures the CMOS tables. If a BIOS update made any changes in the CMOS mapping, it will "fix" the mapping. Mapping changes the require a default reset should be spelled out in the readme files, but I have found that sometimes the BIOS engineers forget to mention the changes or users forget to read the readme notes or both.)

                I have gotten in the habit of always loading the defaults after a BIOS update, just to be on the safe side.

                • 5. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
                  intel-za

                  Hi Doc_SilverCreek

                   

                  Thanks for the suggestions and info.

                   

                  I understand that USB devices slow down the boot time considerably. The more USB devices plugged in the slower it gets as it looks for each one. What I cannot understand is why the BIOS does not look at the Boot options specified and work in that order. Why does it waste time looking for several usb devices when in the BIOS it has been clearly specified NOT to boot from USB devices and that the main boot drive is a fixed SATA DRIVE ?

                   

                  That to me is like the simplest of programming:

                   

                  If boot from USB = no
                    and Boot drive = Sata then
                    boot from Sata and stop wasting PC owners time looking for USB devices which you are not going to boot from
                  end if

                   

                  I'll try the latest 5529 bios to humour myself as I am having problems with the board detecting a PCie x4 card. It sometimes detects it and sometimes does not .... really hit and miss. I hope 5529 can fix this and not break something else like losing my USB keyboard in BIOS.

                   

                  Regards

                  • 6. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
                    Doc_SilverCreek

                    USB scanning and priority is a algorithm that (I think) still needs some work. (maybe its better in the new BIOS?)

                     

                    When you talk coding, first the system needs to determine what, if any, USB devices are attached. Then query each device as to its function..

                    You may not care if the USB drive or fob is present during POST, but a USB keyboard & mouse working before getting to the OS is a very nice to have.

                    The BIOS does not know what the device is until it is scanned.Some system may also have several USB connected inputting devices. My system I using has 2 keyboards, 2 mice (one at the desk and one at the easy chair) and a RMM3 which creates another set of Keyboards and mice for when I remote into my system.I am fussy and really had to get out of my easy chair to walk over to the desk to press "Any Key" if i need BIOS or my RAID has a issue and vice versa

                     

                    As you noted, each USB device attached slows down POST, so some BIOS programmers put a time limit in to the code which lets USB scan for a period and stops and continues to post relying on the OS then to find and load any devices it missed. This works, but with the number of USB devices attached by techno manics (how could I live without my USB nerf rocket launcher?) like me may result in critical devices (my keyboard) may not get loaded.

                    My resolution was to play musical ports until all my keyboards are in the early scan and the web cams, rocket launcher, printers, card readers, sound cards, joy stick, and a couple other things , are all further down the scan.

                     

                    Also a simple USB boot = no means never ever under any condition boot to a USB device. This can make things tough if your board BIOS requires a USB DOS boot to flash new code. Most have a USB boot priority which either lets new devices be placed at the top of the boot order (bad idea from a security point of view, but nice for manufactures) or at the bottom so that a boot menu will let you chose. (still a little week on security) or no USB boot at all. (Safest since now to hack into the system via a reboot, you need get into BIOS setup and change parameters).

                     

                    It ends up being a huge number of trade offs. Do you optimize the BIOS function for the end user (most of which will never enter BIOS set-up) or for the manafactures who all need flash and make BIOS settings changes in every system? Systen secutity can trump easy of manafacturing since no one wants it to be easy to break into a system. Open archtuctures make valadation a problem too since BIOS valadation teams will connect a usb device to each port, but many of the devices today are multifunction and have half a dozen devices in every device.

                     

                    A lot of board manafactures get around this by only supporting a locked configuration. I tried to add a sata card to a old system (vendor not specificed, but it was not an Intel board) my wife was using to get her a faster HDD and larger storage. Worked fine, execpt for the fact that the vendors BIOS only reconized the on board IDE as a boot device and would not even complete POST if an IDE HDD was not attached.. 

                     

                    One solution would be to specify that two USB ports must be used by keyboard and mouse (which kind of defeats the purpose of USB over PS2).

                     

                    I can tell you that the newest BIOS on my workstation seems to have solved all my keyboard not detected problems and all my keyboards are active on every boot now. Maybe the desktop folks included the same fixes that are in the high end BIOS? 

                     

                    Good luck

                    • 7. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
                      intel-za

                      Thanks again doc_silvercreek

                       

                      Appreciate all your insight .... I'll give 5529 a whirl tomorrow and see if it fixes everything.

                      Will report back.

                       

                      Kind Regards

                      • 8. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
                        Doc_SilverCreek

                        I will look forward to it..

                         

                        "To err is human, to really mess stuff up takes a computer!"

                        • 9. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
                          intel-za

                          installed 5529 and I am once again seriously peeved with Intel's poor BIOS programming. Once again like with 5506 I have lost my Logitech USB illuminated keyboard. So now every time I want to get into BIOs I have to shut down, plug out the logitech keyboard, plug in another "no name brand" usb keyboard, then go into bios, then shutdown, then put my logitech keyboard back and then boot into my OS.

                           

                          This is really utter BS from Intel, it is not rocket science detecting a USB keyboard but it seems this problem is happening on numerous BIOs releases for Intel boards and Intel has done diddly squat to fix this.

                           

                          Seriously not impressed with Intel.

                           

                          This keyboard has worked through every single BIOS update since I bought this board and in the last bios updates they have managed to kill it.

                          • 10. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
                            Doc_SilverCreek

                            Logitech USB illuminated keyboard ---  hmmmm,

                             

                            Are you directly connected to the boards USB ports or using a usb hub?

                             

                            I check the release notes for the BIOS and see that they have touched the USB code to fix a uEFI issue.

                            Fixed issue where enabling UEFI causes all USB ports to stop working.

                             

                             

                            I looked at logitech site and they did not have much listed on this keyboard in the line of specifications.

                            Do you know if it is USB 1.0, 1.1, 2.0 or 3.0 compliant?

                            Do you know what the current draw is?

                             

                            I did see that is has a port on it so it must have a hub built into it which will pushes it down the scan chain.

                             

                            (Processor --> IOH --> ICH --> (to Hub?) --> to internal keyboard hub --> to keyboard.)

                             

                            The BIOS may not be scanning 4 (or 3) bridges deep on POST.

                            Does not help since all the USB ports on this system are off the ICH unless you hae additional hubs in the chassis or external I don't see any way to shorten the scan chain.

                             

                            The current draw is another question with a port and lights, but i don't think that's the problem since if the USB was over current, the keyboard should not work in the OS either.

                             

                            Level of USB support might be a issue USB 1.0 & 1.1 can really choke a 2.0 or higher system especially if it has any memory (USB 1 flash drives will not work with most usb2.0 system) .

                             

                            But i did find this http://forums.logitech.com/t5/Keyboards-and-Keyboard-Mice/Logitech-Illuminated-Keyboard-unusable-to-enter-BIOS-prior-to/td-p/289945

                             

                            Looks like your not alone. Almost everyone can't get into BIOS using this keyboard regardless of the mother board. (7 pages of folks having issues.)

                            Some of these seem to indicate the keyboard contains memory which is being seen as a storage device which might cause the BIOS to stop scanning this path if USB boot is disabled. (and it may cause the BIOS to hang if USB Boot tries to boot to you keyboard) Other think in is a power issue.(maybe?)

                             

                            Power should be easy to check if you have a powered USB hub, insert it between the system and the keyboard. (does push the scan chan another level)

                            • 11. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
                              intel-za

                              Hi Doc_Silvercreek


                              I wish more people on other forums were as insightful and enquiring as yourself.


                              First of all I have now logged this case with Intel Support and have a case number, hopefully this gets the info through to the powers that be.


                              As for the Logitech Illuminated Keyboard. I have the original release which is now probably over 18 months old. This keyboard is straightforward and has no usb port built in for plugging in a flash disk. It's also plugged directly into the USB port at the back of the board, the port directly above the optical line out of the sound card, same place it's been plugged in since I bought it. I don't have any USB hubs whatsoever, gave up using them several years ago as they just cause problems.


                              It could well be BIOS 5506 that broke it in the first place with the "Fixed issue where enabling UEFI causes all USB ports to stop working."

                               

                              As far as I know it's a USB 2.0 keyboard and I too have seen others complaining about this very same keyboard with BIOS releases on other boards.


                              Right now I'm hoping my case will get to the right person and hoping to see a new BIOS release soon which fixes this.


                              Other than that I am sticking with 5529 for now as I don't really like downgrading BIOS, I'm using another USB keyboard I have but I do miss my illuminated keyboard.


                              I'll keep you posted if I hear anything back from support. So far 2 days since I completed their form.

                               


                              • 12. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST
                                Doc_SilverCreek

                                That is the right thing to do!

                                 

                                Keep us posted.

                                 

                                (Support may also be a little slow this week. A bunch of them are based out of China and this is the Chinese New Years,)

                                • 13. Re: DX58SO (Bios - SOX5810J.86A) - USB Keyboard Fails to Work in BIOS / POST

                                  Hi,

                                  I just wanted to know if there is any new news about this specific board and its BIOS updates.

                                   

                                  My colleague has the board and he is also complaining about aging while his computer is starting up.

                                  He has not yet reloaded his Windows 7 64-Bit, and only wants to do that as a "last" resort. If the BIOS update will be the solution for him I would appreciate any comments, or any other suggestions.

                                   

                                  He did try to start his pc without having any extra usb hdd's plugged in, only mouse and keyboard were plugged in.

                                  • 14. Re: DX58SO (Bios - SOX5810J.86A) ver. 5506 - Bug Ridden BIOS Release

                                    I have the same exact problem, it was working good with my i7 940, but when i switched to my i7 970 i needed to upgrade my bios, so i did that but lost my keyboard (if i plug a no name keyboard or a dell usb keyboard, i don't have this problem). I tried all bios compatible with my cpu but none of them are working with my keyboard. I'd really like to go with an older bios but my processor is not supported. When in windows... no problem! Please intel make something!