1 Reply Latest reply on Jan 14, 2011 12:51 PM by bgmckown

    IamtTerm and Switchbox

    joliva

      Hello,

       

      We are developing an application integrated with Iamtterm.exe in order to give support to AMT computers. It works well now, but we would like to launch Iamtterm against a switchbox machine. Is it possible? We are trying to do it with the next command line and its doesn't work:

       

      iamtterm -h:192.168.1.100 -u:admin:73038 -p:password -t:title

       

      Thanks you very much.

        • 1. Re: IamtTerm and Switchbox
          bgmckown

          Unfortunately, since the date of this original post, the use of the Manageability Switchbox Tool from the overall Manageability Developer Toolkit has been removed in favor of the example Management Presence Server (MPS) provided within the Intel AMT SDK.

           

          However, if you (or anyone else) still has a copy of the Switchbox tool and are trying to use it with the Terminal tool, then there may be several reasons why you are unable to connect to the system under test.

          1. Verify that the IP address provided on the Terminal tool command line is that of the Switchbox system and that there isn't a firewall in place preventing a successful connection
          2. If you have configured the system under test to use TLS to secure incoming connections, then you would need to specify those settings on the command line for the Terminal tool.
          3. Ensure that the system running the Terminal tool ("console") has basic network connectivity to the system under test. Can you ping that system from the console? Can you view the WebUI of the Intel AMT device for that system (http(s)://<IP or hostname>:(16992 | 16993))?
          4. Have you verififed that the system has been provisioned with the SOL/IDER interfaces enabled? What authentication mechanism are they configured to use?
          5. Was the Switchbox tool (or MPS if using today's solution) setup to enable its own authentication/encryption? Have the other systems, console & system under test, been configured appropriately to account for this?

           

          Hope this helps.