2 Replies Latest reply on Dec 19, 2010 6:03 PM by zrkd51

    1080P Playback with GMA4500MHD

      Hi to everyone,
      I'm having a problems with Full HD videos, when I try to play them back, they take too much of my CPU, its perfomance is always around 100 %, but I've read, that shouldn't happen since my graphic card is powerful enough to process those videos, I also read , it's a problem of filters and renderers of video, but I'm not sure, how to get my GPU to work on that, since it looks kind of choppy, and it usually drops a lot of frames.

       

      My CPU is an Intel T2200 @ 2.2 GHz, not overclocked ,  and my GPU is Intel GMA 4500MHD, I'm using Windows 7 Home Premium 64 bits, and I tried to play back, with Media Player Classic and Windows Media Player, I'm actually using K-Lite Codec Pack. I got 3 GB of ram in my laptop.

       


      Any suggestion would be really helpful, thanks. (Sorry for my bad english, not native speaker)
      Thanks.

        • 1. Re: 1080P Playback with GMA4500MHD
          ghost011

          Hi,

          you should first identify the video codec of your movies: personally, I got remarkable benefits with MPEG-2 and H.264 while I'm still working on VC-1. Videos encoded in this format have frequent issues with hardware decoding.

           

          Anyway, you can check MediaPlayer Classic when playing any video: if you see "Playing [DXVA]" in the status bar, then the GMA is used for decoding and you should experience low CPU usage. Otherwise, something is not working.

           

          There many guides on the Web that show how to ensure DXVA (which is DirectX Video Acceleration, BTW) works properly, but they may be confusing at first. Instead, I would suggest you try the following:

           

          1) Reinstall the lastest version of the K-Lite Codec Pack. During setup (Advanced Mode),  there should be screen asking you whether to enable DXVA or not. Check at least the first option (for H.264).

           

          If it still doesn't work:

           

          2)  Open MPC, then File->Options. Select the "Internal Filters" item on the left and UNcheck all checkboxes on the right with DXVA in their name. Then select "External Filters" (on the left) and add the following filters (with the proper button):

           

          Microsoft DTV-DVD Video Decoder

          Microsoft DTV-DVD Audio Decoder

           

          Make sure these ones are on the top of the list (if any other item appers) and select the "Prefer" option for both them. Then save and restart MPC.

           

          This worked fine for me, at least for most videos.

           

          Hope this helps.

           

          P.S.

          Since you're running on a x64 version of Windows, you can also try MPC x64. It performs slightly better on my machine, which has a similar configuration as yours.

          s
          • 2. Re: 1080P Playback with GMA4500MHD

            I went directly to step 2, since I tried step 1 before, it's working all right now, thanks for the advice, really useful.