2 Replies Latest reply on Dec 18, 2010 6:17 AM by Lewan

    Problem with installing Intel Corporation 82598EB 10-Gigabit AF Dual Port Network Connection drivers on Linux

      Hi,

       

      I've just recived few new computers with Intel Corporation 82598EB 10-Gigabit AF Dual Port Network Connection card on board. I installed Ubuntu server with kernel 2.6.35.

       

      The problem is when I put SFP+ modules into ethernet card. It is generating this error in kernel logs:

       

      Dec 15 12:19:26 k6 kernel: [678403.215565] Intel(R) 10 Gigabit PCI Express Network Driver - version 3.1.15-NAPI
      Dec 15 12:19:26 k6 kernel: [678403.215568] Copyright (c) 1999-2010 Intel Corporation.
      Dec 15 12:19:26 k6 kernel: [678403.215603] ixgbe 0000:23:00.0: PCI INT A -> GSI 56 (level, low) -> IRQ 56
      Dec 15 12:19:26 k6 kernel: [678403.215624] ixgbe 0000:23:00.0: setting latency timer to 64
      Dec 15 12:19:26 k6 kernel: [678403.340893] ixgbe: 0000:23:00.0: ixgbe_probe: failed to load because an unsupported SFP+ module type was detected.
      Dec 15 12:19:26 k6 kernel: [678403.340896] Reload the driver after installing a supported module.
      Dec 15 12:19:26 k6 kernel: [678403.341000] ixgbe 0000:23:00.0: PCI INT A disabled

       

      I've tried build in ixgbe kernel driver which has 2.0.62-k2 version, and after this I've also tried 3.0.12 and 3.1.15 driver version from Intel site. And on all drivers I get the same error.

       

      I have two kind of SFP+ modules: AFBR-703SDZ-IN2 and FTLX8571D3BCV-IT. Both of them gives the same error. In drivers README file (http://downloadmirror.intel.com/14687/eng/README.txt) those modules are listed as supported in 82599-based devices, but I have 82598 and there is only written that it only supports original modules. But as I bought it from Dell I guess they are original and they have Intel logo on them. I've tried to conntact Dell support but after few hours they just told me that they can't help me and that I bought those computers without OS, so they don't have to help

       

      So am I doing something wrong?

       

      When etherned card is without SFP+ modules I see interfaces eth1 and eth2, so I guess that this device is supported, but as I plugin SFP+ module it just dissapears. Restarting doesn't help - still the same error.