5 Replies Latest reply on Nov 4, 2011 3:53 PM by atripathy86

    sccBmc errors

    hamur

      Hi,

       

      I'm getting the following error at the end of the training run (sccBmc -i) both from the command line and sccGui:

       

      ERROR: Training unsuccessful: Too small optimal data eye: optimal delay setting is 001 in a 006 wide range, select slower/different SIF phy operation speed ***
      ERROR: Failed to trim SIF! Please try to reload the driver or powercycle SCC board in case of repeated failure!

       

      I tried powercycling the SCC according to the instructions provided and reloading the driver after the failure, but no difference. Both the fast and extended training runs fail before the full training and the final failure. I'm running version 1.3.0 of the firmware.

       

      The driver loads fine according to dmesg:

      [   12.697324] mcedev Id: $Id: mcedev_main.c 16545 2010-06-08 14:25:34Z jbrummer $
      [   12.697347] mcedev_probe found device: VID 0x8086, DID 0xc148, SVID 0x8086, SDID 0xc048, BUS 0x04, DEVFN 0x00.0
      [   12.697364] mcedev 0000:04:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
      [   12.697366] crbif_init: $Id: crbif_main.c 16585 2010-08-24 14:35:55Z jbrummer $ (debuglevel 0000)
      [   12.697368] rckcrb_init: Checking and disabling ASPM on root port 8086:340e (00:07.00) for rckcrb device
      [   12.697373]     Found PCIe Capability structure @ 0x90
      [   12.697375]     Link Control Reg @ 0xa0: 0x30410001, setting to 0x30410000
      [   12.697378]     Link Control Reg @ 0xa0 changed to: 0x30410000
      [   12.697387] mcedev 0000:04:00.0: setting latency timer to 64
      [   12.697468] rckcrb_init: BITSID: 0x20100608
      [   12.697480] MIP/MOP size: 64/64KB (13)
      [   12.697555]   alloc irq_desc for 34 on node -1
      [   12.697556]   alloc kstat_irqs on node -1
      [   12.697565] mcedev 0000:04:00.0: irq 34 for MSI/MSI-X
      [   12.697571] IRQ 34/crbif: IRQF_DISABLED is not guaranteed on shared IRQs

       

      The full training log is available at: http://dl.dropbox.com/u/8103741/training_error.log

      Dump of lspci -vvv: http://dl.dropbox.com/u/8103741/lspci_dump.txt

       

      Any ideas what the problem could be?

       

      Thanks,

      Hrishi

        • 1. Re: sccBmc errors
          hamur

          The problem was fixed by moving the PCIe expansion card from an x16 to an x4 slot.

           

          Thanks,

          Hrishi

          • 2. Re: sccBmc errors
            tedk

            This is interesting. We have data that says

             

            "The firmware should be the latest version … version 2010.06.21. The PCIe interface card should be in the PCIe 16x slot, and configured for 'PCIe Generation 2' mode"

             

            which contradicts what you just found.

            • 3. Re: sccBmc errors
              hamur

              That is interesting. I assume you're talking about the BIOS firmware, but I wasn't able to find a version dated 2010.06.21. The latest BIOS update is version 5506 dated 11/9/2010 whereas the one that we have on the MCPC is version 5200 dated 4/14/2010. Should that be updated? Regarding the SCC firmware we have version 1.3.0.

              • 4. Re: sccBmc errors
                atripathy86

                Hi,

                 

                We are getting the exact same error. Should we try moving the PCIe expansion card from an x16 to an x4 slot or is there some other way to try fix it? We have our own MCPC. Like Hrishi, we tried power cycling the SCC and reloading the driver. Nothing seems to work. What should we do?

                 

                Thanks

                • 5. Re: sccBmc errors
                  atripathy86

                  Actually, we were able to figure it out. (Yet) another power cycle and reinstall of the firmware seems to have fixed the problem (for now). I do not think we have located the root cause of the problem.