1 2 3 Previous Next 38 Replies Latest reply on Jan 7, 2011 10:01 AM by Infocus

    Need Latest 02M3 Firmware for X-25-M 80GB

      I get an error from the SSD Optimizer in the Intel SSD Toolbox to update my drive's firmware; the utility will not run. It says I have the old firmware and informs me I need to update (the drive's firmware).

       

      Intel Product Change Notification number 110343-00, dated December 3, 2010, tells me that the current firmware (for this drive) is version 02M3, not the version 02HD as is in the ISO update on the Intel site and is noted at the latest version of the firmware (110902HD88208850.iso).

       

      The Intel SSD Toolbox "View Drive Information" confirms the firmware is version: 2CV102HD.

       

      The disk created from the ISO file also confirms the firmware is version 02HD and will not update the SSD drive.

       

      I need to update the firmware to version 02M3 to allow the SSD Optimizer to run.

       

      I am running XP media Center Edition with all the latest patches and upgrades. No other problems with the drive or OS.

       

      Please help.

       

      Thanks!

        • 1. Re: Need Latest 02M3 Firmware for X-25-M 80GB
          parsec

          First, I am surprised, where did you get this "Intel Product Change Notification number 110343-00, dated December 3, 2010" document or message, or what?

           

          That would have been huge news in the Intel SSD community here in the forum, yet there has been no discussion of it.

           

          A new Firmware, 02M3?  None of the Moderators have mentioned this, period.  Do you have a G1 or G2 SSD?   New firmware for Intel SSD's would have been front page news!

           

          I searched for that product change you provided, but can't find it, although that does not mean it's not there.

           

          If this new firmware exists, it is a Royal, Deluxe, nee-Plus Ultra, fubar-faux pas-snafu on the part of the Moderators, or Intel not informing the Moderators!!

           

          Please provide us with some more information on this Product Change.  How or where did you get it?  Can you provide a link to it?

           

          What version of the Intel SSD Toolbox do you have?

           

          I ran the optimizer on my Intel 80GB SSD five minutes ago, and I had no problem whatsoever, but that is on Windows 7.

           

          I am baffled by this... are you serious???

          • 2. Re: Need Latest 02M3 Firmware for X-25-M 80GB
            redux

            Intel Product Change Notification number 110343-00, dated December 3, 2010

            Forecasted Key Milestones: Date Customer Must be Ready to Receive Post-Conversion Material: Jan 03, 2011

             

             

            Description of Change to the Customer:

            Intel is upgrading the firmware for its High Performance Solid-State MLC Drives (X25-M/X18-M) from 02HD to version 02M3. These changes are incremental improvements from previous firmware version. Inventory will transition in the Intel factory on or beyond the above date to replace older firmware version with the new 02M3 firmware.

             

            The changes to the TA and SA numbers are shown in the table below.

             

            Please contact your Field Sales Personnel for Errata Report

            • 3. Re: Need Latest 02M3 Firmware for X-25-M 80GB

              The "Product Change Notification" was on Intel's WWW site.

               

              Will this new firmware help me? Do you have an interim fix or patch for this problem?

               

              Please help!

              • 4. Re: Need Latest 02M3 Firmware for X-25-M 80GB
                Ozz

                Which version of the SSD Toolbox are you using?

                • 5. Re: Need Latest 02M3 Firmware for X-25-M 80GB

                  I am using the latest version of Toolbox downloaded a couple of days ago. It is version 2.0.1.000.

                   

                  All of the Intel software was downloaded from Intel within the last week, as per the insert in the box the drive came in.

                   

                  The drive version is G11143-100, product code SSDSA2MH080G2K5.

                   

                  What about Intel e-mailing me the new firmware update so I can have a properly working drive.

                   

                  Thanks

                  • 6. Re: Need Latest 02M3 Firmware for X-25-M 80GB
                    Ozz

                    Personally, I would try uninstalling 2.0.1 and install version 1.3. The new firmware would be much more of a risk than something like the above. Version 1.3 is pretty well tried and tested.

                     

                    Whilst trying to find an official 1.3 link, I came across this thread in which someone was also having trouble running TRIM with version 2.x:

                     

                    http://hardforum.com/showthread.php?t=1554628

                     

                     

                    Also, the link contained within (mediafire) has a 'trusted' copy, hashed it against my archive (SHA1: BF1B1BCFFBB820CBBB4E548FB0C0A9072F9E7CD4)

                    • 7. Re: Need Latest 02M3 Firmware for X-25-M 80GB

                      Ozz:

                       

                      I removed the installed version and put in the older version you recommended. No difference, same error regarding the needed firmware update.

                      • 8. Re: Need Latest 02M3 Firmware for X-25-M 80GB
                        parsec

                        Ok... and I reiterate... why no mention of this?

                         

                        So this is ho-hum, yawn, who cares news?

                         

                        Why wouldn't this be posted in the SSD discussion area?  Ten days after release I hear about this from a random person? (no offense Barbara, that was your first post in the Intel forums.  BTW, Thank You!!!)

                         

                        I searched on the Intel site, and a general Internet search, both nothing.  Still can't find it to save my life... product support page, Download Center, keyword search, zip!!

                         

                        There's a lesson in this for me...

                         

                        Message was edited by: parsec

                         

                        Message was edited by: parsec

                        • 9. Re: Need Latest 02M3 Firmware for X-25-M 80GB
                          redux

                          Intel moves in mysterious ways…or is it works in mysterious ways, I can't remember.

                           

                          The Product Change Notification is (I think) intended for Intel channel partners only, not the public, as it gives advanced information.

                           

                          I only found it via a Google search for "Intel Product Change Notification number 110343-00"

                           

                          Nothing slips out on this forum ahead of a public announcement, which usually arrives indirectly via the likes of Anandtech

                          • 10. Re: Need Latest 02M3 Firmware for X-25-M 80GB
                            parsec

                            Ok, got it.

                             

                            Thanks redux, and I signed up for the QDMS DB thing, so I found the document.  Yeah, isn't that funny that old Anand gets this info, but perhaps from the same source, the QDMS system.  I really need to chill out when I read some of these posts, I take everything so literally.  A bad side-effect of my days as a programmer, everything is black and white, and I take information in as verbatim.  Anyway...

                             

                            Seems that at this time the new firmware has not been released to the general public.  Given that it is an incremental change and not a bug fix, I guess it is not big news, so I stand corrected, my apologies.

                             

                            Barbara, if you don't realize this by now, the firmware is not what is causing your problem, it is something else.  As I have been in a frenzy trying to find the change document, I have not studied the latest posts on your thread.  TTFN.

                             

                            Message was edited by: parsec

                            • 11. Re: Need Latest 02M3 Firmware for X-25-M 80GB
                              parsec

                              At least my eye for detail is worth something at times...  From the Product Change Notification document:

                               

                              Date Customer Must be Ready to Receive Post-Conversion Material:     Jan 03, 2011

                               

                              Perhaps, maybe, possibly, this means the firmware will be available at that time?

                               

                              Again, my apologies to the Moderators and Intel. 

                              • 12. Re: Need Latest 02M3 Firmware for X-25-M 80GB

                                -would this update be for the new 120 gb also ,have two on my desk for install on the weekend in raid 0 ,I asume when this comes out I'll need to breck up raid to update the firm ware ?and clone a image.

                                • 13. Re: Need Latest 02M3 Firmware for X-25-M 80GB

                                  I will throw this out to people who know more than I do:

                                   

                                  I found Registry Mechanic has a "Bleach Disk" utility that essentially will delete files that are marked as free space from the hard drive.

                                   

                                  As I recall from hexadecimal disk editors, these "deleted" files have the first file name character replaced by a symbol that looks like a lower case zero with a tail on the right side. I imagine these are the files the Registry Mechanic utility is looking for.

                                   

                                  From my readings, this just may do the same thing as the “trim” function in the Intel SSD Toolbox.

                                   

                                  I ran the “Bleach Disk” twice on the SSD with no apparent ill effects.

                                   

                                  I welcome all comments and suggestions.

                                   

                                  Thanks!

                                  • 14. Re: Need Latest 02M3 Firmware for X-25-M 80GB
                                    parsec

                                    Barbara,

                                     

                                    The version of the SSD Toolbox that you have (had) 2.0.1, is the same as most Intel SSD owners have, including myself.  I am not experiencing the problem you have described, and (fortunately) there has not been a flood of complaints regarding this version of the Toolbox, so we could conclude that your problem, although real and annoying, is an isolated incident, unless we hear otherwise.

                                     

                                    The release of Toolbox 2.0.1 predates the 02M3 firmware, that is not even available yet.  The 2CV102HD firmware was the current production firmware used on the Intel G2 drives, until very recently, and was also provided as an update for Intel SSD's that had an earlier, different firmware. I'm not sure of the firmware version used in Intel G1 SSD's, but the only firmware update available for quite some time is the 2CV102HD version.  There has not been a long history of firmware updates, and as far as I know, only the 2CV102HD version was made available to the public as an update.

                                     

                                    The problem in your case, is that for some reason, the Optimizer portion of the Toolbox is not seeing the firmware on your SSD as the latest version, 2CV102HD (latest until 02M3 is released), while the SMART attributes section shows your firmware to be '02HD.  I truly do not think it is possible that the Toolbox is telling you update to the 02M3 firmware.  While software is sophisticated, it is not truly intelligent, and is utterly unaware IMO that the 02M3 firmware exists.  Frankly, I predict that with the release to the public, if ever, of the 02M3 firmware, a new version of the Toolbox will be released that is aware of the 02M3 firmware.  Actually, that is a given for the Toolbox to work with the new firmware.

                                     

                                    When you get the message saying you need to update the firmware, does that message reference "02M3" firmware?  I would think it does not.  Given that, your assumption that you need the 02M3 firmware is reasonable, but is not the actual situation.

                                     

                                    Have you tried uninstalling the Toolbox, downloading it again and reinstalling?  If not, I would highly recommend that you do.  The Toolbox manual does not specify any problems when using Windows XP, so we can't immediately say that might be the problem as well.  Is this the first time you have been using the Toolbox, just recently?

                                     

                                    Regarding the Bleach Disk utility you tried, there is more to the TRIM function than overwriting files, I would not assume that you are getting the same result with that utility as you would with TRIM.  Frankly, I can guarantee it.

                                    1 2 3 Previous Next