This discussion is locked
2 Replies Latest reply: Mar 2, 2011 4:07 PM by MARK HANNA RSS

Urgent: how to force speed/duplex on Intel gagibit network adapter?

Community Member
Currently Being Moderated

Hi,

 

I have worked on this issue a while and tried to find a solution. We set up test bench with 3 HP Desktops (HP Z200 Workstation in Windows XP Pro). Each HP station has a on-board NIC (Intel 82578 Gigabit network adapter) and also was installed 2 Intel Gigabit ET Quad network adapters (it is not PCI device, but is PCIe interface). All these Ethernet ports connected to a Ethernet switch board that contained 16 10/100 Ethernet ports. We run our test program that first set the speed/duplex to 10/Half duplex on each adapters and then PING from one port to other ports by the static IP addresses on each workstation. and so on so for setting to 10/Full, 100/Half and 100/FUll.

 

The problem is that the Intel utility toos SetSpeed.exe does not work on these Intel gigabit network adapter anymore. This utility software was working on Intel PRO100 adapter, but it does not work on current gigabit network adapter, which could not force speed/duplex settings. I've searched Internet so far and could not find an answer how to force speed/duplex in Windows XP Pro station with Intel gigabit network adapter.

 

I found 2 articls related to this from Intel website. One suggested to use ProSet utility script file, example  "cscript Adapter_Enumerate.vbs 1 speedDuplex 3" which he said it is under \Program files\Intel|NCS2\Scripts, but I could not find it. I installed ProSet version 15.7 that is one last updated version. Another one suggested to use IBAUTIL.exe to force the speed/duplex. I downloaded the last version Preboot.exe file and have not tried, because I am not familiar with this utility tool.

 

I hope specilists here to provide some kinds of information regarding this force speed/duplex issue.

 

P.S. Don't tell me use setspeed to set the speed/duplex and then reboot driver, because I knew this that I used devcon.exe to force the devices disable and re-enable. But it did not work on Intel Gigabit network adapters.

 

Thanks -Bill

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points